Mint 17.2 loses wifi connection after suspend

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
renatexox
Level 1
Level 1
Posts: 1
Joined: Mon Nov 06, 2017 9:57 pm

Mint 17.2 loses wifi connection after suspend

Postby renatexox » Sun Nov 12, 2017 10:29 pm

My wifi works perfectly fine, until I suspend my laptop; upon reopening the laptop, my wifi will be disconnected, and my network manager will say "unavailable". It won't allow me to turn it back on, but if I reboot, it will work perfectly again. I have already scoured a few forums, and attempted the following:

1:

Code: Select all

sudo gedit /etc/pm/config.d/config

then type " SUSPEND_MODULES="iwlwifi" ", save, and close gedit.

2:

Code: Select all

nmcli nm sleep false


3:

Code: Select all

sudo restart network-manager


4:

Code: Select all

sudo service network-manager restart


5: The following 3 commands;

Code: Select all

sudo touch /etc/pm/sleep.d/wakenet.sh
sudo chmod +x /etc/pm/sleep.d/wakenet.sh
sudo gedit /etc/pm/sleep.d/wakenet.sh


Then paste the following into gedit:
#!/bin/bash
case "$1" in
thaw|resume)
nmcli nm sleep false
pkill -f wpa_supplicant
;;
*)
;;
esac
exit $?

Save, and reboot; none of these have worked. I am completely new to terminal commands. Please help?

Code: Select all

~ $ inxi -Fxz
System:    Host: renate-HP-Pavilion-15-Notebook-PC Kernel: 3.16.0-38-generic x86_64 (64 bit, gcc: 4.8.2)
           Desktop: Cinnamon 2.6.13  Distro: Linux Mint 17.2 Rafaela
Machine:   System: Hewlett-Packard product: HP Pavilion 15 Notebook PC version: 096C120014405F10000620182
           Mobo: Hewlett-Packard model: 2293 version: 78.21 Bios: Insyde version: F.36 date: 02/02/2015
CPU:       Dual core Intel Core i5-5200U CPU (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8779.6
           Clock Speeds: 1: 2390.867 MHz 2: 2200.00 MHz 3: 2200.257 MHz 4: 2368.609 MHz
Graphics:  Card: Intel Broadwell-U Integrated Graphics bus-ID: 00:02.0
           X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz
           GLX Renderer: Mesa DRI Intel Broadwell GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
Audio:     Card-1: Intel Wildcat Point-LP High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2: Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture ver: k3.16.0-38-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 ver: 2.3LK-NAPI port: 3000 bus-ID: 09:00.0
           IF: eth0 state: down mac: <filter>
           Card-2: Intel Wireless 3160 driver: iwlwifi ver: in-tree: bus-ID: 08:00.0
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 1000.2GB (5.3% used) 1: id: /dev/sda model: ST1000LM024_HN size: 1000.2GB
Partition: ID: / size: 427G used: 49G (13%) fs: ext4 ID: swap-1 size: 4.10GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 37.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 193 Uptime: 11 min Memory: 658.5/11939.2MB Runlevel: 2 Gcc sys: 4.8.4
           Client: Shell (bash 4.3.11) inxi: 1.9.17


Last bumped by renatexox on Sun Nov 12, 2017 10:29 pm.

Return to “Wireless”