[SOLVED] Losing wifi and slow wifi with rtl8188ee

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
letouane
Level 1
Level 1
Posts: 2
Joined: Fri Nov 10, 2017 5:44 am

[SOLVED] Losing wifi and slow wifi with rtl8188ee

Postby letouane » Fri Nov 10, 2017 6:36 am

Hello everyone,

As a beginner, I'll try to provide the max informations that I'm capable of. My system is installed in French so, sorry if command results are not in English.

My problem :
1 - Frequently, my wifi connection seems to be disconnected but the tray icon show that connection is ok even to connect on local devices such as my router when writing this post (Shutting down then up the wifi antenna with [fn+f12] key restores the connection).
2 - My wifi performance is awful, when I copy files from my NAS Synology in my LAN the speed remains between 2 and 3 Mbps.
3 - Sometimes, the bars displayed to show he quality of Rx seemss to be very low but I stay close to the router.

Information that can be usefull :
System :
I use Linux Mint 17.2 Cinnamon 64 on a HP Laptop 15-n072sf as my only operating system on this computer.

Wifi adapter :

Code: Select all

lsusb
Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 0bda:571a Realtek Semiconductor Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Code: Select all

lshw -C network
ATTENTION: ce programme devrait être lancé en tant que super-utilisateur.
  *-network               
       description: Interface réseau sans fil
       produit: RTL8188EE Wireless Network Adapter
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:08:00.0
       nom logique: wlan0
       version: 01
       numéro de série: [MY MAC ADDRESS HERE]
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8188ee driverversion=3.16.0-38-generic firmware=N/A ip=192.168.1.239 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       ressources: irq:18 portE/S:5000(taille=256) mémoire:b5500000-b5503fff

Code: Select all

modinfo rtl8188ee
filename:       /lib/modules/3.16.0-38-generic/kernel/drivers/net/wireless/rtlwifi/rtl8188ee/rtl8188ee.ko
firmware:       rtlwifi/rtl8188efw.bin
description:    Realtek 8188E 802.11n PCI wireless
license:        GPL
author:         Larry Finger   <Larry.Finger@lwfinger.net>
author:         Realtek WlanFAE   <wlanfae@realtek.com>
author:         zhiyuan_yang   <zhiyuan_yang@realsil.com.cn>
srcversion:     83E9F79B1C7C341263B448E
alias:          pci:v000010ECd00008179sv*sd*bc*sc*i*
depends:        rtlwifi,rtl_pci,mac80211
intree:         Y
vermagic:       3.16.0-38-generic SMP mod_unload modversions
signer:         Magrathea: Glacier signing key
sig_key:        C2:84:ED:AC:CF:0B:47:36:52:C3:4D:23:BE:C3:56:94:42:36:E6:3B
sig_hashalgo:   sha512
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)

Code: Select all

iwconfig
eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"ManaBOX8AA311" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: [THE MAC ADDRESS OF MY ISP ROUTER] 
          Bit Rate=65 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-8 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:64   Missed beacon:0

lo        no wireless extensions.

Configuration as seen on my router (translated by myself) :

Code: Select all

Interface type:   802.11b/g/n
Real speed [Mbps]:   65
Band:   2.4GHz
Channel selection:   Auto
Canal:   11
Security mode:   WPA-PSK
WPA-PSK Encryption:   TKIP&AES
Version WPA-PSK:   WPA&WPA2


Results from the internet :
I found this thread https://forums.linuxmint.com/viewtopic.php?t=204884 on the current forum that bring me to this page https://sites.google.com/site/easylinuxtipsproject/reserve-7 where I saw :
Wireless Realtek chipsets that are running on the default rtl8192cu driver, often lose connection and run below their proper speed. That's because of a bug in the rtl8192cu driver.

But according to me, my system rely on those chipsets but on the rtl8188ee and I don't know if I can apply the same recipe that was provided by Pjotr at https://forums.linuxmint.com/viewtopic.php?t=204884#p1065376.

Can someone please help me ?

PS : As a joke, during the time i wrote this message, my wifi failed 3 times :-S
Last edited by letouane on Sat Nov 11, 2017 6:11 am, edited 1 time in total.

User avatar
Pjotr
Level 18
Level 18
Posts: 8860
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Losing wifi and slow wifi with rtl8188ee

Postby Pjotr » Fri Nov 10, 2017 7:16 am

First upgrade to the latest kernel of the 4.4 series:
Update Manager - panel: View - Linux kernels

Reboot after installing it.

Then install the rtlwifi_new driver from lwfinger:
https://sites.google.com/site/easylinux ... m-lwfinger
(item 9, right column)

If that's not sufficient: install all level 4 and 5 updates that were previously withheld. Afterwards, reboot again.
Tip: 10 things to do after installing Linux Mint 18.2 Sonya
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

letouane
Level 1
Level 1
Posts: 2
Joined: Fri Nov 10, 2017 5:44 am

Re: Losing wifi and slow wifi with rtl8188ee

Postby letouane » Sat Nov 11, 2017 6:10 am

Hello Pjotr,

I did all the steps and I haven't got the problem since. I'm confident it will work.
Many thanks for your answer, your time and your work.


Return to “Wireless”