System mini freeze / stutter when wifi is enabled

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Mon Nov 13, 2017 3:22 am

System mini freeze / stutter when wifi is enabled

Post by BrotherSanguin » Thu Nov 16, 2017 7:52 am

Hello everyone, i am new around here.
I Installed Mint about 2 months ago on my new Laptop (ASUS Zenbook UX3410UA-GV215T) and was surprised how well it went and how well the hardware was supported. Even the keyboard lights work.
Some time later i noticed the whole system freezes regularly whenever the WIFI is enabled(in MINT, no hardware switch present). Since i installed some kernel-updates i thought i had made a mistake somewhere and reinstalled the whole system, but to no effect. Freezes are still there.
Every about 10 Sec the system stands still. If i write the Editor does not show what i am writing until the freeze passes about 1-2 seconds later.
It is even more disturbing when watching a Movie. The Image freezes, but the sound continues uninterrupted. I tried with xplayer and vlc.
If WIFI is turned off, the problem is not present at all. So i currently use a USB-Ethernet adapter to connect to my network.
I also tried connecting an external WIFI-Adapter but that did not help either. But i did notice that if i turn WIFI on i can switch On and Off the interfaces independently. The problem however persists EVEN IF NO INTERFACE IS SWITCHED ON. :shock:
At first i thought it could be an issue with the WIFI-Driver/Module of the internal wifi hardware, but now i am not sure anymore.

Of course i searched for similar issues before posting found 2 issues that had similar symptoms but had nothing to do with WIFI and did not freeze /stutter system-wide.
I am not so familiar with linux yet, that i could track down the problem on my own, so i hope some kind soul can help me out.
If it helps here is my System Info(inxi -Fxz):

Code: Select all

System:    Host: xxxxxx Kernel: 4.10.0-37-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   System: ASUSTeK (portable) product: UX410UAK v: 1.0
           Mobo: ASUSTeK model: UX410UAK v: 1.0
           Bios: American Megatrends v: UX410UAK.304 date: 06/08/2017
CPU:       Dual core Intel Core i7-7500U (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11616
           clock speeds: max: 3500 MHz 1: 658 MHz 2: 613 MHz 3: 666 MHz
           4: 687 MHz
Graphics:  Card: Intel Device 5916 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.01hz
           GLX Renderer: Mesa DRI Intel HD Graphics 620 (Kabylake GT2)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.10.0-37-generic
Network:   Card: Intel Wireless 8260 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 256.1GB (52.7% used)
           ID-1: /dev/sda model: Micron_1100_MTFD size: 256.1GB
Partition: ID-1: / size: 227G used: 119G (56%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 8.47GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 28.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 223 Uptime: 50 min Memory: 2285.7/7865.2MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
Edit: For the sake of helping any one else having this problem. The last batch of Package updates seems to have solved the Problem. Since I do not know what was the cause of the Problem in the first place, i can not say with any certainty which Package update fixed it. If I had to guess, I would bet on the Kernel update, assuming the Issue was caused by a Kernel-Module. Sys Info:

Code: Select all

System:    Host: xxxxxx Kernel: 4.13.0-26-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia

Considering no one replied anything to this, i will look for help elsewhere, should I run into anything like this again.
Last edited by BrotherSanguin on Fri Jan 26, 2018 3:15 am, edited 1 time in total.

Level 1
Level 1
Posts: 2
Joined: Mon Nov 13, 2017 3:22 am

Re: System mini freeze / stutter when wifi is enabled

Post by BrotherSanguin » Thu Dec 07, 2017 5:41 am

Updated to the latest Mint-Release 18.3. Problem still persists. Is my Problem so specific that no one can help? Or am I in the wrong place to ask? If so please point me in the right direction please.

Post Reply

Return to “Wireless”