Bluetooth is working but Wifi is not

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
beegee
Level 1
Level 1
Posts: 2
Joined: Tue Nov 14, 2017 3:40 pm

Bluetooth is working but Wifi is not

Post by beegee » Tue Nov 14, 2017 4:03 pm

Hi,
I installed Linux Mint 18.2 Cinnamon 64 bit in my HP 15q BU004TU. It's wireless device specification is : 802.11b/g/n (1x1) and Bluetooth 4.0 combo
Unfortunately I am not able to get the driver for this in Sonya.

Seems Bluetooth is working but wifi is not working

$ iwconfig wlan0
wlan0 No such device

$ iwconfig
lo no wireless extensions.

eno1 no wireless extensions.

$ rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

Is anything could be done to make wifi working in mint

Thanks in advance

Regards

User avatar
karlchen
Level 19
Level 19
Posts: 9429
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Bluetooth is working but Wifi is not

Post by karlchen » Tue Nov 14, 2017 4:23 pm

Hi, beegee.

Please, post the terminal output generated by the command

Code: Select all

inxi -Fxz
This will give us a concise overview on your system specification. It will also give us some basic information on what Mint "thinks about" your wifi interface.

Best regards,
Karl
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

beegee
Level 1
Level 1
Posts: 2
Joined: Tue Nov 14, 2017 3:40 pm

Re: Bluetooth is working but Wifi is not

Post by beegee » Wed Nov 15, 2017 10:42 pm

[*]
Hi Karl,

Please find the output:

System: Host: MyHP Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.2 Sonya
Machine: System: HP product: HP Laptop 15q-bu0xx v: Type1ProductConfigId
Mobo: HP model: 8328 v: 23.37 Bios: Insyde v: F.21 date: 07/04/2017
CPU: Dual core Intel Core i3-6006U (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7968
clock speeds: max: 2000 MHz 1: 1360 MHz 2: 1086 MHz 3: 1912 MHz
4: 857 MHz
Graphics: Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@60.02hz
GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio: Card Intel Sunrise Point-LP HD Audio
driver: snd_hda_intel bus-ID: 00:1f.3
Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 01:00.0
IF: eno1 state: down mac: <filter>
Card-2: Realtek Device d723 port: 3000 bus-ID: 02:00.0
IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
Drives: HDD Total Size: 1000.2GB (5.8% used)
ID-1: /dev/sda model: WDC_WD10JPVX size: 1000.2GB
Partition: ID-1: / size: 184G used: 5.6G (4%) fs: ext4 dev: /dev/sda5
ID-2: swap-1 size: 8.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 38.0C mobo: 29.8C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 201 Uptime: 1 min Memory: 538.3/3867.0MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

Thanks and Regards

Post Reply

Return to “Wireless”