Slow WIFI connection in Linux Mint

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
ObiKenobiXD
Level 1
Level 1
Posts: 4
Joined: Tue Nov 21, 2017 4:17 pm

Slow WIFI connection in Linux Mint

Postby ObiKenobiXD » Tue Nov 21, 2017 4:45 pm

Hi, I recently installed Linux Mint in my desktop pc. I have a tp-link wifi adapter TL-WN8200ND.
I have dual Boot with windows 10, In windows internet works fine, but in mint works too slow.
I think it is some kind of problem with the modem because I tried connecting to my smartphone shared internet and It works fine!.

Any help?

User avatar
Pjotr
Level 19
Level 19
Posts: 9012
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Slow WIFI connection in Linux Mint

Postby Pjotr » Tue Nov 21, 2017 4:50 pm

a. Please generate an overview of your system like this:
- Launch a terminal window (this is how to launch a terminal window);
- make the terminal window full screen, to avoid chopped lines;
- Copy/paste this command into the terminal:

Code: Select all

inxi -Fxz

(if you type: the letter F is a capital letter)

Press Enter.

Copy/paste the output in your next message.

b. Do the same with the following four commands:

Code: Select all

rfkill list all

and:

Code: Select all

iwconfig

and:

Code: Select all

inxi -Nn

and:

Code: Select all

lsusb
Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

ObiKenobiXD
Level 1
Level 1
Posts: 4
Joined: Tue Nov 21, 2017 4:17 pm

Re: Slow WIFI connection in Linux Mint

Postby ObiKenobiXD » Tue Nov 21, 2017 5:08 pm

inxi -Fxz:

System: Host: juan Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.2 Sonya
Machine: System: ASUS product: All Series
Mobo: ASUSTeK model: Z97-P v: Rev X.0x Bios: American Megatrends v: 2202 date: 07/11/2014
CPU: Quad core Intel Core i7-4790 (-HT-MCP-) cache: 8192 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28781
clock speeds: max: 4000 MHz 1: 3600 MHz 2: 3600 MHz 3: 3600 MHz 4: 3600 MHz 5: 3600 MHz 6: 3600 MHz
7: 3596 MHz 8: 3602 MHz
Graphics: Card: NVIDIA GM204 [GeForce GTX 970] bus-ID: 01:00.0
Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
GLX Renderer: GeForce GTX 970/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.90 Direct Rendering: Yes
Audio: Card-1 NVIDIA GM204 High Definition Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
Card-2 Intel 9 Series Family HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
IF: enp3s0 state: down mac: <filter>
Drives: HDD Total Size: 1250.3GB (0.6% used) ID-1: /dev/sda model: Samsung_SSD_840 size: 250.1GB
ID-2: /dev/sdb model: WDC_WD1003FZEX size: 1000.2GB
Partition: ID-1: / size: 138G used: 6.8G (6%) fs: ext4 dev: /dev/sdb2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:61C
Fan Speeds (in rpm): cpu: 0
Info: Processes: 253 Uptime: 1:27 Memory: 2005.0/15989.7MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35


rfkill list all -> No output



iwconfig:

lo no wireless extensions.

enp3s0 no wireless extensions.

wlx18a6f71ff142 IEEE 802.11bg ESSID:"Fibertel WiFi496" Nickname:"<WIFI@REALTEK>"
Mode:Managed Frequency:2.412 GHz Access Point: 70:7E:43:FE:7F:1F
Bit Rate:54 Mb/s Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality=100/100 Signal level=100/100 Noise level=0/100
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

inxi -Nn:

Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
IF: enp3s0 state: down mac: 54:a0:50:52:2f:32


lsusb:

Bus 002 Device 002: ID 8087:8001 Intel Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8009 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 1532:0202 Razer USA, Ltd
Bus 003 Device 002: ID 09da:3f9b A4Tech Co., Ltd.
Bus 003 Device 005: ID 2357:0100
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Return to “Wireless”