No Name Resolution

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
BeagleDog
Level 1
Level 1
Posts: 14
Joined: Wed Jun 01, 2016 2:05 pm

No Name Resolution

Post by BeagleDog » Sun Nov 26, 2017 4:00 pm

New 18.3 install.
WiFi is connected, but Net names are not resolved to IP addresses! (e.g, Firefox, lynx, ping).
Nameserver shown is 127.0.0.1, just like the 17.3 I am posting this from. I don't have a clue how to solve this problem.

BTW, why the "odd" interface names? What happened to good old wlan0?

User avatar
Spearmint2
Level 15
Level 15
Posts: 5734
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: No Name Resolution

Post by Spearmint2 » Sun Nov 26, 2017 4:35 pm

127.0.0.1 is "local host". Wifi will connect to the router, but it won't allow access until you've entered it, the SSID, the encryption method used (WEP, WPA, WPA2....), and the passphrase or hex.

what does this report?

Code: Select all

iwconfig
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

BeagleDog
Level 1
Level 1
Posts: 14
Joined: Wed Jun 01, 2016 2:05 pm

Re: No Name Resolution

Post by BeagleDog » Mon Nov 27, 2017 2:56 pm

Ooops! Two errors in my first post. It's Mint 18.2 (Sonya), not 18.3. Worse, the nameserver should have said '127.0.1.1', not '127.0.0.1'. Sorry for those time-wasting typos.
Both ifconfig and iwconfig show that WiFi is up and running normally.

User avatar
greerd
Level 5
Level 5
Posts: 986
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: No Name Resolution

Post by greerd » Mon Nov 27, 2017 3:33 pm

Hi BeagleDog,

As far as the 'odd' interface names goes, welcome to systemd and PredictableNetworkIntefaceNames

To your DNS problem, you probably had dnsmasq as a local forwarding nameserver in 17.3, see here for an explanation and fix.

Cheers

BeagleDog
Level 1
Level 1
Posts: 14
Joined: Wed Jun 01, 2016 2:05 pm

Re: No Name Resolution

Post by BeagleDog » Tue Nov 28, 2017 4:31 pm

That was a very interesting and (I hope) useful reply. I'm going to try it when I boot into 18.2 again.

The problem seems to involve a WiFi connection that is 'up', yet which does not appear to be capable of sending/receiving date at all! Eventually the WiFi link goes down. The problem appears at an unpredictable time after boot, and can be fixed only by rebooting. Thus, during the problem, here's what ifconfig and wconfig shows:
wlp4s0 IEEE 802.11 ESSID:"XXXX"
Mode:Managed Frequency:2.437 GHz Access Point: XXXXX
Bit Rate=12 Mb/s Tx-Power=30 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:on
Link Quality=60/70 Signal level=-50 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:1396 Invalid misc:168 Missed beacon:0

hlarons@hound:~$ ifconfig wlp4s0
wlp4s0 Link encap:Ethernet HWaddr 00:08:a1:b4:f9:3b
inet addr:172.16.8.51 Bcast:172.16.15.255 Mask:255.255.240.0
inet6 addr: fe80::a988:4813:e53c:ad6a/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1127345 errors:0 dropped:0 overruns:0 frame:0
TX packets:530007 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:973092522 (973.0 MB) TX bytes:47144384 (47.1 MB)
After the WiFi interface goes down, it just won't reconnect.

I'm about to give up on 18.2, but I'll try your fix with a static nameserver.

Thanks for listening.

User avatar
Spearmint2
Level 15
Level 15
Posts: 5734
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: No Name Resolution

Post by Spearmint2 » Tue Nov 28, 2017 4:36 pm

Code: Select all

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
There's your problem, which I told you above. You need to enter your network settings and give your wifi access to the router using SSID, the encryption method used, and the password or hex set. Plug a LAN cord into your router, go into it's wireless area, write down what you need, and then configure your networking on the computer.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

JeremyB
Level 19
Level 19
Posts: 9304
Joined: Fri Feb 21, 2014 8:17 am

Re: No Name Resolution

Post by JeremyB » Tue Nov 28, 2017 6:23 pm

I worry about the wifi power management being on in LM18 as it causes numerous issues, the fix is

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
systemctl restart network-manager.service
Or just reboot

BeagleDog
Level 1
Level 1
Posts: 14
Joined: Wed Jun 01, 2016 2:05 pm

Re: No Name Resolution

Post by BeagleDog » Wed Nov 29, 2017 3:26 pm

Spearmint2: Unfortunately I don't have access to the router.

Jeremy8: I just found that file; looks promising indeed. However, why wifi.powersave = 2? Why not wifi.powersave = 0?

JeremyB
Level 19
Level 19
Posts: 9304
Joined: Fri Feb 21, 2014 8:17 am

Re: No Name Resolution

Post by JeremyB » Wed Nov 29, 2017 5:48 pm

Because 2 is actually off, the source code shows

Code: Select all

typedef enum {
    NM_SETTING_WIRELESS_POWERSAVE_DEFAULT = 0,
    NM_SETTING_WIRELESS_POWERSAVE_IGNORE = 1,
    NM_SETTING_WIRELESS_POWERSAVE_DISABLE = 2,
    NM_SETTING_WIRELESS_POWERSAVE_ENABLE = 3,

BeagleDog
Level 1
Level 1
Posts: 14
Joined: Wed Jun 01, 2016 2:05 pm

Re: No Name Resolution

Post by BeagleDog » Thu Nov 30, 2017 3:03 pm

Wow! Imagine consulting the source code for the answer. :D

Clear and precise; I'm trying it now, so far so good.

Thanks for your insight.

BeagleDog
Level 1
Level 1
Posts: 14
Joined: Wed Jun 01, 2016 2:05 pm

Re: No Name Resolution [SOLVED]

Post by BeagleDog » Fri Dec 01, 2017 3:05 pm

Looks like this was a power management problem after all. Here's what I did for a fix:

1. Stopped WiFi power management by changing "wifi.powersave = 3" to "wifi.powersave = 2" in /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

2. Stopped dnsmasq by commenting out the line "dns = dnsmasq" in /etc/NetworkManager/NetworkManager.conf

3. Added static DN Servers by adding the line "prepend domain-name-servers 8.8.8.8, 8.8.4.4;" to /etc/dhcp/dhclient.conf

Items 2 and 3 may not be necessary.

Thanks again to all who contributed ideas and suggestions.

Post Reply

Return to “Wireless”