[SOLVED]How to enable WI-fi?

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
deepakdeshp
Level 10
Level 10
Posts: 3362
Joined: Sun Aug 09, 2015 10:00 am

[SOLVED]How to enable WI-fi?

Post by deepakdeshp » Wed Nov 29, 2017 5:41 am

I have a USB wi-fi device , but Mint does not connect to the wi-fi
details are

Code: Select all

lsusb
Bus 001 Device 114: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
When I disconnect and reconnect the device

Code: Select all

 dmesg 
 New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  834.119217] usb 1-5: Product: 802.11 n WLAN

sudo iwconfig
[sudo] password for aimserver: 
lo        no wireless extensions.

enp2s0    no wireless extensions.
iwlist scan
lo        Interface doesn't support scanning.

enp2s0    Interface doesn't support scanning.

Last edited by deepakdeshp on Wed Nov 29, 2017 7:25 am, edited 1 time in total.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18.3 Cinnamon 64 bit with AMD processor . Memory 8GB

User avatar
Pjotr
Level 20
Level 20
Posts: 10214
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: How to enable WI-fi?

Post by Pjotr » Wed Nov 29, 2017 5:46 am

I have exactly the same wifi chipset, and it's plug-and-play.... It just works out of the box.

Please generate an overview of your system like this:
- Launch a terminal window (this is how to launch a terminal window);
- make the terminal window full screen, to avoid chopped lines;
- Copy/paste this command into the terminal:

Code: Select all

inxi -Fxz
(if you type: the letter F is a capital letter)

Press Enter.

Copy/paste the output in your next message.

b. Do the same with the following three commands:

Code: Select all

rfkill list all
and:

Code: Select all

iwconfig
and:

Code: Select all

inxi -Nn
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

deepakdeshp
Level 10
Level 10
Posts: 3362
Joined: Sun Aug 09, 2015 10:00 am

Re: How to enable WI-fi?

Post by deepakdeshp » Wed Nov 29, 2017 7:25 am

Pjotr wrote:I have exactly the same wifi chipset, and it's plug-and-play.... It just works out of the box.
It works out of the box with following kernel.

Code: Select all

   uname -a
Linux aimserver 4.8.0-53-generic #56~16.04.1-Ubuntu SMP Tue May 16 01:14:44 UTC 2017 i686 i686 i686 GNU/Linux
I had update to Kernel 4.9.x in between and much later I found that wi-fi has stopped working. All along I was trying out different things but eventually the Kernel edition changing worked.

Thank you for your help.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18.3 Cinnamon 64 bit with AMD processor . Memory 8GB

User avatar
Pjotr
Level 20
Level 20
Posts: 10214
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: [SOLVED]How to enable WI-fi?

Post by Pjotr » Wed Nov 29, 2017 7:33 am

Good that you've solved it. :)

This wifi chipset should work with the official 4.10 and 4.11 kernels as well....
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Post Reply

Return to “Wireless”