Wireless / Wi-Fi Problem - Linux Mint 18.x+

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
wifi_pro
Level 1
Level 1
Posts: 7
Joined: Wed Nov 29, 2017 11:44 am

Wireless / Wi-Fi Problem - Linux Mint 18.x+

Post by wifi_pro » Wed Nov 29, 2017 11:53 am

I have been using Linux mint since version 17.0, the 'live boot usb' version (read only). Wifi Always worked fine.

But with version 18.x the Wi-Fi does not work. When I attach the USB network adapter (realktek RTL 8191S), it detect it and shows the available networks and prompts me to put a password for the selected network, and the tries to connect, but after a few seconds prompts me to enter the password again, as though the router rejected it.

Version 17.3 and lower still work correctly.

But if I use a Wifi USB adaptor with a RaLink 11n chipset, that still works with 18.x.

What happened to the last versions?, and why?, how can it be fixed?.

Remember this is from a 'read only' live boot usb.
Last edited by wifi_pro on Wed Nov 29, 2017 11:45 pm, edited 4 times in total.

JeremyB
Level 19
Level 19
Posts: 9175
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless / Wi-Fi Problem - Linux Mint 18.2+

Post by JeremyB » Wed Nov 29, 2017 3:16 pm

I would guess that wifi power management is the issue on 18.2 and 18.3

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
systemctl restart network-manager.service
That should fix it

wifi_pro
Level 1
Level 1
Posts: 7
Joined: Wed Nov 29, 2017 11:44 am

Re: Wireless / Wi-Fi Problem - Linux Mint 18.x

Post by wifi_pro » Wed Nov 29, 2017 5:50 pm

JeremyB wrote:I would guess that wifi power management is the issue on 18.2 and 18.3

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
systemctl restart network-manager.service
That should fix it
I tried the above (that's separate 2 lines , yes ).
Does not work, no difference.

But if I use a Wifi USB adaptor with a RaLink 11n chipset, that still works with 18.x.

?

JeremyB
Level 19
Level 19
Posts: 9175
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless / Wi-Fi Problem - Linux Mint 18.x+

Post by JeremyB » Sat Dec 02, 2017 5:21 pm

Have a look at https://ubuntuforums.org/showthread.php ... st13614520
It could be an encryption issue with one chipset or power save built into the module. See the wireless script link in my signature and post results

wifi_pro
Level 1
Level 1
Posts: 7
Joined: Wed Nov 29, 2017 11:44 am

Re: Wireless / Wi-Fi Problem - Linux Mint 18.x+

Post by wifi_pro » Sun Dec 17, 2017 12:07 pm

JeremyB wrote:Have a look at https://ubuntuforums.org/showthread.php ... st13614520
It could be an encryption issue with one chipset or power save built into the module. See the wireless script link in my signature and post results
Here is the result of the script (I am trying to connect to the network called TestWifiNetwork):

Code: Select all

########## wireless info START ##########

Report from: 17 Dec 2017 16:00 UTC +0000

Booted last: 17 Dec 2017 00:00 UTC +0000

Script from: 05 Dec 2017 03:13 UTC +0000

##### release ###########################

Distributor ID:	LinuxMint
Description:	Linux Mint 18.3 Sylvia
Release:	18.3
Codename:	sylvia

##### kernel ############################

Linux 4.10.0-38-generic #42~16.04.1-Ubuntu SMP Tue Oct 10 16:30:51 UTC 2017 i686 i686 i686 GNU/Linux

Parameters: file=/cdrom/preseed/linuxmint.seed, boot=casper, initrd=/casper/initrd.lz, quiet, splash, --

##### desktop ###########################

MATE

##### lspci #############################

00:03.0 Ethernet controller [0200]: Intel Corporation 82540EM Gigabit Ethernet Controller [8086:100e] (rev 02)
	Subsystem: Intel Corporation PRO/1000 MT Desktop Adapter [8086:001e]
	Kernel driver in use: e1000

##### lsusb #############################

Bus 001 Device 003: ID 0bda:8172 Realtek Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

##### PCMCIA card info ##################

##### rfkill ############################

##### lsmod #############################

r8712u                159744  0
cfg80211              532480  0

##### interfaces ########################

auto lo
iface lo inet loopback

##### ifconfig ##########################

enp0s3    Link encap:Ethernet  HWaddr <MAC 'enp0s3' [IF1]>  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4734 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3158 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5339622 (5.3 MB)  TX bytes:255364 (255.3 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:528 errors:0 dropped:0 overruns:0 frame:0
          TX packets:528 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:42959 (42.9 KB)  TX bytes:42959 (42.9 KB)

wlx<IF from MAC [IF2]> Link encap:Ethernet  HWaddr <MAC 'wlx<IF from MAC [IF2]>' [IF2]>  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

##### iwconfig ##########################

lo        no wireless extensions.

enp0s3    no wireless extensions.

wlx<IF from MAC [IF2]>  unassociated  Nickname:"rtl_wifi"
          Mode:Managed  Access Point: Not-Associated   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

##### route #############################

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

##### resolv.conf #######################

nameserver 127.0.1.1

##### network managers ##################

Installed:

	NetworkManager

Running:

root       969     1  0 15:51 ?        00:00:00 /usr/sbin/NetworkManager --no-daemon

##### NetworkManager info ###############

GENERAL.DEVICE:                         wlx<IF from MAC [IF2]>
GENERAL.TYPE:                           wifi
GENERAL.NM-TYPE:                        NMDeviceWifi
GENERAL.VENDOR:                         Manufacturer Realtek 
GENERAL.PRODUCT:                        RTL8191S WLAN Adapter 
GENERAL.DRIVER:                         r8712u
GENERAL.DRIVER-VERSION:                 
GENERAL.FIRMWARE-VERSION:               
GENERAL.HWADDR:                         <MAC 'wlx<IF from MAC [IF2]>' [IF2]>
GENERAL.MTU:                            1500
GENERAL.STATE:                          50 (connecting (configuring))
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1f.5/usb1/1-1/1-1:1.0/net/wlx<IF from MAC [IF2]>
GENERAL.IP-IFACE:                       
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     TestWiFiNetwork
GENERAL.CON-UUID:                       8fa04d70-e38a-486e-a5ce-f4f784180015
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/3
GENERAL.METERED:                        unknown
CAPABILITIES.CARRIER-DETECT:            no
CAPABILITIES.SPEED:                     unknown
CAPABILITIES.IS-SOFTWARE:               no
WIFI-PROPERTIES.WEP:                    yes
WIFI-PROPERTIES.WPA:                    yes
WIFI-PROPERTIES.WPA2:                   yes
WIFI-PROPERTIES.TKIP:                   yes
WIFI-PROPERTIES.CCMP:                   yes
WIFI-PROPERTIES.AP:                     no
WIFI-PROPERTIES.ADHOC:                  yes
WIFI-PROPERTIES.2GHZ:                   yes
WIFI-PROPERTIES.5GHZ:                   no
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{1}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   8fa04d70-e38a-486e-a5ce-f4f784180015 | TestWiFiNetwork

GENERAL.DEVICE:                         enp0s3
GENERAL.TYPE:                           ethernet
GENERAL.NM-TYPE:                        NMDeviceEthernet
GENERAL.VENDOR:                         Intel Corporation
GENERAL.PRODUCT:                        82540EM Gigabit Ethernet Controller (PRO/1000 MT Desktop Adapter)
GENERAL.DRIVER:                         e1000
GENERAL.DRIVER-VERSION:                 7.3.21-k8-NAPI
GENERAL.FIRMWARE-VERSION:               
GENERAL.HWADDR:                         <MAC 'enp0s3' [IF1]>
GENERAL.MTU:                            1500
GENERAL.STATE:                          30 (disconnected)
GENERAL.REASON:                         39 (Device disconnected by user or client)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:03.0/net/enp0s3
GENERAL.IP-IFACE:                       
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    no
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     --
GENERAL.CON-UUID:                       --
GENERAL.CON-PATH:                       --
GENERAL.METERED:                        unknown
CAPABILITIES.CARRIER-DETECT:            yes
CAPABILITIES.SPEED:                     1000 Mb/s
CAPABILITIES.IS-SOFTWARE:               no
WIRED-PROPERTIES.CARRIER:               on
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{0}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   a16510f6-0d69-3d51-a051-a97aa1ecd29e | Wired connection 1

SSID           BSSID              MODE   CHAN  FREQ      RATE       SIGNAL  BARS  SECURITY   ACTIVE  * 
TestWiFiNetwork  <MAC 'TestWiFiNetwork' [AC1]>  Infra  6     2437 MHz  54 Mbit/s  76      ▂▄▆_  WPA1 WPA2  no        
VM1358054      <MAC 'VM1358054' [AC2]>  Infra  6     2437 MHz  54 Mbit/s  48      ▂▄__  WPA1 WPA2  no        

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/TestWiFiNetwork]] (600 root)
[connection] id=TestWiFiNetwork | type=wifi | permissions=user:mint:;
[wifi] mac-address=<MAC 'wlx<IF from MAC [IF2]>' [IF2]> | mac-address-blacklist= | ssid=TestWiFiNetwork
[ipv4] method=auto
[ipv6] method=auto

##### Netplan config ####################

##### iw reg get ########################

Region: Etc/UTC (based on set time zone)

country 00: DFS-UNSET
	(2402 - 2472 @ 40), (N/A, 20), (N/A)
	(2457 - 2482 @ 40), (N/A, 20), (N/A), NO-IR
	(2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, NO-IR
	(5170 - 5250 @ 80), (N/A, 20), (N/A), NO-IR
	(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, NO-IR
	(5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, NO-IR
	(5735 - 5835 @ 80), (N/A, 20), (N/A), NO-IR
	(57240 - 63720 @ 2160), (N/A, 0), (N/A)

##### iwlist channels ###################

lo        no frequency information.

enp0s3    no frequency information.

wlx<IF from MAC [IF2]>  14 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Channel 14 : 2.484 GHz

##### iwlist scan #######################

lo        Interface doesn't support scanning.

enp0s3    Interface doesn't support scanning.

Channel occupancy:

      2   APs on   Frequency:2.437 GHz (Channel 6)

wlx<IF from MAC [IF2]>  Scan completed :
          Cell 01 - Address: <MAC 'TestWiFiNetwork' [AC1]>
                    ESSID:"TestWiFiNetwork"
                    Protocol:IEEE 802.11bgn
                    Mode:Master
                    Frequency:2.437 GHz (Channel 6)
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:wpa_ie=dd1a0050f20101000050f20202000050f2020050f20401000050f202
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    Extra:rsn_ie=30180100000fac020200000fac02000fac040100000fac020000
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    Signal level=76/100  
          Cell 02 - Address: <MAC 'VM1358054' [AC2]>
                    ESSID:"VM1358054"
                    Protocol:IEEE 802.11bgn
                    Mode:Master
                    Frequency:2.437 GHz (Channel 6)
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:wpa_ie=dd1a0050f20101000050f20202000050f2040050f20201000050f202
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    Extra:rsn_ie=30180100000fac020200000fac04000fac020100000fac020000
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    Signal level=47/100  

##### module infos ######################

[r8712u]
filename:       /lib/modules/4.10.0-38-generic/kernel/drivers/staging/rtl8712/r8712u.ko
firmware:       rtlwifi/rtl8712u.bin
author:         Larry Finger
description:    rtl871x wireless lan driver
license:        GPL
srcversion:     FFBC0B75B959BAFD2FEC8EB
depends:        
staging:        Y
intree:         Y
vermagic:       4.10.0-38-generic SMP mod_unload 686 
parm:           wifi_test:int
parm:           video_mode:int
parm:           chip_version:int
parm:           rfintfs:int
parm:           lbkmode:int
parm:           hci:int
parm:           network_mode:int
parm:           channel:int
parm:           mp_mode:int
parm:           wmm_enable:int
parm:           vrtl_carrier_sense:int
parm:           vcs_type:int
parm:           busy_thresh:int
parm:           ht_enable:int
parm:           cbw40_enable:int
parm:           ampdu_enable:int
parm:           rf_config:int
parm:           power_mgnt:int
parm:           low_power:int
parm:           ifname: Net interface name, wlan%d=default (string)
parm:           initmac:MAC-Address, default: use FUSE (charp)

[cfg80211]
filename:       /lib/modules/4.10.0-38-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
srcversion:     D77C8F93375950F3BA95B16
depends:        
intree:         Y
vermagic:       4.10.0-38-generic SMP mod_unload 686 
parm:           bss_entries_limit:limit to number of scan BSS entries (per wiphy, default 1000) (int)
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[r8712u]
ampdu_enable: 1
busy_thresh: 40
cbw40_enable: 1
channel: 1
chip_version: 2
hci: 1
ht_enable: 1
ifname: wlan%d
initmac: (null)
lbkmode: 0
low_power: 0
mp_mode: 0
network_mode: 0
power_mgnt: 0
rf_config: 1
rfintfs: 2
vcs_type: 1
video_mode: 1
vrtl_carrier_sense: 2
wifi_test: 0
wmm_enable: 0

[cfg80211]
bss_entries_limit: 1000
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

##### modprobe options ##################

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

[/etc/modprobe.d/mlx4.conf]
softdep mlx4_core post: mlx4_en

##### rc.local ##########################

exit 0

##### pm-utils ##########################

##### udev rules ########################

##### dmesg #############################

[   22.680397] IPv6: ADDRCONF(NETDEV_UP): enp0s3: link is not ready (repeated 2 times)
[   22.689546] e1000: enp0s3 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
[   22.689795] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s3: link becomes ready
[  252.550211] r8712u: module is from the staging directory, the quality is unknown, you have been warned.
[  252.552008] r8712u: register rtl8712_netdev_ops to netdev_ops
[  252.552013] usb 1-1: r8712u: USB_SPEED_HIGH with 4 endpoints
[  252.556298] usb 1-1: r8712u: Boot from EFUSE: Autoload OK
[  258.983025] usb 1-1: r8712u: CustomerID = 0x000a
[  258.983028] usb 1-1: r8712u: MAC Address from efuse = <MAC 'wlx<IF from MAC [IF2]>' [IF2]>
[  258.983029] usb 1-1: r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
[  259.014215] r8712u 1-1:1.0 wlx<IF from MAC [IF2]>: renamed from wlan0
[  259.054283] IPv6: ADDRCONF(NETDEV_UP): wlx<IF from MAC [IF2]>: link is not ready
[  259.891205] r8712u 1-1:1.0 wlx<IF from MAC [IF2]>: 1 RCR=0x153f00e
[  259.897197] r8712u 1-1:1.0 wlx<IF from MAC [IF2]>: 2 RCR=0x553f00e
[  261.445538] IPv6: ADDRCONF(NETDEV_UP): wlx<IF from MAC [IF2]>: link is not ready (repeated 2 times)
[  284.898002] r8712u: register rtl8712_netdev_ops to netdev_ops
[  284.898005] usb 1-1: r8712u: USB_SPEED_HIGH with 4 endpoints
[  284.901595] usb 1-1: r8712u: Boot from EFUSE: Autoload OK
[  291.311169] usb 1-1: r8712u: CustomerID = 0x000a
[  291.311172] usb 1-1: r8712u: MAC Address from efuse = <MAC 'wlx<IF from MAC [IF2]>' [IF2]>
[  291.311174] usb 1-1: r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
[  292.357169] r8712u 1-1:1.0 wlx<IF from MAC [IF2]>: renamed from wlan0
[  292.373535] IPv6: ADDRCONF(NETDEV_UP): wlx<IF from MAC [IF2]>: link is not ready
[  293.215450] r8712u 1-1:1.0 wlx<IF from MAC [IF2]>: 1 RCR=0x153f00e
[  293.221420] r8712u 1-1:1.0 wlx<IF from MAC [IF2]>: 2 RCR=0x553f00e
[  294.777595] IPv6: ADDRCONF(NETDEV_UP): wlx<IF from MAC [IF2]>: link is not ready (repeated 4 times)
[  311.674847] IPv6: ADDRCONF(NETDEV_UP): enp0s3: link is not ready (repeated 2 times)
[  311.678693] IPv6: ADDRCONF(NETDEV_UP): wlx<IF from MAC [IF2]>: link is not ready
[  311.684274] e1000: enp0s3 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
[  313.189951] IPv6: ADDRCONF(NETDEV_UP): wlx<IF from MAC [IF2]>: link is not ready
[  313.191689] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s3: link becomes ready
[  313.235969] IPv6: ADDRCONF(NETDEV_UP): wlx<IF from MAC [IF2]>: link is not ready (repeated 2 times)

########## wireless info END ############


JeremyB
Level 19
Level 19
Posts: 9175
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless / Wi-Fi Problem - Linux Mint 18.x+

Post by JeremyB » Sun Dec 17, 2017 12:34 pm

Can you set the router encryption to WPA2 only? Now it is also using TKIP encryption and that can cause issues. Also go into Network Manager settings for the connection and disable IPv6

The realtek module being used is in the staging directory, that usually means it isn't very good

User avatar
Pjotr
Level 20
Level 20
Posts: 10899
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Wireless / Wi-Fi Problem - Linux Mint 18.x+

Post by Pjotr » Sun Dec 17, 2017 12:52 pm

I think you mean: "AES only". :)
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

JeremyB
Level 19
Level 19
Posts: 9175
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless / Wi-Fi Problem - Linux Mint 18.x+

Post by JeremyB » Sun Dec 17, 2017 1:09 pm

Pjotr wrote:I think you mean: "AES only". :)
I guess I am used to my router, WPA2 only results with just AES

wifi_pro
Level 1
Level 1
Posts: 7
Joined: Wed Nov 29, 2017 11:44 am

Re: Wireless / Wi-Fi Problem - Linux Mint 18.x+

Post by wifi_pro » Sun Dec 31, 2017 3:39 am

JeremyB wrote:Can you set the router encryption to WPA2 only? Now it is also using TKIP encryption and that can cause issues. Also go into Network Manager settings for the connection and disable IPv6

The realtek module being used is in the staging directory, that usually means it isn't very good

When I set it to WP2 with AES encryption, it does connect to the router. BUT, then the web browser does not work. No websites load (actually they do but just for the 1st second or two after the connection to the router).

IP6, if i disable this in the Linux Connection Manager then it does not show any Wi-Fi networks. If I disable this in the router then it does not connect to the router.

WEP encryption connects, but websites only load for a few seconds or so, not for many minutes or longer.

(Remember, with older Linux Mint, this problem was not there, with the same router configuration).

jdm
Level 1
Level 1
Posts: 24
Joined: Wed May 28, 2014 7:18 pm

Re: Wireless / Wi-Fi Problem - Linux Mint 18.x+

Post by jdm » Mon Jan 01, 2018 7:04 am

I'm no expert but what kernel are you on in LM18 and what kernel were you on in LM17? Maybe an older kernel might solve your problem. I think 18 comes with 4.10 but 4.4 works well for me and is LTS whereas 4.10 isn't LTS.

Just an idea.

HNY

JDM

deepakdeshp
Level 11
Level 11
Posts: 3797
Joined: Sun Aug 09, 2015 10:00 am

Re: Wireless / Wi-Fi Problem - Linux Mint 18.x+

Post by deepakdeshp » Mon Jan 01, 2018 9:20 am

4.14 is LTS for 6 years. Please try installing highest series no. of this, reboot and test.

Code: Select all

 uname -a
will give which kernel you booted from.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

wifi_pro
Level 1
Level 1
Posts: 7
Joined: Wed Nov 29, 2017 11:44 am

Re: Wireless / Wi-Fi Problem - Linux Mint 18.x+

Post by wifi_pro » Mon Jan 01, 2018 9:01 pm

jdm wrote:I'm no expert but what kernel are you on in LM18 and what kernel were you on in LM17? Maybe an older kernel might solve your problem. I think 18 comes with 4.10 but 4.4 works well for me and is LTS whereas 4.10 isn't LTS.

Just an idea.

HNY

JDM

The default one as supplied with the DVD image of the MATE desktop version, as in the ISO download from this website.

wifi_pro
Level 1
Level 1
Posts: 7
Joined: Wed Nov 29, 2017 11:44 am

Re: Wireless / Wi-Fi Problem - Linux Mint 18.x+

Post by wifi_pro » Mon Jan 01, 2018 9:01 pm

deepakdeshp wrote:4.14 is LTS for 6 years. Please try installing highest series no. of this, reboot and test.

Code: Select all

 uname -a
will give which kernel you booted from.

The default one as supplied with the DVD image of the MATE desktop version, as in the ISO download from this website.

jdm
Level 1
Level 1
Posts: 24
Joined: Wed May 28, 2014 7:18 pm

Re: Wireless / Wi-Fi Problem - Linux Mint 18.x+

Post by jdm » Tue Jan 02, 2018 2:31 pm

I'm assuming you are new to mint, forgive me if you already know how to do the following.

I would suggest installing the latest release of kernel 4.4 from update manager, click on View and select Linux Kernels to select the kernel to install. Do NOT remove your esisting kernel.
To boot into the newly installed kernel reboot and hit ESC a few times when the bios screen appears and this should bring up a menu to select the kernel to boot from. If that doesn't work you can still go back to the default kernel by rebooting. Boot will default to the latest kernel version i.e. 4.10 if you have 4.4 and 4.10 installed etc.

If this doesn't solve your problem or creates new issues you could try installing 4.14.

Good luck

jdm

Post Reply

Return to “Wireless”