Page 1 of 1

Can't set up ad-hoc wifi.

Posted: Sun Dec 03, 2017 7:22 am
by Davetesc
A while ago using Mint 17.3 XFCE I managed to set up an ad-hoc wifi network so I could sync my laptop to my desktop. I can't remember which guide I worked from but it was basically about using network manager to create the ad-hoc wifi network and assigning static ip's to both computers. Once I got the firewall configured and added public key access it worked a treat. Until I updated to mint 18.2 or thereabouts then I could recreate the network on my laptop ( the desktop was stuck with 17.3 as it's an always on PVR ) so I had to copy the working config file from the previous install on the laptop and that worked.

Now the PC running 17.3 is dead and I've run up a replacement on LMDE so both my laptop and the desktop are running the same distro and I cannot get it to set up a new ad-hoc wifi link. I read a couple of posts somewhere saying there's a bug in network manager, something to do with WPA encryption maybe. Can anyone point me to a new reliable guide for setting this up again. I don't mind using the cli if need be, but have had disasters trying to install WICD so won't touch that again.

Any help would be greatly appreciated and I can post back with more info if that would help but didn't want to post loads of useless info.

Thanks. Dave.