Wireless Lan Linux Driver installation failed

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
User avatar
pcfan5
Level 4
Level 4
Posts: 231
Joined: Tue Sep 06, 2016 10:57 am
Location: antartica

Wireless Lan Linux Driver installation failed

Post by pcfan5 » Sun Dec 03, 2017 5:39 pm

Hi there, I have the same nano USB unit RT2870 (according to the driver), I cannot do what it is explained in the "readme" file that comes with a cd, as the person who post this in first place, since I am a standard linux user, I don't know how to program or write in files or run advanced commands in console. I also read this post is from 2015, maybe things have changed since then. The issue I have is that I get disconnected everytime.

Code: Select all

sil@sil-MS-7529 ~ $  inxi -Fxx
System:    Host: sil-MS-7529 Kernel: 4.4.0-98-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.16.2 (Gtk 3.18.9-1ubuntu3.3) dm: mdm
           Distro: Linux Mint 18.1 Serena
Machine:   Mobo: MICRO-STAR model: G31TM-P21 (MS-7529) v: 1.0
           Bios: American Megatrends v: V4.7 date: 07/28/2010
CPU:       Dual core Pentium E5300 (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 10400
           clock speeds: min/max: 1203/2603 MHz 1: 2003 MHz 2: 2603 MHz
Graphics:  Card: Intel 82G33/G31 Express Integrated Graphics Controller
           bus-ID: 00:02.0 chip-ID: 8086:29c2
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1360x768@60.02hz
           GLX Renderer: Mesa DRI Intel G33
           GLX Version: 1.4 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card VIA VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller
           driver: snd_ice1724 ports: ec00 e880 bus-ID: 03:00.0 chip-ID: 1412:1724
           Sound: Advanced Linux Sound Architecture v: k4.4.0-98-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: d800
           bus-ID: 02:00.0 chip-ID: 10ec:8136
           IF: enp2s0 state: down mac: 00:24:21:dd:c0:d7
           [color=#BF4040][b]Card-2: Realtek RTL8188CUS 802.11n WLAN Adapter
           driver: rtl8192cu usb-ID: 001-003 chip-ID: 0bda:8176
           IF: wlx784476907d03 state: N/A mac: N/A[/b][/color]
Drives:    HDD Total Size: 320.1GB (80.9% used)
           ID-1: /dev/sda model: SAMSUNG_HD322HJ size: 320.1GB serial: S17AJ9DS626758
Partition: ID-1: / size: 20G used: 16G (83%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 4.10GB used: 0.04GB (1%) fs: swap dev: /dev/sda5
RAID:      System: supported: N/A
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   System Temperatures: cpu: 48.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 166 Uptime: 1:40 Memory: 2246.3/3942.1MB
           Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481 running in mate-terminal) inxi: 2.2.35 
sil@sil-MS-7529 ~ $ 

Ps: the link given before for downloading two files https://github.com/Alberto97/rt2870 is out of service.

JeremyB
Level 18
Level 18
Posts: 8127
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless Lan Linux Driver installation failed

Post by JeremyB » Sun Dec 03, 2017 5:52 pm

Split from viewtopic.php?f=49&t=191243

Please post results for lsusb as your inxi results do not show the same device as the other thread

User avatar
pcfan5
Level 4
Level 4
Posts: 231
Joined: Tue Sep 06, 2016 10:57 am
Location: antartica

Re: Wireless Lan Linux Driver installation failed

Post by pcfan5 » Thu Dec 07, 2017 6:33 pm

JeremyB wrote:Split from viewtopic.php?f=49&t=191243

Please post results for lsusb as your inxi results do not show the same device as the other thread

Code: Select all

 lsusbBus 001 Device 003: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 1c4f:0002 SiGma Micro Keyboard TRACER Gamma Ivory
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Sorry for my delay.

@jereyB: I edited this post since I was so s....y that I forgot to plugg the device. Sorry
Last edited by pcfan5 on Thu Dec 07, 2017 10:47 pm, edited 1 time in total.

JeremyB
Level 18
Level 18
Posts: 8127
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless Lan Linux Driver installation failed

Post by JeremyB » Thu Dec 07, 2017 6:39 pm

Those results show no USB wireless device, perhaps try a different USB port

User avatar
pcfan5
Level 4
Level 4
Posts: 231
Joined: Tue Sep 06, 2016 10:57 am
Location: antartica

Re: Wireless Lan Linux Driver installation failed

Post by pcfan5 » Thu Dec 07, 2017 10:48 pm

JeremyB wrote:Those results show no USB wireless device, perhaps try a different USB port
Post edited,-check it again , pleases, forgive me. I forgot to plugg the device in. Sorry

Post Reply

Return to “Wireless”