Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
naimf1
Level 1
Level 1
Posts: 10
Joined: Mon Dec 04, 2017 6:01 am

Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby naimf1 » Mon Dec 04, 2017 6:32 am

Hi. I have the internet very slow, there are times where it works well and others do not.
Also when I use the "suspend" mode I lose the speed of the internet. This is not solved by restarting the PC. I await your help.

sudo iwconfig

Code: Select all

wlp2s0b1  IEEE 802.11  ESSID:"TIGO-INTERNET714" 
          Mode:Managed  Frequency:2.452 GHz  Access Point: 14:5B:D1:95:95:C6   
          Bit Rate=24 Mb/s   Tx-Power=19 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=66/70  Signal level=-44 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:306  Invalid misc:684   Missed beacon:0

eno1      no wireless extensions.

lo        no wireless extensions.


inxi -Fxz

Code: Select all

System:    Host: ale-ENVY Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Hewlett-Packard product: HP ENVY 6 Notebook PC v: 0795100000205600000320100
           Mobo: Hewlett-Packard model: 18DE v: 77.47
           Bios: Insyde v: F.15 date: 01/22/2013
CPU:       Dual core AMD A6-4455M APU with Radeon HD Graphics (-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 8384
           clock speeds: max: 2100 MHz 1: 1800 MHz 2: 2100 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Trinity [Radeon HD 7500G]
           bus-ID: 00:01.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.03hz
           GLX Renderer: Gallium 0.4 on AMD ARUBA (DRM 2.49.0 / 4.10.0-38-generic, LLVM 4.0.0)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Trinity HDMI Audio Controller
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 01:00.2
           IF: eno1 state: down mac: <filter>
           Card-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter
           driver: bcma-pci-bridge bus-ID: 02:00.0
           IF: wlp2s0b1 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (2.0% used)
           ID-1: /dev/sda model: Hitachi_HTS54505 size: 500.1GB temp: 0C
Partition: ID-1: / size: 89G used: 6.0G (8%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 3.72GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 45.0C mobo: N/A gpu: 44.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 183 Uptime: 58 min Memory: 1216.2/3414.5MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35


rfkill list all

Code: Select all

0: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no
1: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no


inxi -Nn

Code: Select all

Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: eno1 state: down mac: 28:92:4a:1a:4e:0d
           Card-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter
           driver: bcma-pci-bridge
           IF: wlp2s0b1 state: up mac: e0:06:e6:11:2b:f3


lsusb

Code: Select all

Bus 002 Device 002: ID 1bcf:2c0e Sunplus Innovation Technology Inc.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 0a5c:21e3 Broadcom Corp. HP Portable Valentine
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


iwlist scan | egrep -i 'essid|cipher'

Code: Select all

eno1      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

                    ESSID:"TIGO-INTERNET714"
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP

User avatar
lisabonne citadel
Level 3
Level 3
Posts: 126
Joined: Fri Oct 13, 2017 5:13 am

Re: Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby lisabonne citadel » Mon Dec 04, 2017 12:53 pm

I had the same problem here and i guess almost everyone except in Japan had the same.

You can try to disable IPV6 as standard connection

in /etc/gai.conf
open as root and edit with your text editor.
you will see some parameters that you can change :)

you can also disable telemetry on firefox

type on firefox address field
about:config
ON SEARCH
toolkit.telemetry.archive CHANGE to false
toolkit.telemetry.enabled CHANGE to false
toolkit.telemetry.unified CHANGE to false

telemetry collects data and sends to firefox servers for analysis statistics.

This two measures should be enough for your needs

naimf1
Level 1
Level 1
Posts: 10
Joined: Mon Dec 04, 2017 6:01 am

Re: Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby naimf1 » Mon Dec 04, 2017 3:03 pm

lisabonne citadel wrote:You can try to disable IPV6 as standard connection


Hello @lisabonne
With this was enough to disable?

Code: Select all

#precedence  ::1/128       50
#precedence  ::/0          40
#precedence  2002::/16     30
#precedence ::/96          20
precedence ::ffff:0:0/96  10


The problem is very intermittent. There are days that work, others do not.
Sometimes the speed of the internet is restored by itself in 1 hour or more.
I think it has to do with the energy manager.
At this moment the internet is working well, but when restarting the PC, I have zero guarantees that it continues to work well. :lol:

EDIT: I just rebooted the PC, after disabling the IPV6. And again I lost the speed of the Internet

naimf1
Level 1
Level 1
Posts: 10
Joined: Mon Dec 04, 2017 6:01 am

Re: Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby naimf1 » Tue Dec 05, 2017 5:53 am

Any other ideas I can prove?
I still have the same problem

JeremyB
Level 17
Level 17
Posts: 7727
Joined: Fri Feb 21, 2014 8:17 am

Re: Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby JeremyB » Tue Dec 05, 2017 6:46 am

I would change the wifi router encryption to WPA2 only as TKIP has always caused problems on my machines using Linux

naimf1
Level 1
Level 1
Posts: 10
Joined: Mon Dec 04, 2017 6:01 am

Re: Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby naimf1 » Tue Dec 05, 2017 8:53 am

JeremyB wrote:I would change the wifi router encryption to WPA2 only as TKIP has always caused problems on my machines using Linux

Image

Ok, apparently it's working.
If in a few days it does not cause me more problems. I will return to comment that the problem solved.

Thanks @JeremiB and @Lizabonne

naimf1
Level 1
Level 1
Posts: 10
Joined: Mon Dec 04, 2017 6:01 am

Re: Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby naimf1 » Wed Dec 06, 2017 7:13 am

Unfortunately, my internet still does not work properly.
It's still very intermittent, one day it works another day, no. Every time I turn on the PC I have a 50% chance that it works or not.

Image

ruohtula
Level 1
Level 1
Posts: 1
Joined: Thu Sep 14, 2017 12:20 pm
Location: Helsinki, Finland

Re: Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby ruohtula » Wed Dec 06, 2017 7:28 am

I don't know if this is related to your problem, but I did notice you had Broadcom wifi, and today I had an interesting upgrade experience that may have something to do with it. (I run Mint on an small Asus 1225B laptop where log says in boot "Broadcom 43xx driver loaded").
I had not updated Mint 18.2 for a while, then let it install the default updates (was it up to level 2), among other things, this omitted the kernel update. After this, the wifi started acting up. First it did not connect, then after some retries it did. The broadcom driver spit lots of warnings to the log, and occasionally dropped connection. I thought that maybe this could be fixed by a kernel update, and let the updater install the rest of the pending updates, which included the kernel and systemd. Fortunately the connection stayed up long enough.
After this the wifi problem appears to be fixed!
I have no real idea why, but I suspect the first update installed something (firmware?) that did not work right on its own without having also the kernel updated.

naimf1
Level 1
Level 1
Posts: 10
Joined: Mon Dec 04, 2017 6:01 am

Re: Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby naimf1 » Wed Dec 06, 2017 4:09 pm

Thank @ruohtula
I do not think it's a good idea to update Kernel.
But I have to try, so I updated it..
I will inform you if I have the same problem again

naimf1
Level 1
Level 1
Posts: 10
Joined: Mon Dec 04, 2017 6:01 am

Re: Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby naimf1 » Thu Dec 07, 2017 5:56 am

I'm still having the same problem.
:(

naimf1
Level 1
Level 1
Posts: 10
Joined: Mon Dec 04, 2017 6:01 am

Re: Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby naimf1 » Mon Dec 11, 2017 6:19 am

I still have the same problem. After having installed all the updates.

This is really sad. I need to use Mint because I use it to work. I hope to find a solution ....

JeremyB
Level 17
Level 17
Posts: 7727
Joined: Fri Feb 21, 2014 8:17 am

Re: Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby JeremyB » Mon Dec 11, 2017 6:38 am

There are a couple other modules that get loaded but aren't needed

Code: Select all

echo "blacklist b43" | sudo tee /etc/modprobe.d/b43-ssb.conf

Code: Select all

echo "blacklist ssb" | sudo tee -a /etc/modprobe.d/b43-ssb.conf

Reboot

naimf1
Level 1
Level 1
Posts: 10
Joined: Mon Dec 04, 2017 6:01 am

Re: Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby naimf1 » Tue Dec 12, 2017 6:35 am

JeremyB wrote:There are a couple other modules that get loaded but aren't needed

Code: Select all

echo "blacklist b43" | sudo tee /etc/modprobe.d/b43-ssb.conf

Code: Select all

echo "blacklist ssb" | sudo tee -a /etc/modprobe.d/b43-ssb.conf

Reboot

I have added the modules to the blacklist. Unfortunately, the problem continues.
It will not be something related to the energy manager?

JeremyB
Level 17
Level 17
Posts: 7727
Joined: Fri Feb 21, 2014 8:17 am

Re: Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby JeremyB » Tue Dec 12, 2017 6:54 am

You could try

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Code: Select all

systemctl restart network-manager.service


See if disabling wifi power management helps

naimf1
Level 1
Level 1
Posts: 10
Joined: Mon Dec 04, 2017 6:01 am

Re: Internet wifi slow - Linux Mint 18.3 - HP Envy 6

Postby naimf1 » Wed Dec 13, 2017 6:34 am

JeremyB wrote:You could try

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Code: Select all

systemctl restart network-manager.service

See if disabling wifi power management helps


Thanks @Jeremy.
Power management is off

Code: Select all

wlp2s0b1  IEEE 802.11  ESSID:"TIGO-INTERNET714" 
          Mode:Managed  Frequency:2.452 GHz  Access Point: 14:5B:D1:95:95:C6   
          Bit Rate=24 Mb/s   Tx-Power=19 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-172 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:39  Invalid misc:131   Missed beacon:0


But I still do not solve the problem, it seems that we have reached a dead end.
Thanks for all the help, if it can not be solved, nothing happens :(
I will use the internet at 34 Kbps :lol:


Return to “Wireless”