LM 18.1 MATE 64bit - Driver for usb wifi adapter "TP-Link Archer T2UH" wanted

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Centauri39
Level 3
Level 3
Posts: 195
Joined: Sun Mar 23, 2014 2:20 pm

Re: LM 18.1 MATE 64bit - Driver for usb wifi adapter "TP-Link Archer T2UH" wanted

Post by Centauri39 » Tue Dec 12, 2017 3:11 pm

I also noticed another side effect, I can plugin this device, but I cannot unplug it without Mint freezing.

As for the blacklist, what device is supposed to be in modprobe.d, the 2800 or the 7610?

JeremyB
Level 18
Level 18
Posts: 8125
Joined: Fri Feb 21, 2014 8:17 am

Re: LM 18.1 MATE 64bit - Driver for usb wifi adapter "TP-Link Archer T2UH" wanted

Post by JeremyB » Tue Dec 12, 2017 5:47 pm

I would blacklist mt7610u_sta, I don't know why the rt2800 would need to be blacklisted

Centauri39
Level 3
Level 3
Posts: 195
Joined: Sun Mar 23, 2014 2:20 pm

Re: LM 18.1 MATE 64bit - Driver for usb wifi adapter "TP-Link Archer T2UH" wanted

Post by Centauri39 » Tue Dec 12, 2017 9:30 pm

But as far as I understand this, the mt7610u_sta is for the Archer device and the rt2800usb for the previous one,
so why would I try so hard to install this driver if in the end I blacklist it?

Centauri39
Level 3
Level 3
Posts: 195
Joined: Sun Mar 23, 2014 2:20 pm

Re: LM 18.1 MATE 64bit - Driver for usb wifi adapter "TP-Link Archer T2UH" wanted

Post by Centauri39 » Wed Dec 13, 2017 12:34 am

On kernel 4.4, this device isn't working either.

Centauri39
Level 3
Level 3
Posts: 195
Joined: Sun Mar 23, 2014 2:20 pm

Re: LM 18.1 MATE 64bit - Driver for usb wifi adapter "TP-Link Archer T2UH" wanted

Post by Centauri39 » Wed Dec 13, 2017 1:13 am

Now, I got it! :shock:
You want me to blacklist mt7610u_sta, because there's another mt7610u (without _sta) installed.

Anyway, the 4.4 kernel doesn't help.

JeremyB
Level 18
Level 18
Posts: 8125
Joined: Fri Feb 21, 2014 8:17 am

Re: LM 18.1 MATE 64bit - Driver for usb wifi adapter "TP-Link Archer T2UH" wanted

Post by JeremyB » Wed Dec 13, 2017 5:48 pm

Code: Select all

cd ~/mt7610u_wifi_sta_v3002_dpo_20130916
sudo make uninstall
cd ~/mt7610u
sudo make uninstall
Then try https://askubuntu.com/a/819231/300665 while using a 4.4 kernel, if that doesn't work find a different device

Centauri39
Level 3
Level 3
Posts: 195
Joined: Sun Mar 23, 2014 2:20 pm

Re: LM 18.1 MATE 64bit - Driver for usb wifi adapter "TP-Link Archer T2UH" wanted

Post by Centauri39 » Thu Dec 14, 2017 12:06 pm

This guide is about the T1U, not about the T2UH.

Well at least, somehow it did work (sort of!), but only for channels 36 to 48.
Changing channels didn't work without rebooting Mint.
The device just doesn't exist for Mint, if you set up your router to higher channels.
The device also doesn't work for 2.4 Ghz channels, only for the lower 5 GHz channels.

The reason I've been trying all this was this topic, but it didn't help.
The distortions mentioned there are still present.

JeremyB
Level 18
Level 18
Posts: 8125
Joined: Fri Feb 21, 2014 8:17 am

Re: LM 18.1 MATE 64bit - Driver for usb wifi adapter "TP-Link Archer T2UH" wanted

Post by JeremyB » Thu Dec 14, 2017 5:57 pm

Centauri39 wrote:This guide is about the T1U, not about the T2UH.

Well at least, somehow it did work (sort of!), but only for channels 36 to 48.
Changing channels didn't work without rebooting Mint.
The device just doesn't exist for Mint, if you set up your router to higher channels.
The device also doesn't work for 2.4 Ghz channels, only for the lower 5 GHz channels.

The reason I've been trying all this was this topic, but it didn't help.
The distortions mentioned there are still present.
Both the T1U and the T2UH use the same wifi chipset and both should be supported by the ulli-kroll github source that you said didn't work and I imagine that Pilot6's file was based on ulli-kroll or another github source.
Check iw reg get and see if the country code is correct

Centauri39
Level 3
Level 3
Posts: 195
Joined: Sun Mar 23, 2014 2:20 pm

Re: LM 18.1 MATE 64bit - Driver for usb wifi adapter "TP-Link Archer T2UH" wanted

Post by Centauri39 » Sat Dec 23, 2017 7:12 am

Meanwhile, I gave up on the T2UH and I purchased a T4UH AC 1300.
For this device, I had to compile the driver, too, but at least, this one did work perfectly.

Here's, how I did it:

Code: Select all

sudo apt-get install build-essential dkms
git clone https://github.com/gnab/rtl8812au
In the rtl8812au folder
I made sure the T4UH AC1300 was present in

Code: Select all

rtl8812au/os_dep/linux/usb_intf.c

Then, within the rtl8812au folder, I did

Code: Select all

make
sudo make install
sudo depmod
Using

Code: Select all

iwlist chan
I saw the available channels.

Post Reply

Return to “Wireless”