SOLVED: HP Stream 11 Realtek Driver Fix On Mint 18.(2 or 3) Destroys Networking

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
pjc123
Level 2
Level 2
Posts: 57
Joined: Tue Apr 09, 2013 2:13 pm
Contact:

SOLVED: HP Stream 11 Realtek Driver Fix On Mint 18.(2 or 3) Destroys Networking

Post by pjc123 » Wed Dec 13, 2017 6:00 pm

NOTE: This pertains to the HP Stream model 11-r010nr with the rtl8723be chipset only (Others may or may not have the same chipset and/or have a second antenna).

Previously I was running Linux Mint 18.2 Cinnamon from a USB Flash Drive (Windows was installed on the laptop). The HP Stream has only one antenna but two antenna ports, but the driver picked the port with the missing antenna, which obviously resulted in very poor wifi reception. So for the past year I have used lwfinger's updated wireless drivers shown below and it has fixed the problem because it allows you to select the port with the antenna attached:

https://github.com/lwfinger/rtlwifi_new ... el_version

So now, since Windows no longer fits on the laptops main drive (puny 32GB eMMC chip), I just went ahead and replaced Windows with Linux Mint 18.2 Mate (Instead of Cinnamon). However, when I update the Realtek drivers with lwfingers driver's, the wireless icon in the bottom right of the screen disappears, so I have no way to connect to wifi. At that point I have to reinstall Linux Mint to get wireless back.

The only things that have changed from when this was working and not working are:
1) I am now running Linux Mint from the laptop itself and not from a USB Flash Drive.
2) I am now using Mate instead of Cinnamon because of the laptops low specs (2GB RAM, low end cpu) in order to speed up things a bit.
3) lwfingers old branch became obsolete
Before I needed to do "git checkout rock.new_btcoex".
And now it has changed to "git checkout kernel_version".

Is there something different between how Mint 18.2 MATE and Cinnamon perform wireless? What in the commands below are wiping out my wireless settings, and can they be restored after updating the drivers?

Here are the commands that used to work (The only change below is that I changed to the new kernel_version branch):

Code: Select all

$ git clone git://github.com/lwfinger/rtlwifi_new.git
$ cd rtlwifi_new
$ git checkout kernel_version
$ make
$ sudo make install

REBOOT THE LAPTOP

$ sudo modprobe -rv rtl8723be
$ sudo modprobe -v rtl8723be ant_sel=2
I don't see any errors when running "make" or "make install", but the modprobe commands just hang.

At this point wireless reception would normally increase dramatically, but like I mentioned before, now there is no wireless icon, so no wireless settings or wifi access point to pick. If it worked properly, I would then create the file /etc/modprobe.d/50-rtl8723be.conf and add the options "rtl8723be ant_sel=2 ips=0" so that the settings are retained after the laptop is booted.

SYSTEM REPORTS WITH STOCK MINT NETWORK DRIVERS (BEFORE IWFINGER DRIVERS):

inxi -Fxz

Code: Select all

System:    Host: <REMOVED> Kernel: 4.10.0-42-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.2 Sonya
Machine:   System: HP (portable) product: HP Stream Notebook v: Type1ProductConfigId
           Mobo: HP model: 815E v: 32.25 Bios: Insyde v: F.16 date: 03/09/2017
CPU:       Dual core Intel Celeron N3050 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6400
           clock speeds: max: 2160 MHz 1: 1586 MHz 2: 1779 MHz
Graphics:  Card: Intel Device 22b1 bus-ID: 00:02.0
           Display Server: X.org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           tty size: 135x34 Advanced Data: N/A for root
Audio:     Card Intel Device 2284 driver: snd_hda_intel bus-ID: 00:1b.0 Sound: ALSA v: k4.10.0-42-generic
Network:   Card: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be port: 1000 bus-ID: 02:00.0
           IF: wlo1 state: up mac: <filter>
Drives:    HDD Total Size: NA (-) ID-1: /dev/mmcblk0 model: N/A size: 31.3GB
Partition: ID-1: / size: 27G used: 11G (43%) fs: ext4 dev: /dev/mmcblk0p2
           ID-2: swap-1 size: 2.00GB used: 0.07GB (3%) fs: swap dev: /dev/mmcblk0p3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 32.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 213 Uptime: 11 min Memory: 1469.5/1857.8MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
inxi -Nn

Code: Select all

Network:   Card: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be
           IF: wlo1 state: up mac: <REMOVED>
iwconfig

Code: Select all

wlo1      IEEE 802.11  ESSID:"NETGEAR40"
          Mode:Managed  Frequency:2.462 GHz  Access Point: <REMOVED>
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=36/70  Signal level=-74 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:382   Missed beacon:0
rfkill list all

Code: Select all

0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
Last edited by pjc123 on Wed Jan 24, 2018 11:59 am, edited 4 times in total.

pjc123
Level 2
Level 2
Posts: 57
Joined: Tue Apr 09, 2013 2:13 pm
Contact:

Re: Updating Wireless Driver Kills Network Settings and ICON

Post by pjc123 » Tue Jan 23, 2018 5:01 pm

SOLVED: I found a post today from linuxquestions.org where a user noted that it is no longer necessary to use the lwfinger Realtek drivers because the antenna select option is now included in the Realtek drivers of the newer kernels, so only the last couple of steps in my last post are necessary. After applying those steps I am back to full wifi power again (I went from a 80 dBm signal to a 26 dBm signal afterwards, so immediately I knew it worked. Yippee!).

Here is that thread. (NOTE: See Post #10 for instructions pertaining to the steps for the newer kernels):

https://www.linuxquestions.org/question ... 175618967/

Post Reply

Return to “Wireless”