Mint freezes after connecting to WIFI

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
lw7
Level 1
Level 1
Posts: 5
Joined: Sat Dec 16, 2017 1:11 pm

Mint freezes after connecting to WIFI

Post by lw7 » Sat Dec 16, 2017 1:20 pm

Hello guys, I often struggle with wifi connectivity ; it's either too slow and working or like very good for a while then the system freezes ; it occured to me while using debian then with ubuntu and now with mint ...

wired connection works fine ( connection with my phone and sharing via a usb cable (temp solution))

Please help!!!!! :cry: :cry: :cry: :cry:

lw7
Level 1
Level 1
Posts: 5
Joined: Sat Dec 16, 2017 1:11 pm

Re: Mint freezes after connecting to WIFI

Post by lw7 » Mon Dec 18, 2017 7:43 am

Help please anyone?????????

User avatar
Pjotr
Level 19
Level 19
Posts: 9633
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Mint freezes after connecting to WIFI

Post by Pjotr » Mon Dec 18, 2017 8:19 am

a. Please generate an overview of your system like this:
- Launch a terminal window (this is how to launch a terminal window);
- make the terminal window full screen, to avoid chopped lines;
- Copy/paste this command into the terminal:

Code: Select all

inxi -Fxz
(if you type: the letter F is a capital letter)

Press Enter.

Copy/paste the output in your next message.

b. Do the same with the following three commands:

Code: Select all

rfkill list all
and:

Code: Select all

iwconfig
and:

Code: Select all

inxi -Nn
Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

lw7
Level 1
Level 1
Posts: 5
Joined: Sat Dec 16, 2017 1:11 pm

Re: Mint freezes after connecting to WIFI

Post by lw7 » Thu Dec 21, 2017 12:25 pm

A-

System: Host: LW Kernel: 4.10.17-041017-generic x86_64 (64 bit gcc: 6.3.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: System: ASUSTeK (portable) product: X553MA v: 1.0
Mobo: ASUSTeK model: X553MA v: 1.0
Bios: American Megatrends v: X553MA.209 date: 08/08/2014
CPU: Dual core Intel Celeron N2840 (-MCP-) cache: 1024 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8663
clock speeds: max: 2582 MHz 1: 1430 MHz 2: 1563 MHz
Graphics: Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@59.99hz
GLX Renderer: Mesa DRI Intel Bay Trail
GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio: Card Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: ALSA v: k4.10.17-041017-generic
Network: Card-1: Broadcom BCM43142 802.11b/g/n driver: wl bus-ID: 02:00.0
IF: wlp2s0 state: up mac: <filter>
Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 03:00.2
IF: enp3s0f2 state: down mac: <filter>
Drives: HDD Total Size: 502.0GB (18.1% used)
ID-1: /dev/sda model: ST500LT012 size: 500.1GB
ID-2: USB /dev/sdb model: Color_Line size: 1.9GB
Partition: ID-1: / size: 31G used: 21G (72%) fs: ext4 dev: /dev/sda4
ID-2: swap-1 size: 5.25GB used: 0.03GB (1%) fs: swap dev: /dev/sda3
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 64.0C mobo: N/A
Fan Speeds (in rpm): cpu: 2700
Info: Processes: 207 Uptime: 10 min Memory: 1290.5/1885.4MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

B-
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: brcmwl-0: Wireless LAN
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no


anbox0 no wireless extensions.

wlp2s0 IEEE 802.11 ESSID:"home"
Mode:Managed Frequency:2.412 GHz Access Point: 5C:03:39:3C:82:04
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:on

lo no wireless extensions.

enp3s0f2 no wireless extensions.



Network: Card-1: Broadcom BCM43142 802.11b/g/n driver: wl
IF: wlp2s0 state: up mac: 5c:93:a2:c2:3d:96
Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
driver: r8169
IF: enp3s0f2 state: down mac: ac:9e:17:e7:d0:b6

lw7
Level 1
Level 1
Posts: 5
Joined: Sat Dec 16, 2017 1:11 pm

Re: Mint freezes after connecting to WIFI

Post by lw7 » Thu Dec 28, 2017 2:05 pm

Hello? Anyone willing to help..... PLEASE ??? :cry: :cry:

User avatar
jimallyn
Level 17
Level 17
Posts: 7441
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Mint freezes after connecting to WIFI

Post by jimallyn » Thu Jan 04, 2018 2:43 pm

Bump.

Anybody able to help here?
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

JeremyB
Level 17
Level 17
Posts: 7892
Joined: Fri Feb 21, 2014 8:17 am

Re: Mint freezes after connecting to WIFI

Post by JeremyB » Thu Jan 04, 2018 5:46 pm

I would try

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf && systemctl restart network-manager.service
This will prevent Network Manager from enabling wifi power management since that causes a lot of issues

lw7
Level 1
Level 1
Posts: 5
Joined: Sat Dec 16, 2017 1:11 pm

Re: Mint freezes after connecting to WIFI

Post by lw7 » Fri Jan 05, 2018 11:18 am

JeremyB wrote:I would try

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf && systemctl restart network-manager.service
This will prevent Network Manager from enabling wifi power management since that causes a lot of issues
Tried it but the system still freezes

Post Reply

Return to “Wireless”