Wireless Card Not Detected

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
kc-
Level 1
Level 1
Posts: 3
Joined: Fri Dec 22, 2017 8:07 pm

Wireless Card Not Detected

Post by kc- » Fri Dec 22, 2017 8:44 pm

Hello, I just installed Linux Mint 18.3 Cinnamon and cannot find a way to connect wifi, though internet works with an ethernet cable.
Here is some more info:
inxi -Fx

Code: Select all

System:    Host: Ch3kPC Kernel: 4.10.0-42-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: ASUSTeK model: ROG STRIX B350-F GAMING v: Rev X.0x
           Bios: American Megatrends v: 0902 date: 09/08/2017
CPU:       Quad core AMD Ryzen 5 1500X (-HT-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 27945
           clock speeds: max: 3500 MHz 1: 1550 MHz 2: 1550 MHz 3: 1550 MHz
           4: 1550 MHz 5: 1550 MHz 6: 1550 MHz 7: 3000 MHz 8: 1550 MHz
Graphics:  Card: NVIDIA Device 1c82 bus-ID: 26:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 1050 Ti/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.90 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] Device 1457
           driver: snd_hda_intel bus-ID: 28:00.3
           Card-2 NVIDIA Device 0fb9 driver: snd_hda_intel bus-ID: 26:00.1
           Sound: Advanced Linux Sound Architecture v: k4.10.0-42-generic
Network:   Card: Intel I211 Gigabit Network Connection
           driver: igb v: 5.4.0-k port: e000 bus-ID: 1e:00.0
           IF: enp30s0 state: up speed: 1000 Mbps duplex: full
           mac: b0:6e:bf:bb:31:0d
Drives:    HDD Total Size: NA (-) ID-1: /dev/nvme0n1 model: N/A size: 250.1GB
Partition: ID-1: / size: 214G used: 16G (8%) fs: ext4 dev: /dev/nvme0n1p1
           ID-2: swap-1 size: 17.11GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: N/A mobo: N/A gpu: 0.0:27C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 245 Uptime: 37 min Memory: 2019.8/16039.4MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
iwconfig

Code: Select all

enp30s0   no wireless extensions.

lo        no wireless extensions.
ifconfig

Code: Select all

enp30s0   Link encap:Ethernet  HWaddr b0:6e:bf:bb:31:0d  
          inet addr:192.168.1.6  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::ef6f:a485:a8de:ae72/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5050 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4167 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2765037 (2.7 MB)  TX bytes:423917 (423.9 KB)
          Memory:f7500000-f751ffff 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:709 errors:0 dropped:0 overruns:0 frame:0
          TX packets:709 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:68757 (68.7 KB)  TX bytes:68757 (68.7 KB)
The following commands don't show anything when entered: lspci | grep -i wireless
and rfkill list

New to Linux, please go easy on me. Any help is greatly appreciated.

User avatar
kc1di
Level 14
Level 14
Posts: 5481
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless Card Not Detected

Post by kc1di » Sat Dec 23, 2017 6:10 am

Hello kc- and Welcome to Linux Mint Forums,

Is there by any chance a setting in your bios that turns the card on or off? Or a combination of keys that does?
on my laptop it the fn + f5 key.
Easy tips : https://easylinuxtipsproject.blogspot.com/ Pjotr's Great Linux projects page.
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

puddleglum
Level 1
Level 1
Posts: 37
Joined: Fri Dec 22, 2017 12:03 pm

Re: Wireless Card Not Detected

Post by puddleglum » Sat Dec 23, 2017 8:32 am

Your outputs aren't showing any wireless devices, only ethernet. To see your wifi hardware try running:

sudo lshw -sanitize -class network

kc-
Level 1
Level 1
Posts: 3
Joined: Fri Dec 22, 2017 8:07 pm

Re: Wireless Card Not Detected

Post by kc- » Sun Dec 24, 2017 8:04 pm

Hello kc1di,

Thanks for the reply. I wasn't able to find anything in bios to turn on the card. Trying to enable the wireless card using various commands in the terminal hasn't worked and no keys turn on wireless either.

kc-
Level 1
Level 1
Posts: 3
Joined: Fri Dec 22, 2017 8:07 pm

Re: Wireless Card Not Detected

Post by kc- » Sun Dec 24, 2017 8:09 pm

Hi puddleglum,

The command only shows ethernet, no wireless.

Code: Select all

sudo lshw -sanitize -class network

markedward88
Level 2
Level 2
Posts: 55
Joined: Mon Feb 01, 2016 2:23 pm

Re: Wireless Card Not Detected

Post by markedward88 » Mon Dec 25, 2017 5:59 am

according to asus website it appears that your mobo does NOT include wireless only lan

below are url's to verify

https://www.asus.com/us/Motherboards/RO ... -F-GAMING/

https://www.asus.com/us/Motherboards/RO ... fications/

https://www.asus.com/us/Motherboards/RO ... /HelpDesk/

Post Reply

Return to “Wireless”