Page 1 of 1

<SOLVED> b43 driver installation issue.

Posted: Tue Dec 26, 2017 4:37 pm
by Scottjo64
Hello,

I've tried in vain to install the Broadcom b43.x driver on two different laptop using a USB drive and copying and installing them per supplied instructions. I know the WiFi hardware works on both. I can swap to a HD w/Windows and they both operate correctly.

I do not have access to a hard network port, just wireless using another (this) laptop.

System A:
Dell Vostro 1500
Intel Dual Core x64
Win7

System B:
HP 355G2
AMD x64
4 core CPU

Both systems use the Broadcom b43 hardware as indicated by hardware scanning programs.

I searched for a day or two and I always find the same drivers and installation instructions that I've already tried.

If anyone has a link with better instructions and or a driver, it's much appreciated.

SJ

Re: b43 driver installation issue.

Posted: Tue Dec 26, 2017 4:51 pm
by JeremyB
What are the chips ID's

Code: Select all

lspci -nnk | grep -iA3 net
I believe they start with 14e4

Re: b43 driver installation issue.

Posted: Tue Dec 26, 2017 5:58 pm
by puddleglum
You should just be able to install "firmware-b43-installer" from Software Manager. This will also install 43-fwcutter and download, extract, and install the broadcom driver. Then you just activate it from the Driver Manager.

If you don't currently have access to the internet on the installed computer you will need to use another computer or the Windows OS on this computer to download the required files and then transfer them to your Linux computer for installation. You can use the Synaptic Package Manager to get a list of files to download for firmware-b43-installer and 43-fwcutter.

Re: b43 driver installation issue.

Posted: Tue Dec 26, 2017 6:11 pm
by JeremyB
puddleglum wrote:You should just be able to install "firmware-b43-installer" from Software Manager. This will also install 43-fwcutter and download, extract, and install the broadcom driver. Then you just activate it from the Driver Manager.

If you don't currently have access to the internet on the installed computer you will need to use another computer or the Windows OS on this computer to download the required files and then transfer them to your Linux computer for installation. You can use the Synaptic Package Manager to get a list of files to download for firmware-b43-installer and 43-fwcutter.
The Linux Mint has no internet connection, so that will not work
The poster could try downloading https://www.dropbox.com/s/7exlzch25ap6uha/b43.zip
Transfer it via thumb drive to the Linux Mint computer and then in terminal

Code: Select all

unzip b43.zip

Code: Select all

sudo mkdir /lib/firmware/b43

Code: Select all

sudo cp ~/b43/* /lib/firmware/b43/
Then reboot

Re: b43 driver installation issue.

Posted: Wed Dec 27, 2017 12:04 pm
by Scottjo64
That is correct, I do not have a ethernet web connection, just wireless. Unless I stumble across one in my travels.

The Dropbox link to b43.zip is dead. I found one on the Ubuntu site but, I had to register. C'est la vie.

I'll try it when I return home.

This will be the 4th time and hopefully the final one.

I'll keep you posted.

SJ

Re: b43 driver installation issue.

Posted: Wed Dec 27, 2017 4:13 pm
by puddleglum
Here is the one I used. Looks like that site is still there:

Code: Select all

wget -c http://www.lwfinger.com/b43-firmware/broadcom-wl-5.100.138.tar.bz2
with b43-fwcutter like so:

Code: Select all

wget -c http://mirrors.xmission.com/ubuntu/pool/main/b/b43-fwcutter/b43-fwcutter_018-2_amd64.deb
wget -c http://mirrors.xmission.com/ubuntu/pool/multiverse/b/b43-fwcutter/firmware-b43-installer_018-2_all.deb
tar xfvj broadcom-wl-5.100.138.tar.bz2
sudo b43-fwcutter -w /lib/firmware broadcom-wl-5.100.138/linux/wl_apsta.o

Re: b43 driver installation issue.

Posted: Fri Dec 29, 2017 7:28 pm
by Scottjo64
Well, stranger things have happened.

I finally get around to playing with the old Dell I dropped LM 18.3 on and obviously had Wifi driver issues.

I plug it in, turn it on and the WiFi lit up! Looks like the installation did work after all! Although I have NO FREAKIN idea why it worked after sitting idle for 4 days.

Go figure. But I am a happy guy! This week has been SWEEEEET!
deadpool.smiling.jpg