[SOLVED] Wireless: unavailable

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
ameliorate
Level 1
Level 1
Posts: 13
Joined: Sat Jan 13, 2018 10:33 am

[SOLVED] Wireless: unavailable

Post by ameliorate » Sat Jan 13, 2018 10:46 am

Hello guys,

First, I have to say that I am not that experienced with linux. Now here is my problem: I am using HP ProBook 450 G0 with the famous Ralink RT3290 Wireless card. Yesterday I installed Linux Mint 18.3 which was running perfect from LiveCD. After installation I cannot connect to internet via wireless, is says that is unavailable. I read multiple forums and none of the solution worked.

Code: Select all

rfkill unblock wifi
Didn't work.

Code: Select all

iwlist scan 
Returned this:
wlo1 Failed to read scan data : Network is down

lo Interface doesn't support scanning.

enp5s0 Interface doesn't support scanning.

Code: Select all

sudo ifconfig wlo1 up
Returns this error:
SIOCSIFFLAGS: Input/output error

Restarting network-manager didn't work as well.

Also, I have to mention that the wireless button on the laptop doesn't work, it stays orange, which usually shows that the wifi is turned off, but doesn't change upon pressing it. (It is working properly under Windows)

Thanks in advance for your answers, if you need any further information, I will be glad to share.

P.S. Sorry for my broken English :(
Last edited by ameliorate on Mon Jan 15, 2018 3:10 am, edited 2 times in total.

orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: Wireless: unavailable

Post by orschiro » Sat Jan 13, 2018 10:58 am

Yesterday I installed Linux Mint 18.2
Is there a specific reason why you are not trying 18.3?

ameliorate
Level 1
Level 1
Posts: 13
Joined: Sat Jan 13, 2018 10:33 am

Re: Wireless: unavailable

Post by ameliorate » Sat Jan 13, 2018 11:02 am

Not really, I was unable to download latest version and this is the one I had ready to install. Well, I will upgrade anyways, but was curious about this problem.

User avatar
kc1di
Level 13
Level 13
Posts: 4705
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless: unavailable

Post by kc1di » Sat Jan 13, 2018 11:02 am

could you post the output of the following command :

Code: Select all

inxi -nn
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

ameliorate
Level 1
Level 1
Posts: 13
Joined: Sat Jan 13, 2018 10:33 am

Re: Wireless: unavailable

Post by ameliorate » Sat Jan 13, 2018 11:05 am

Network: Card-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe driver: rt2800pci
IF: wlo1 state: down mac: xx:xx:xx:xx:xx:xx
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169
IF: enp5s0 state: up speed: 100 Mbps duplex: full
mac: xx:xx:xx:xx:xx:xx

returned from

Code: Select all

inxi -nn

User avatar
kc1di
Level 13
Level 13
Posts: 4705
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless: unavailable

Post by kc1di » Sat Jan 13, 2018 12:33 pm

I Believe the problem is that the wrong driver is loaded. it should be rt3290 not rt2800pci.
if you can connect via Ethernet cable they try going to Menu> Aministration> Driver Manager and see if it will offer you the correct driver
If not Then you can download if from here:
http://www.mediafire.com/file/l3zoch2y1 ... 290.tar.gz
Follow the instructions in the Readme.txt file.
good luck.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

ameliorate
Level 1
Level 1
Posts: 13
Joined: Sat Jan 13, 2018 10:33 am

Re: Wireless: unavailable

Post by ameliorate » Sun Jan 14, 2018 8:46 am

kc1di wrote:I Believe the problem is that the wrong driver is loaded. it should be rt3290 not rt2800pci.
if you can connect via Ethernet cable they try going to Menu> Aministration> Driver Manager and see if it will offer you the correct driver
If not Then you can download if from here:
http://www.mediafire.com/file/l3zoch2y1 ... 290.tar.gz
Follow the instructions in the Readme.txt file.
good luck.
There was only intel-microcode in Driver Manager.
After installing the driver from the link, wireless is completely gone. Doesn't show at all. :(

After I uninstalled it, instead of unavailable shows firmware missing and still nothing shows in Driver Manager.

EDIT: I ran

Code: Select all

apt-get upgrade
and it installed some firmware which made the wireless work, but after reboot it still shows unavailable.

JeremyB
Level 19
Level 19
Posts: 9138
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless: unavailable

Post by JeremyB » Sun Jan 14, 2018 12:56 pm

ameliorate wrote:Hello guys,

First, I have to say that I am not that experienced with linux. Now here is my problem: I am using HP ProBook 450 G0 with the famous Ralink RT3290 Wireless card. Yesterday I installed Linux Mint 18.3 which was running perfect from LiveCD. After installation I cannot connect to internet via wireless, is says that is unavailable. I read multiple forums and none of the solution worked.

Code: Select all

rfkill unblock wifi
Didn't work.

Code: Select all

iwlist scan 
Returned this:
wlo1 Failed to read scan data : Network is down

lo Interface doesn't support scanning.

enp5s0 Interface doesn't support scanning.

Code: Select all

sudo ifconfig wlo1 up
Returns this error:
SIOCSIFFLAGS: Input/output error

Restarting network-manager didn't work as well.

Also, I have to mention that the wireless button on the laptop doesn't work, it stays orange, which usually shows that the wifi is turned off, but doesn't change upon pressing it. (It is working properly under Windows)

Thanks in advance for your answers, if you need any further information, I will be glad to share.

P.S. Sorry for my broken English :(
I would try

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
Reboot

ameliorate
Level 1
Level 1
Posts: 13
Joined: Sat Jan 13, 2018 10:33 am

Re: Wireless: unavailable

Post by ameliorate » Sun Jan 14, 2018 1:38 pm

In my case

Code: Select all

dmesg | grep rt2800
returned :
[ 11.078868] rt2800pci 0000:04:00.0 wlo1: renamed from wlan0
[ 11.690672] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[ 11.771495] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[ 17.127921] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[ 17.134791] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10322.622326] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10323.627972] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10323.710015] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10323.717248] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10323.897852] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
Didn't work, still saying wireless: firmware missing

JeremyB
Level 19
Level 19
Posts: 9138
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless: unavailable

Post by JeremyB » Sun Jan 14, 2018 1:43 pm

ameliorate wrote:In my case

Code: Select all

dmesg | grep rt2800
returned :
[ 11.078868] rt2800pci 0000:04:00.0 wlo1: renamed from wlan0
[ 11.690672] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[ 11.771495] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[ 17.127921] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[ 17.134791] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10322.622326] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10323.627972] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10323.710015] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10323.717248] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10323.897852] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
Didn't work, still saying wireless: firmware missing

Code: Select all

wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/rt3290.bin
sudo cp rt3290.bin /lib/firmware/
Reboot

ameliorate
Level 1
Level 1
Posts: 13
Joined: Sat Jan 13, 2018 10:33 am

Re: Wireless: unavailable

Post by ameliorate » Sun Jan 14, 2018 2:04 pm

JeremyB wrote:
ameliorate wrote:In my case

Code: Select all

dmesg | grep rt2800
returned :

Code: Select all

[   11.078868] rt2800pci 0000:04:00.0 wlo1: renamed from wlan0
[   11.690672] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[   11.771495] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[   17.127921] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[   17.134791] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10322.622326] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10323.627972] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10323.710015] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10323.717248] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2
[10323.897852] rt2800pci 0000:04:00.0: Direct firmware load for rt3290.bin failed with error -2

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
Didn't work, still saying wireless: firmware missing

Code: Select all

wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/rt3290.bin
sudo cp rt3290.bin /lib/firmware/
Reboot
Now it doesn't say missing firmware, changed to "wireless unavailable" again :D

New return from

Code: Select all

dmesg | grep rt2800
:

Code: Select all

[   11.045758] rt2800pci 0000:04:00.0 wlo1: renamed from wlan0
[   13.713465] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   15.713420] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   15.713425] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   17.809401] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   19.809417] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   19.809428] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   21.861378] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   23.861327] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   23.861338] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   25.893211] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   27.893239] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   27.893250] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   30.041112] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   32.053151] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   32.053161] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   34.097094] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   36.097054] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   36.097066] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   40.068904] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   42.076863] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   42.076868] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   44.108816] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   46.116772] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   46.116777] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   58.084390] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   60.092330] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   60.092335] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   62.136266] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   64.136220] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   64.136247] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   76.079823] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   78.079772] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   78.079777] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   80.103729] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   82.103641] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   82.103647] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   94.075262] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   96.087198] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[   96.087204] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   98.115138] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[  100.115089] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[  100.115094] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  112.070700] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[  114.070635] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[  114.070640] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  116.102564] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[  118.106508] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068]
[  118.106514] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)

JeremyB
Level 19
Level 19
Posts: 9138
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless: unavailable

Post by JeremyB » Sun Jan 14, 2018 2:07 pm

See the wireless script link in my signature and post results
Actually can you get into the router settings and disable Wireless N mode and set it to b/g

ameliorate
Level 1
Level 1
Posts: 13
Joined: Sat Jan 13, 2018 10:33 am

Re: Wireless: unavailable

Post by ameliorate » Sun Jan 14, 2018 2:13 pm

JeremyB wrote:See the wireless script link in my signature and post results
Actually can you get into the router settings and disable Wireless N mode and set it to b/g
Me or the guy who invaded my topic? xD

I do not have access to the router.

JeremyB
Level 19
Level 19
Posts: 9138
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless: unavailable

Post by JeremyB » Sun Jan 14, 2018 2:30 pm

I guess you could post results from the script but I think the issue might be with having Wireless N mode enabled.

ameliorate
Level 1
Level 1
Posts: 13
Joined: Sat Jan 13, 2018 10:33 am

Re: Wireless: unavailable

Post by ameliorate » Sun Jan 14, 2018 2:35 pm

JeremyB wrote:I guess you could post results from the script but I think the issue might be with having Wireless N mode enabled.
File attached
Attachments
wireless-info.tar.gz
(5.81 KiB) Downloaded 153 times

JeremyB
Level 19
Level 19
Posts: 9138
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless: unavailable

Post by JeremyB » Sun Jan 14, 2018 2:39 pm

You could try deleting the wireless settings in Network Manager and then reboot to see if the wifi stays up
Post results for

Code: Select all

inxi -Fxz
Maybe one of the newest kernels may help

ameliorate
Level 1
Level 1
Posts: 13
Joined: Sat Jan 13, 2018 10:33 am

Re: Wireless: unavailable

Post by ameliorate » Sun Jan 14, 2018 2:45 pm

JeremyB wrote:You could try deleting the wireless settings in Network Manager and then reboot to see if the wifi stays up
Post results for

Code: Select all

inxi -Fxz
Maybe one of the newest kernels may help

Deleting setting didn't help.
Here is the result from inxi:
System: Host: ameliorate-pc Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: System: Hewlett-Packard (portable) product: HP ProBook 450 G0 v: A2018CD200
Mobo: Hewlett-Packard model: 1949 v: KBC Version 90.0D
Bios: Hewlett-Packard v: 68IRF Ver. F.25 date: 10/24/2013
CPU: Quad core Intel Core i7-3632QM (-HT-MCP-) cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 17560
clock speeds: max: 3200 MHz 1: 1375 MHz 2: 1437 MHz 3: 1437 MHz
4: 1210 MHz 5: 1618 MHz 6: 1224 MHz 7: 1343 MHz 8: 1199 MHz
Graphics: Card-1: Intel 3rd Gen Core processor Graphics Controller
bus-ID: 00:02.0
Card-2: Advanced Micro Devices [AMD/ATI] Mars [Radeon HD 8670A/8670M/8750M]
bus-ID: 01:00.0
Display Server: X.Org 1.18.4 drivers: ati,radeon,intel (unloaded: fbdev,vesa)
Resolution: 1366x768@59.99hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile
GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes
Audio: Card Intel 7 Series/C210 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network: Card-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe
driver: rt2800pci v: 2.3.0 bus-ID: 04:00.0
IF: wlo1 state: down mac: <filter>
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 05:00.0
IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 256.1GB (9.6% used)
ID-1: /dev/sda model: INTEL_SSDSC2KW25 size: 256.1GB
Partition: ID-1: / size: 220G used: 7.9G (4%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 17.02GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 49.0C mobo: 0.0C gpu: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 258 Uptime: 1 min Memory: 1064.7/15897.4MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

JeremyB
Level 19
Level 19
Posts: 9138
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless: unavailable

Post by JeremyB » Sun Jan 14, 2018 3:00 pm

If you know how to use the Grub menu at boot to use an older kernel I would install the newest 4.13 kernel and boot into it and see if it works. The kernel you have is EOL and vulnerable to Meltdown

ameliorate
Level 1
Level 1
Posts: 13
Joined: Sat Jan 13, 2018 10:33 am

Re: Wireless: unavailable

Post by ameliorate » Sun Jan 14, 2018 3:11 pm

JeremyB wrote:If you know how to use the Grub menu at boot to use an older kernel I would install the newest 4.13 kernel and boot into it and see if it works. The kernel you have is EOL and vulnerable to Meltdown
I can update the Kernel with Update Manager right?

JeremyB
Level 19
Level 19
Posts: 9138
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless: unavailable

Post by JeremyB » Sun Jan 14, 2018 3:22 pm

Yes you can use the Update Manager, click on View then Linux Kernels, you should see 4.13 on the left side of the kernel window

Post Reply

Return to “Wireless”