[SOLVED] Mint 18.3 laptop can't connect to WLAN

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 11
Joined: Fri Jan 15, 2016 7:40 pm

[SOLVED] Mint 18.3 laptop can't connect to WLAN

Post by dimic » Tue Jan 16, 2018 9:45 pm

Hello Mint-Users,
my problem is already solved, i post it for documentation and your information.

Existing WLAN network with Netgear WNR1000v3 router, Mint 18.2 laptop (Toshiba), iPhone 4, Playstation 3 => working fine.
Installed Mint 18.3 Sylvia Cinnamon on a new Asus VivoBook => no WLAN connection.
Tried to connect a new Brother printer via WLAN => no connection.

No new devices can connect to the WLAN router while old devices work fine.

Router firmware problem. Access control list (MAC address filter) is not processed properly for brand new devices.
Firmware could not be updated because the hardware was too old (> 8 years).

Buy a new WLAN router (Netgear WNR2000v5) with fresh firmware.
All devices can connect - including Mint 18.3. laptop.

Looked like "WLAN problem with Linux Mint 18.3" to me, because all devices worked, except the Mint 18.3 machine.
But then the Brother printer also could not connect.
Turned out to be a router firmware problem, the router does not support brand new WLAN adapters.
And I learned: when no firmware update is available any more, it's time to buy new hardware.
Last edited by dimic on Tue Jan 16, 2018 9:49 pm, edited 1 time in total.

User avatar
Level 18
Level 18
Posts: 8917
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Mint 18.3 laptop can't connect to WLAN [SOLVED]

Post by Pierre » Tue Jan 16, 2018 9:47 pm

that sure is an Linux thing - - re-using Old Hardware.
we are all guilty of that one.

but, sometimes, your hand is forced & a New Gadget is needed.
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Post Reply

Return to “Wireless”