Wireless intermittent (but frequent) failures - stuck at configuring interface

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Level 1
Level 1
Posts: 20
Joined: Thu Dec 28, 2017 10:55 pm

Wireless intermittent (but frequent) failures - stuck at configuring interface

Post by Swerve » Wed Jan 24, 2018 4:41 pm

Hi, I'm having problems with my wireless lately.

Long story short - new PC, new to Linux; originally I tried Ubuntu. I ordered a usb wireless dual band adapter, but I was naive and bought one that even said on its Amazon webpage (upon later inspection) "not compatible with Linux". So I ended up having to buy another 2.4 only usb adapter (only cheap one I could find) that said it was compatible.

Later though, after learning a bit more about Linux, I decided to try to hunt down a driver to make the first one work, because I wanted the 5.0 connection. Eventually I was successful.

However, then I decided I didn't like Ubuntu that much and switched to Mint 18.3 with KDE plasma desktop. Completely forgot to save the working driver I found, so at first I was again unable to use the dual band adapter. Eventually I stumbled on this page

viewtopic.php?f=53&t=238399&p=1270572&h ... r#p1270572

and this one worked. Happily ever after. For a while.

Past several days now, the connection will suddenly drop. It then hangs on "configuring interface", and after a few seconds says "Wireless network could not be found" and "deactivating connection". Then it tries to connect to the other version (it was on 5.0; now it tries to connect to 2.4) and does the same thing. Then it goes back and forth between trying to connect to 5.0 and 2.4, etc, several times with the same results before finally giving up. All the while, all the connections are visible in the network connections icon, along with all of my neighbors' connections.

Iirc, this was happening before the new kernel, although I did have to reinstall the driver to get it to work after installing the new kernel. The other adapter which always worked before also wouldn't work immediately after the new kernel was installed, but it started working later along with the dual band one. Unclear if installing the driver had anything to do with the other one working/not working since it worked fine without it before (but the timing of it working again was pretty coincidental in that case).

Finally, this morning, I noticed that when I booted up it connected to the 2.4 instead of the 5.0 as it usually did. I surfed a bit, so it was working, before I realized it and tried to switching to the 5.0. At this point it started the above behaviour, meaning that after being unable to connect to 5.0, it suddenly wouldn't connect to 2.4 anymore either, even though I was using that fine just a minute before. Rebooting my PC fixed it this time, but again it automatically connected to 2.4. I tried switching connections again just to see if it reproduced, and it did; rebooting a second time has me connected to 2.4 again no problem. The other day this also happened on its own in the middle of surfing, and iirc rebooting did not help it connect to either 2.4 or 5.0; eventually I went to sleep and woke up and it (including 5.0) was working fine.

Here is some terminal output that it seems like you guys like to ask for:

Code: Select all

~ $ lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0bda:a811 Realtek Semiconductor Corp.   <-
Bus 001 Device 003: ID 04d9:1503 Holtek Semiconductor, Inc. Keyboard
Bus 001 Device 002: ID 093a:2532 Pixart Imaging, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Code: Select all

~ $ inxi -Fzx

System:    Host: swerve Kernel: 4.13.0-31-generic x86_64 (64 bit gcc: 5.4.0) Desktop: KDE Plasma 5.8.8 (Qt 5.6.2)
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: MSI model: Z270-A PRO (MS-7A71) v: 1.0 Bios: American Megatrends v: 1.42 date: 09/13/2017
CPU:       Quad core Intel Core i7-7700K (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 33600
           clock speeds: max: 4500 MHz 1: 4200 MHz 2: 4200 MHz 3: 4200 MHz 4: 4200 MHz 5: 4200 MHz 6: 4200 MHz
           7: 4200 MHz 8: 4200 MHz
Graphics:  Card: NVIDIA Device 1b06 bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 1080 Ti/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.111 Direct Rendering: Yes
Audio:     Card-1 Intel Device a2f0 driver: snd_hda_intel bus-ID: 00:1f.3 Sound: ALSA v: k4.13.0-31-generic
           Card-2 NVIDIA Device 10ef driver: snd_hda_intel bus-ID: 01:00.1
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 1240.3GB (8.4% used) ID-1: /dev/sda model: WDC_WDS240G1G0A size: 240.1GB
           ID-2: /dev/sdb model: WDC_WD10EZEX size: 1000.2GB
Partition: ID-1: / size: 204G used: 82G (43%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 17.14GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:47C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 197 Uptime: 7 min Memory: 774.8/16003.4MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

Code: Select all

~ $ lsmod | grep rtl

rtl8812au            1351680  0
cfg80211              614400  1 rtl8812au

I might also note that, at one time, both adapters were plugged in (and seemed to be working) simultaneously. This may have been around when the problems started but I can't exactly recall.

One final note that may or may not be relevant:

In the connections manager, next to the 2.4 network name (and only the 2.4 name), is shows this: (wlp0s20f0u7)

I'm not 100% sure about this, but I'm almost certain that this extra bit wasn't there before i installed/starting using the extra driver. Now, when it starts doing it's back and forth deactivating bit, every message that pops up that says "Wireless network couldn't be found" has the title/larger text that says, more specifically, "Wireless interface (wlp0s20f0u7) couldn't be found" (paraphrased since I can't see it right now). It says this when it can't connect to 2.4 as well as when it can't connect to 5.0, even though the 5.0 doesn't have this extra bit next to its name.

Anyway. No idea if that means anything, but now you know what I know. Plus all the stuff you hopefully know on top of that.

Hoping this is a fixable driver issue. Please note that buying a third new adapter is not an option at this point. I'd really like to have the 5.0 working though if possible.

Thanks a lot in advance for any help anyone can provide.
Last edited by Swerve on Wed Jan 24, 2018 9:36 pm, edited 2 times in total.

User avatar
Level 1
Level 1
Posts: 20
Joined: Thu Dec 28, 2017 10:55 pm

Re: Wireless intermittent (but frequent) failures - stuck at configuring interface

Post by Swerve » Wed Jan 24, 2018 8:21 pm

Just a quick update:

I went through the connection manager and unticked all of the "connect automatically" checkboxes, so now upon reboot, it waits for me to select a network. The first network to which I then choose to connect works fine. However, once I've connected to a network, trying to change networks apparently breaks it again so that it can't reconnect to anything until another reboot. This holds true for simply disconnecting and trying to reconnect to the same network, so it looks like it's the mere deactivation of a connection that kicks the whole problem into motion.

So the good news is that I can now use whichever network I want if I stick with it, but the problem isn't really solved since obviously there's still something going on there.

User avatar
Level 1
Level 1
Posts: 20
Joined: Thu Dec 28, 2017 10:55 pm

Re: Wireless intermittent (but frequent) failures - stuck at configuring interface

Post by Swerve » Sat Jan 27, 2018 6:40 pm

Polite 48 hour+ bump.

In the interim, I happened to notice the "wireless script" in JeremyB's signature, so I downloaded and ran it. I ran it once while everything was working, then I tried to change networks, and when it went into its deactivating/'stuck at configuring interface' cycle, I ran the script again. Posting both results here in case there's a clue between the two as to why I can't switch networks without breaking my wireless.

Scripts were too long to post in a single post, so I linked the text of each here:



Post Reply

Return to “Wireless”