WiFi stops working after close laptop lid

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
rte638
Level 1
Level 1
Posts: 6
Joined: Mon Dec 05, 2016 5:47 pm

WiFi stops working after close laptop lid

Post by rte638 » Sun Jan 28, 2018 7:39 pm

I have a Dell Inspiron 15 3000 series running Mint 18.3 64bit, kernel 4.04.0-112 that recently developed a wifi connection problem.
When the pc is booted the wireless network connects automatically. When the laptop lid is closed and then reopened the wifi connection will not reconnect.
The Power Management settings for when lid is closed both ac power and battery are set to suspend. After the lid is opened, the Network setting for WiFi on/off can not be reset to on.

Any resolution suggestions are appreciated.

$ inxi -Fxz
System: Host: rte638-Satellite-C75D-B Kernel: 4.4.0-112-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine: System: TOSHIBA (portable) product: Satellite C75D-B v: PSCLEU-004002
Mobo: TOSHIBA model: Portable PC v: MP Bios: Insyde v: 1.40 date: 11/03/2014
CPU: Quad core AMD A6-6310 APU with AMD Radeon R4 Graphics (-MCP-) cache: 8192 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 14372
clock speeds: max: 1800 MHz 1: 1600 MHz 2: 1000 MHz 3: 1000 MHz 4: 1000 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R4/R5 Graphics] bus-ID: 00:01.0
Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1600x900@60.08hz
GLX Renderer: Gallium 0.4 on AMD MULLINS (DRM 2.43.0, LLVM 3.8.0)
GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio: Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel bus-ID: 00:14.2
Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio driver: snd_hda_intel bus-ID: 00:01.1
Sound: Advanced Linux Sound Architecture v: k4.4.0-112-generic
Network: Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 01:00.0
IF: enp1s0 state: down mac: <filter>
Card-2: Qualcomm Atheros AR9485 Wireless Network Adapter bus-ID: 05:00.0
IF: N/A state: N/A mac: N/A
Card-3: Ralink RT5370 Wireless Adapter driver: rt2800usb v: 2.3.0 usb-ID: 001-003
IF: wlx9cefd5ff870e state: N/A mac: N/A
Drives: HDD Total Size: 750.2GB (15.8% used) ID-1: /dev/sda model: HGST_HTS541075A9 size: 750.2GB
Partition: ID-1: / size: 207G used: 106G (55%) fs: ext4 dev: /dev/sda7
ID-2: swap-1 size: 5.33GB used: 0.05GB (1%) fs: swap dev: /dev/sda8
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 54.6C mobo: N/A gpu: 51.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 211 Uptime: 1:19 Memory: 3500.0/4921.0MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

iwconfig
lo no wireless extensions.

enp1s0 no wireless extensions.

wlx9cefd5ff870e IEEE 802.11bgn ESSID:"usr5461"
Mode:Managed Frequency:2.452 GHz Access Point: A0:04:60:69:5A:63
Bit Rate=120 Mb/s Tx-Power=30 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:on
Link Quality=63/70 Signal level=-47 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:178 Invalid misc:560 Missed beacon:0

inxi -Nn
Network: Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169
IF: enp1s0 state: down mac: 00:8c:fa:8a:9f:07
Card-2: Qualcomm Atheros AR9485 Wireless Network Adapter
IF: N/A state: N/A mac: N/A
Card-3: Ralink RT5370 Wireless Adapter driver: rt2800usb
IF: wlx9cefd5ff870e state: N/A mac: N/A

lsusb
Bus 002 Device 002: ID 0438:7900 Advanced Micro Devices, Inc.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 002: ID 0438:7900 Advanced Micro Devices, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 062a:4106 Creative Labs
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

User avatar
Joe2Shoe
Level 3
Level 3
Posts: 155
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: WiFi stops working after close laptop lid

Post by Joe2Shoe » Sun Jan 28, 2018 8:15 pm

On my 4 LM laptops, in Power Options, I choose "Do nothing" under "what to do when the lid is closed".
You may also want to disable power management for the WiFi adapter in your system.
Good luck.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

Post Reply

Return to “Wireless”