[SOLVED] Another HP laptop 3160 wifi issue

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Tue Feb 06, 2018 9:45 pm

[SOLVED] Another HP laptop 3160 wifi issue

Post by andrew66 » Tue Feb 06, 2018 10:16 pm

Hi Guy's,

Just a wireless networking question from a novice linux user.

I was given a 3 year old HP laptop with a dual band intel AC 3160 wireless chip. I have Linux Mint 18.1 Serena installed on it. Kernel 4.4.0-112-generic.
The unit has no wireless hardware on/off switch, just a software enable selector. It does have an airplane key but this makes no difference. There is no option in
the Bios to disable wireless. Every time I try to switch wireless on it instantly turns itself off. This seems to be a running theme with these chips. It is currently
connected by ethernet cable. I have tried a few solutions listed here and elsewhere over time all to no avail.

Then a few days ago while searching for something else I found a old 802.11bg USB wireless dongle. I thought I give this a go and plugged it in.
When I clicked on the network connection icon not only was the wireless dongle listed but the 3160 connection was also shown. I clicked on it and it connected
without issue. I could also remove the dongle once it was connected and it stayed connected. Once I disconnected the only way to get the 3160 connection
option to appear again was to insert the dongle. All the time the 3160 was connected the main wireless software on/off selector was showing off.

I'm wondering if this infomation offers any insight as to what might be happening
(why I cant select wireless on normally)


Code: Select all

inxi -Fx
System:    Host: NoteBook Kernel: 4.4.0-112-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.1 Serena
Machine:   System: Hewlett-Packard (portable) product: HP Pavilion x360 NoteBook PC v: Type1ProductConfigId
           Mobo: Hewlett-Packard model: 8074 v: 66.35
           Bios: Insyde v: F.35 date: 08/20/2015
CPU:       Dual core Intel Celeron N3050 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6399
           clock speeds: max: 2160 MHz 1: 1878 MHz 2: 1653 MHz
Graphics:  Card: Intel Device 22b1 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics (Cherryview)
           GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card Intel Device 2284 driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-112-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full
           mac: 30:8d:99:1c:42:df
           Card-2: Intel Wireless 3160 driver: iwlwifi bus-ID: 03:00.0
           IF: wlp3s0 state: down mac: e4:f8:9c:1e:a8:20
Drives:    HDD Total Size: 500.1GB (34.3% used)
           ID-1: /dev/sda model: HGST_HTS545050A7 size: 500.1GB
Partition: ID-1: / size: 455G used: 157G (37%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 4.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 45.0C mobo: 39.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 170 Uptime: 2:17 Memory: 1520.7/3811.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

wlp3s0    IEEE 802.11abgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
enp2s0    no wireless extensions.

tun0      no wireless extensions.

lo        no wireless extensions.

Code: Select all

rfkill list all
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: acer-wireless: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
Last edited by andrew66 on Wed Feb 07, 2018 11:47 pm, edited 2 times in total.

Level 1
Level 1
Posts: 2
Joined: Tue Feb 06, 2018 9:45 pm

Re: Another HP laptop 3160 wifi issue

Post by andrew66 » Wed Feb 07, 2018 10:08 pm

After doing some more searching on the forum I came across this advice which finally solved my problem.
Turn the kernel module acer_wmi off
1.7. A certain kernel module, called acer_wmi, causes problems on some laptops. Because it has been loaded when it shouldn't have been.

a. Launch a terminal window.
(You can launch a terminal window like this: *Click*)

b. Now check whether the module is loaded; copy/paste the following green command line into the terminal:

rfkill list all

Press Enter.

This command will tell you, how your wireless card is called. In many problem cases, it's called (among other things) like this:

1: acer-wireless: Wireless LAN
Soft blocked: yes
Hard blocked: no

The clue is then, that it's called acer-wireless (which means that acer_wmi is loaded) and that it has a soft block.

In such a case, proceed like this:

c. Copy/paste the following blue command line into the terminal (you can copy/paste with the right mouse button, it's one line):

sudo tee /etc/modprobe.d/blacklist-acer-wmi.conf <<< "blacklist acer_wmi"

Press Enter and submit your password. Please note that the password will remain invisible, not even asterisks will show, which is normal.

d. Reboot your computer.

Post Reply

Return to “Wireless”