Page 1 of 1

wireless connection issue on toshiba satellite c55-b854

Posted: Wed Feb 07, 2018 7:57 pm
by sharif tarig agabani
hi, i have recently installed linux mint unfortunately the wireless connection doesn't works, i found that the there is a hard block but the issue the bottom is not working after i installed linux mint when i were using windows i used to enable it by pressing fn+f12, kindly advise me what can i do
my labtop is toshiba satellite c55-b854


thanks

Re: wireless connection issue on toshiba satellite c55-b854

Posted: Thu Feb 08, 2018 6:49 am
by kc1di
Hello sharif tarig agabani and Welcome to Linux Mint Forums,
Could you go to a terminal and issue these commands one at a time and post the output here:

Code: Select all

inxi -Fxz
rfkill list

Re: wireless connection issue on toshiba satellite c55-b854

Posted: Fri Feb 09, 2018 7:39 pm
by sharif tarig agabani
agabani@agabani-Satellite-C55-B ~ $ inxi -Fxz
System: Host: agabani-Satellite-C55-B Kernel: 4.13.0-32-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: System: TOSHIBA product: Satellite C55-B v: PSKT4V-03V001AR
Mobo: Type2 - Board Vendor Name1 model: Type2 - Board Product Name1 v: Type2 - Board Version
Bios: Insyde v: 1.00 date: 03/03/2014
CPU: Dual core Intel Core i3-4005U (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6784
clock speeds: max: 1600 MHz 1: 1696 MHz 2: 1696 MHz 3: 1696 MHz
4: 1696 MHz
Graphics: Card: Intel Haswell-ULT Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@60.00hz
GLX Renderer: Mesa DRI Intel Haswell Mobile
GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes
Audio: Card-1 Intel 8 Series HD Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Card-2 Intel Haswell-ULT HD Audio Controller
driver: snd_hda_intel bus-ID: 00:03.0
Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network: Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
driver: ath9k bus-ID: 02:00.0
IF: wlp2s0 state: down mac: <filter>
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 03:00.0
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 500.1GB (2.1% used)
ID-1: /dev/sda model: TOSHIBA_MQ01ABF0 size: 500.1GB
Partition: ID-1: / size: 455G used: 6.3G (2%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 4.22GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 48.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 187 Uptime: 26 min Memory: 807.3/3873.4MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35
agabani@agabani-Satellite-C55-B ~ $ rfkill list
0: Toshiba Bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
2: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no

Re: wireless connection issue on toshiba satellite c55-b854

Posted: Fri Feb 09, 2018 7:53 pm
by sharif tarig agabani
kc1di wrote:
Thu Feb 08, 2018 6:49 am
Hello sharif tarig agabani and Welcome to Linux Mint Forums,
Could you go to a terminal and issue these commands one at a time and post the output here:

Code: Select all

inxi -Fxz
rfkill list

Code: Select all

agabani@agabani-Satellite-C55-B ~ $ inxi -Fxz
System:    Host: agabani-Satellite-C55-B Kernel: 4.13.0-32-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: TOSHIBA product: Satellite C55-B v: PSKT4V-03V001AR
           Mobo: Type2 - Board Vendor Name1 model: Type2 - Board Product Name1 v: Type2 - Board Version
           Bios: Insyde v: 1.00 date: 03/03/2014
CPU:       Dual core Intel Core i3-4005U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6784
           clock speeds: max: 1600 MHz 1: 1696 MHz 2: 1696 MHz 3: 1696 MHz
           4: 1696 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile
           GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Haswell-ULT HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network:   Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           driver: ath9k bus-ID: 02:00.0
           IF: wlp2s0 state: down mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 500.1GB (2.1% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABF0 size: 500.1GB
Partition: ID-1: / size: 455G used: 6.3G (2%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 4.22GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 48.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 187 Uptime: 26 min Memory: 807.3/3873.4MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
agabani@agabani-Satellite-C55-B ~ $ rfkill list
0: Toshiba Bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
2: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no

Re: wireless connection issue on toshiba satellite c55-b854

Posted: Fri Feb 09, 2018 8:24 pm
by kc1di
According to the rfkill command your wireless card is hard blocked. Which means card is turned off by a hardwire switch. and must be turned on manually.
According to the manual fn+F12 should unblock the card. If that is not working You may be able to find a setting in bios, But there has to be some manual switch.

Re: wireless connection issue on toshiba satellite c55-b854

Posted: Sat Feb 10, 2018 7:26 am
by sharif tarig agabani
thank you, but i already tried that an found that fn+f12 control the soft block not the hard block i ll mentioned the both situation on/off bellow
when i press fn+f12 it gives:

Code: Select all

agabani@agabani-Satellite-C55-B ~ $ rfkill list all
0: Toshiba Bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
3: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no

when i close it it gives :
[code] agabani@agabani-Satellite-C55-B ~ $ rfkill list all
0: Toshiba Bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: yes
3: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no

Re: wireless connection issue on toshiba satellite c55-b854

Posted: Sat Feb 10, 2018 7:45 am
by JeremyB
You could try going into BIOS/UEFI settings at boot and see if resetting to defaults clears the hard block, if not, shutdown the computer, remove battery and power cord and hold the power button for 30 seconds, put it back together and see if wifi works

Re: wireless connection issue on toshiba satellite c55-b854

Posted: Sat Feb 10, 2018 7:46 am
by kc1di
you can try this in the terminal

Code: Select all

rfkill unblock all 
also preform the steps JeremyB suggested.

Re: wireless connection issue on toshiba satellite c55-b854

Posted: Sat Feb 10, 2018 7:57 am
by sharif tarig agabani
same issue

Code: Select all

agabani@agabani-Satellite-C55-B ~ $ rfkill unblock all
agabani@agabani-Satellite-C55-B ~ $ rfkill list all
0: Toshiba Bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
3: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

Re: wireless connection issue on toshiba satellite c55-b854

Posted: Sat Feb 10, 2018 8:09 am
by kc1di
Did you look in bios/uefi ?
The hard block needs to be cleared and it is not a software issue but a machine issue.

Re: wireless connection issue on toshiba satellite c55-b854

Posted: Mon Feb 12, 2018 10:08 am
by sharif tarig agabani
it works thank you all , i searched in boot sitting i didn't find w lan settings,but i did jeremmyb solution and it works,
many thanks for your support.

Re: wireless connection issue on toshiba satellite c55-b854

Posted: Mon Feb 12, 2018 10:27 am
by kc1di
Glad you found the solution, enjoy :)
please take a moment and edit the subject line in your original post and mark it as solved - Thanks.