Error when trying to install TP-Link AC600 T2UH Archer

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
amiibonovation
Level 1
Level 1
Posts: 5
Joined: Mon Feb 26, 2018 6:21 am

Error when trying to install TP-Link AC600 T2UH Archer

Post by amiibonovation » Mon Feb 26, 2018 6:26 am

Currently using version 4.13.0-36-generic kernel

I have followed the instructions given here:

https://askubuntu.com/questions/674116/ ... nk-mt7610u

However the problem is when i get to

Code: Select all

make
command i get the error

Code: Select all

In function ‘memcpy’,
    inlined from ‘rt_ioctl_iwaplist’ at /home/dev/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux/../../os/linux/sta_ioctl.c:696:2:
./include/linux/string.h:305:4: error: call to ‘__read_overflow2’ declared with attribute error: detected read beyond size of object passed as 2nd parameter
    __read_overflow2();
Now i have done a google search for this problem and found this as a solution: https://github.com/jurobystricky/Netgea ... /issues/81

Code: Select all

@firemaricius
First suggestion: Please put code or terminal output in code blocks. See the "Styling with Markdown is supported" link below the comment box for details.

To all of you:
I guess that Arch (and maybe other distros too) use different (more pedantic) options to build the kernel and its modules, helping us to find programming mistakes. I am not sure whether this is correct, but you can try this (and please report back whether it worked):
In os/linux/sta_ioctl.c:549, replace addr[0] with struct sockaddr so the line looks like this

    memcpy(extra, addr, i*sizeof(struct sockaddr));

instead of

    memcpy(extra, addr, i*sizeof(addr[0]));
I applied this solution but the problem still remains, i changed those lines but the error still remains

Anyone know how to fix this?

JeremyB
Level 19
Level 19
Posts: 9435
Joined: Fri Feb 21, 2014 8:17 am

Re: Error when trying to install TP-Link AC600 T2UH Archer

Post by JeremyB » Mon Feb 26, 2018 6:42 am


Post Reply

Return to “Wireless”