wifi suddenly stops in mint 18.3

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
lightdarkx
Level 1
Level 1
Posts: 7
Joined: Thu Jan 18, 2018 7:54 am

wifi suddenly stops in mint 18.3

Post by lightdarkx » Fri Mar 02, 2018 2:50 pm

I have a hp omen ax-250tx with specks:-(code for inxi -Fx)

Code: Select all

System:    Host: ld-pc Kernel: 4.13.0-36-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9) Distro: Linux Mint 18.3 Sylvia
Machine:   System: HP (portable) product: OMEN by HP Laptop v: Type1ProductConfigId
           Mobo: HP model: 8259 v: 83.72 Bios: Insyde v: F.45 date: 01/25/2018
CPU:       Quad core Intel Core i7-7700HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464
           clock speeds: max: 3800 MHz 1: 2800 MHz 2: 2800 MHz 3: 2800 MHz 4: 2800 MHz
           5: 2800 MHz 6: 2800 MHz 7: 2800 MHz 8: 2800 MHz
Graphics:  Card-1: Intel Device 591b bus-ID: 00:02.0
           Card-2: NVIDIA Device 1c8c bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.02hz
           GLX Renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card Intel Device a171 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-36-generic
Network:   Card-1: Intel Wireless 7265 bus-ID: 04:00.0
           IF: N/A state: N/A mac: N/A
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 05:00.0
           IF: eth0 state: down mac: 3c:52:82:30:7d:17
Drives:    HDD Total Size: 1128.2GB (4.7% used)
           ID-1: /dev/sda model: SanDisk_SD8SNAT size: 128.0GB temp: 41C
           ID-2: /dev/sdb model: HGST_HTS721010A9 size: 1000.2GB temp: 0C
Partition: ID-1: / size: 50G used: 12G (25%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 197G used: 38G (21%) fs: ext4 dev: /dev/sdb3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 52.5C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 250 Uptime: 4:23 Memory: 1855.4/15926.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
The internal wifi card works fine but sometimes, automatically gets switched off until I reboot the pc.
Using

Code: Select all

sudo service networking restart
or

Code: Select all

sudo service network-manager restart
doesn't help.

The output for ifconfig is

Code: Select all

eth0      Link encap:Ethernet  HWaddr 3c:52:82:30:7d:17  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:99459 errors:0 dropped:0 overruns:0 frame:0
          TX packets:99459 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:20128389 (20.1 MB)  TX bytes:20128389 (20.1 MB)

wlan0     Link encap:Ethernet  HWaddr c0:25:e9:18:d3:79  
          inet addr:172.16.41.181  Bcast:172.16.127.255  Mask:255.255.128.0
          inet6 addr: fe80::7550:f239:2a2a:13e8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:114881 errors:0 dropped:65015 overruns:0 frame:0
          TX packets:5324 errors:0 dropped:2 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:31365620 (31.3 MB)  TX bytes:1332042 (1.3 MB)
The results of iwconfig is

Code: Select all

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"MY WIFI"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.437 GHz  Access Point: 0A:18:D6:C7:3A:36   
          Bit Rate:72.2 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=66/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
The result of sudo lshw -C network is

Code: Select all

 *-network UNCLAIMED     
       description: Network controller
       product: Wireless 7265
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 61
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:b4200000-b4201fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: eth0
       version: 15
       serial: 3c:52:82:30:7d:17
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168h-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:130 ioport:3000(size=256) memory:b4104000-b4104fff memory:b4100000-b4103fff
  *-network
       description: Wireless interface
       physical id: 3
       bus info: usb@1:1
       logical name: wlan0
       serial: c0:25:e9:18:d3:79
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=r8188eu ip=172.16.41.181 multicast=yes wireless=IEEE 802.11bgn
The rfkill list all doesn't show anything related to wifi so I think its not blocked

Code: Select all

0: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no
I don't know what to do to fix the issue, if its a driver problem, then please tell me how to download and install the drivers.

NOTE- I an using an usb wifi adapter (TL-WN722N) to connect to internet.
NOTE2-I use mint in dual-boot with windows 10. Their is no issue with windows 10 as well as ubuntu 16.04 which I used previously in the same machine.

User avatar
Spearmint2
Level 15
Level 15
Posts: 5749
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: wifi suddenly stops in mint 18.3

Post by Spearmint2 » Fri Mar 02, 2018 3:37 pm

not restart but start. Try this instead.

Code: Select all

sudo service network-manager start
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
greerd
Level 5
Level 5
Posts: 986
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: wifi suddenly stops in mint 18.3

Post by greerd » Fri Mar 02, 2018 5:11 pm

lightdarkx wrote:
Fri Mar 02, 2018 2:50 pm
Soft blocked: yes
Hard blocked: no
Gleaned from one of JeremyB's posts, try

Code: Select all

sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*
to disable power management.

EDIT: Might have to reboot after.

lightdarkx
Level 1
Level 1
Posts: 7
Joined: Thu Jan 18, 2018 7:54 am

Re: wifi suddenly stops in mint 18.3

Post by lightdarkx » Tue Mar 06, 2018 8:00 am

greerd wrote:
Fri Mar 02, 2018 5:11 pm
lightdarkx wrote:
Fri Mar 02, 2018 2:50 pm
Soft blocked: yes
Hard blocked: no
Gleaned from one of JeremyB's posts, try

Code: Select all

sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*
to disable power management.

EDIT: Might have to reboot after.
I tried but the problem remains.

And the lines you quoted, I think that shows the soft block for the Bluetooth (as I disable it )
Last edited by lightdarkx on Tue Mar 06, 2018 8:03 am, edited 1 time in total.

lightdarkx
Level 1
Level 1
Posts: 7
Joined: Thu Jan 18, 2018 7:54 am

Re: wifi suddenly stops in mint 18.3

Post by lightdarkx » Tue Mar 06, 2018 8:01 am

Spearmint2 wrote:
Fri Mar 02, 2018 3:37 pm
not restart but start. Try this instead.

Code: Select all

sudo service network-manager start
Nothing happens if I type the code. Any other solution??

asinoro
Level 4
Level 4
Posts: 246
Joined: Mon Feb 12, 2018 11:43 am

Re: wifi suddenly stops in mint 18.3

Post by asinoro » Tue Mar 06, 2018 9:00 am

Try to install 4.4 lts kernel.
viewtopic.php?t=223244

User avatar
Spearmint2
Level 15
Level 15
Posts: 5749
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: wifi suddenly stops in mint 18.3

Post by Spearmint2 » Tue Mar 06, 2018 9:13 am

Only a link. I use 17.3 and it works there, but I see things have changed in 18.3, so maybe as others stated, you have driver problem, so give you this link.

viewtopic.php?t=226293

I suspect the driver being used is not the correct one, shown below. You should check what the device itself identifies as using lsusb command. Maybe then we can determine the correct driver for it. It may be you have to do similar as in the above link.

Code: Select all

           
  *-network
       description: Wireless interface
       physical id: 3
       bus info: usb@1:1
       logical name: wlan0
       serial: c0:25:e9:18:d3:79
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=r8188eu ip=172.16.41.181 multicast=yes wireless=IEEE 802.11bgn           
           
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

lightdarkx
Level 1
Level 1
Posts: 7
Joined: Thu Jan 18, 2018 7:54 am

Re: wifi suddenly stops in mint 18.3

Post by lightdarkx » Tue Mar 06, 2018 9:19 am

Spearmint2 wrote:
Tue Mar 06, 2018 9:13 am
Only a link. I use 17.3 and it works there, but I see things have changed in 18.3, so maybe as others stated, you have driver problem, so give you this link.

viewtopic.php?t=226293

I suspect the driver being used is not the correct one, shown below. You should check what the device itself identifies as using lsusb command. Maybe then we can determine the correct driver for it. It may be you have to do similar as in the above link.

Code: Select all

           
  *-network
       description: Wireless interface
       physical id: 3
       bus info: usb@1:1
       logical name: wlan0
       serial: c0:25:e9:18:d3:79
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=r8188eu ip=172.16.41.181 multicast=yes wireless=IEEE 802.11bgn           
           
The problem is with the inbuilt wifi adapter not with the USB one(as I am using that to connect to the internet).

User avatar
Spearmint2
Level 15
Level 15
Posts: 5749
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: wifi suddenly stops in mint 18.3

Post by Spearmint2 » Tue Mar 06, 2018 9:36 am

For further info;

https://www.privateinternetaccess.com/f ... workaround

You use both wifi devices? This is the internal one.

Code: Select all

Card-1: Intel Wireless 7265 bus-ID: 04:00.0
           IF: N/A state: N/A mac: N/A
you said;
The internal wifi card works fine but sometimes, automatically gets switched off until I reboot the pc.
So, this doesn't even seem a wifi problem as much as a power control problem. Have you checked your power settings to see if some of them may be causing this? Just to check it out, make all power off timed settings be many hours, or turned off totally, see if the problem continues.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

Henway
Level 1
Level 1
Posts: 1
Joined: Fri Feb 16, 2018 9:41 am

Re: wifi suddenly stops in mint 18.3

Post by Henway » Thu Mar 08, 2018 9:11 am

I saw on Utube that setting your router to only broadcast on one channel (static rather than dynamic) was a fix. I'm trying it now and it seems to have helped thou it's only been a couple days. NOTE: it helps to check on what channels other wifi networks in your area are using so you can select one that is possibly more "isolated"

Post Reply

Return to “Wireless”