[SOLVED]Have a problem to connect to the WiFi

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
User avatar
XoFoX1995
Level 1
Level 1
Posts: 11
Joined: Mon Mar 05, 2018 8:27 am
Location: Iran _ NKH

[SOLVED]Have a problem to connect to the WiFi

Post by XoFoX1995 » Mon Mar 05, 2018 8:44 am

HI everyone... :D
Recently I've decided to install a Linux and test it out for the first time...
And I searched alot in the Internet and finaly find the mighty mint and all I read about it is good things and I have decided to installed it in to my low end lap top... :lol: But
After installation is Done... I think I have a WiFi problem because WiFi was there I mean I have the option but the WiFi device can't find any WiFi signals at all...
SO
I searched alot for the solution but I can't find it and so I decided to create this topic to find the method to solve this problem... OK
And finally im pretty much newbie with Linux and seek for the solution please if anyone can help me
Last edited by XoFoX1995 on Mon Mar 05, 2018 6:28 pm, edited 2 times in total.
wait... wait... wait... ok go

User avatar
Moem
Level 15
Level 15
Posts: 5847
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Have a problem to connect to the WiFi

Post by Moem » Mon Mar 05, 2018 8:49 am

Latest Linux Mint is 18.3, not 18.
Are you using Cinnamon, KDE, XFCE or Mate?

The easiest way to answer that question, and give is lots of useful information about your hardware, is to post the result of the following terminal command, and enclose it in code tags. That's the button marked </>. Can you please do that?
This is needed for pretty much any question about your system, so it's a good habit to post it straight away.

Code: Select all

inxi -Fxz
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
XoFoX1995
Level 1
Level 1
Posts: 11
Joined: Mon Mar 05, 2018 8:27 am
Location: Iran _ NKH

Re: Have a problem to connect to the WiFi

Post by XoFoX1995 » Mon Mar 05, 2018 8:59 am

I'm using the Cinnamon version of the linux mint and thats what the code gave me.
and sorry for not knowing that im not used any forum in my life this is the first time newbie

Code: Select all

System:    Host: ali-S12T-3M-S12-3M Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: Micro-Star model: MS-124K v: REV:1.0
           Bios: American Megatrends v: E124KAMS.301 date: 03/17/2014
CPU:       Dual core AMD E1-2100 APU with Radeon HD Graphics (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 3992
           clock speeds: max: 1000 MHz 1: 1000 MHz 2: 900 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Kabini [Radeon HD 8210]
           bus-ID: 00:01.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: AMD KABINI (DRM 2.49.0 / 4.10.0-38-generic, LLVM 5.0.0)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Realtek RTL8723AE PCIe Wireless Network Adapter
           driver: rtl8723ae port: e000 bus-ID: 01:00.0
           IF: wlp1s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros AR8161 Gigabit Ethernet
           driver: alx port: d000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (8.5% used)
           ID-1: /dev/sda model: WDC_WD5000LPVX size: 500.1GB
Partition: ID-1: / size: 147G used: 6.3G (5%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 116G used: 30G (27%) fs: ext4 dev: /dev/sda7
           ID-3: swap-1 size: 4.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 53.0C mobo: N/A gpu: 51.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 180 Uptime: 44 min Memory: 1117.8/3400.0MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
Last edited by XoFoX1995 on Mon Mar 05, 2018 9:12 am, edited 3 times in total.
wait... wait... wait... ok go

User avatar
Moem
Level 15
Level 15
Posts: 5847
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Have a problem to connect to the WiFi

Post by Moem » Mon Mar 05, 2018 9:01 am

That's what you get when you use f, but I asked for the result with F.

Cinnamon is nice, I'm using it too!
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
XoFoX1995
Level 1
Level 1
Posts: 11
Joined: Mon Mar 05, 2018 8:27 am
Location: Iran _ NKH

Re: Have a problem to connect to the WiFi

Post by XoFoX1995 » Mon Mar 05, 2018 9:03 am

sorry i don't get it :?:
oh i get it now im fix in iit right away
:D :D
wait... wait... wait... ok go

User avatar
XoFoX1995
Level 1
Level 1
Posts: 11
Joined: Mon Mar 05, 2018 8:27 am
Location: Iran _ NKH

Re: Have a problem to connect to the WiFi

Post by XoFoX1995 » Mon Mar 05, 2018 9:06 am

THE CODE RESULT EDITED
wait... wait... wait... ok go

Marziano
Level 6
Level 6
Posts: 1346
Joined: Thu Jan 04, 2018 1:00 pm

Re: Have a problem to connect to the WiFi

Post by Marziano » Mon Mar 05, 2018 9:12 am

Would you please post the output from:

Code: Select all

rfkill list all
?
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

User avatar
XoFoX1995
Level 1
Level 1
Posts: 11
Joined: Mon Mar 05, 2018 8:27 am
Location: Iran _ NKH

Re: Have a problem to connect to the WiFi

Post by XoFoX1995 » Mon Mar 05, 2018 9:14 am

This is the result...

Code: Select all

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
wait... wait... wait... ok go

Marziano
Level 6
Level 6
Posts: 1346
Joined: Thu Jan 04, 2018 1:00 pm

Re: Have a problem to connect to the WiFi

Post by Marziano » Mon Mar 05, 2018 9:21 am

Have you installed the drivers specific to your hardware?
You can go to Settings: Driver Manager and see if there are any suggested driver there. If positive, install and reboot.
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

User avatar
XoFoX1995
Level 1
Level 1
Posts: 11
Joined: Mon Mar 05, 2018 8:27 am
Location: Iran _ NKH

Re: Have a problem to connect to the WiFi

Post by XoFoX1995 » Mon Mar 05, 2018 9:28 am

The only thing that Driver manager shows me is this:
http://i64.tinypic.com/zv5xzl.png
wait... wait... wait... ok go

Marziano
Level 6
Level 6
Posts: 1346
Joined: Thu Jan 04, 2018 1:00 pm

Re: Have a problem to connect to the WiFi

Post by Marziano » Mon Mar 05, 2018 9:40 am

They are installed.
Please post the outpu from:

Code: Select all

iwconfig
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

User avatar
XoFoX1995
Level 1
Level 1
Posts: 11
Joined: Mon Mar 05, 2018 8:27 am
Location: Iran _ NKH

Re: Have a problem to connect to the WiFi

Post by XoFoX1995 » Mon Mar 05, 2018 9:56 am

Here is the result

Code: Select all

lo        no wireless extensions.

wlp1s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          
enp2s0    no wireless extensions.

enp0s19f2u1  no wireless extensions.
wait... wait... wait... ok go

User avatar
XoFoX1995
Level 1
Level 1
Posts: 11
Joined: Mon Mar 05, 2018 8:27 am
Location: Iran _ NKH

Re: Have a problem to connect to the WiFi

Post by XoFoX1995 » Mon Mar 05, 2018 10:28 am

I used the command that u gave me but nothing changed...
it's still the same...
deleted why?
wait... wait... wait... ok go

Marziano
Level 6
Level 6
Posts: 1346
Joined: Thu Jan 04, 2018 1:00 pm

Re: Have a problem to connect to the WiFi

Post by Marziano » Mon Mar 05, 2018 10:39 am

Try this:

Code: Select all

sudo ifconfig wlp1s0  up
and then run this:

Code: Select all

iwlist wlp1s0  scan
Wrong of me to delete. Just wanted to make a correction. Sorry about that.
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

Marziano
Level 6
Level 6
Posts: 1346
Joined: Thu Jan 04, 2018 1:00 pm

Re: Have a problem to connect to the WiFi

Post by Marziano » Mon Mar 05, 2018 11:18 am

XoFoX1995 wrote:
Mon Mar 05, 2018 9:56 am

Code: Select all

 wlp1s0    IEEE 802.11  ESSID:off/any 
I wonder if ESSID:off/any means that there are no signals from the router.


When I run iwconfig, I get this:

Code: Select all

lo        no wireless extensions.
wlp2s0    IEEE 802.11  ESSID:"my_network_name"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 4F:35:F3:7B:5D:3E   
          Bit Rate=121.5 Mb/s   Tx-Power=16 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-30 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:509  Invalid misc:1530   Missed beacon:0
enp3s0f2  no wireless extensions.
Would anybody looking in lend us a hand ?
Thanks!
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx


User avatar
XoFoX1995
Level 1
Level 1
Posts: 11
Joined: Mon Mar 05, 2018 8:27 am
Location: Iran _ NKH

Re: Have a problem to connect to the WiFi

Post by XoFoX1995 » Mon Mar 05, 2018 6:27 pm

Men YOU are the savior thanks a lot
:D :D And thank u for everyone that help me today
U found a new proud member of the Linux Mint community.
I'm going to Flagged this topic solved THANKS...
  • thanks
    thanks
    thanks
wait... wait... wait... ok go

Post Reply

Return to “Wireless”