Connectivity issues

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
KaiKemmann
Level 1
Level 1
Posts: 1
Joined: Mon Apr 23, 2018 8:59 am

Connectivity issues

Post by KaiKemmann » Mon Apr 23, 2018 11:59 am

My network manager in Linux Mint 18.2 with XFCE used to display widely varying wireless connection speeds between 1 and 54 Mb/s (or more when using an USB wlan adaptor).
The internet connection used to change accordingly between very slow and quite decent and would sometimes be interrupted for a few hours in between.

Restarting the browser or the computer or unplugging an external USB network adapter (TP-Link TL-WN722N) did sometimes help, but not reliably.

Up to 20 other wlan networks with a slightly lower signal are detected so there might be some interference.
But this can probably not explain why at the moment I can usually either use the internet with a decent speed or not at all (i.e. apparently unrelated to the connection speed).

Firefox displays "server not found" or sometimes "the connection has timed out". Chrome says something like 'there is no internet connection'. Gmail in browser says "not connected"

Other computers or mobile phones are not affected. Also changing between the wifi router and its repeater or to a different wifi router does not seem to make a change.

After not being able to use the internet for three days I took the notebook computer to a friend where it worked right away.
Back home it worked for some hours but since then the on/off pattern seems to persist.

Here is some more information (some of the commands were run with the external USB network adapter "TP-Link TL-WN722N" plugged in, some without):

- lspci RESULTS in
02:04.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

- lsusb RESULTS in (with TP-Link TL-WN722N adaptor plugged in)
Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n

- sudo lshw -C network RESULTS in (with TP-Link TL-WN722N adaptor plugged in)
*-network:0 description: Network controller product: BCM4306 802.11b/g Wireless LAN Controller vendor: Broadcom Corporation physical id: 4 bus info: pci@0000:02:04.0 version: 03 width: 32 bits clock: 33MHz capabilities: bus_master configuration: driver=b43-pci-bridge latency=64 resources: irq:21 memory:d0000000-d0001fff
*-network:1 description: Ethernet interface product: BCM4401-B0 100Base-TX vendor: Broadcom Corporation physical id: e bus info: pci@0000:02:0e.0 logical name: eth0 version: 02 serial: 00:12:79:c3:1e:3e
*-network description: Wireless interface physical id: 1 logical name: wlan0 serial: 00:90:4b:ad:97:59 capabilities: ethernet physical wireless configuration: broadcast=yes driver=b43 driverversion=4.4.0-21-generic firmware=666.2 ip=192.168.0.102 link=yes multicast=yes wireless=IEEE 802.11bg

- rfkill list all SHOWS nothing is blocked

- cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf RESULTS in
[connection] wifi.powersave = 2

- nxi -Fxz RESULTS in
System: Host: compaq Kernel: 4.4.0-21-generic i686 (32 bit gcc: 5.3.1) Desktop: Xfce 4.12.3 (Gtk 2.24.28)
Distro: Linux Mint 18.2 Sonya
Machine: System: Hewlett-Packard product: HP Compaq nx6110 (PT601ET#ABD) v: F.03
Mobo: Hewlett-Packard model: 3088 v: KBC Version 39.18
Bios: Hewlett-Packard v: 68DTD Ver. F.03 date: 02/25/2005
CPU: Single core Intel Celeron M (-UP-) cache: 1024 KB
flags: (pae sse sse2) bmips: 2793 speed: 1396 MHz (max)
Graphics: Card: Intel Mobile 915GM/GMS/910GML Express Graphics Controller bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x768@61.32hz
GLX Renderer: Mesa DRI Intel 915GM x86/MMX/SSE2 GLX Version: 1.4 Mesa 12.0.6 Direct Rendering: Yes
Audio: Card Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller
driver: snd_intel8x0 ports: 2100 2200 bus-ID: 00:1e.2
Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network: Card-1: Broadcom BCM4306 802.11b/g Wireless LAN Controller driver: b43-pci-bridge bus-ID: 02:04.0
IF: wlan0 state: up mac: <filter>
Card-2: Broadcom BCM4401-B0 100Base-TX driver: b44 v: 2.0 bus-ID: 02:0e.0
IF: eth0 state: down mac: <filter>
Drives: HDD Total Size: 40.0GB (90.8% used) ID-1: /dev/sda model: FUJITSU_MHT2040A size: 40.0GB
Partition: ID-1: / size: 35G used: 32G (98%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 2.14GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 65.0C mobo: 49.0C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 175 Uptime: 15:56 Memory: 1424.7/2006.0MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

- iwconfig RESULTS in
wlx74ea3a901293 IEEE 802.11bgn ESSID:"Supercontroller"
Mode:Managed Frequency:2.462 GHz Access Point: 34:31:C4:81:18:51
Bit Rate=48 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=27/70 Signal level=-83 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:3 Invalid misc:1 Missed beacon:0
wlan0 IEEE 802.11bg ESSID:"Casahegel"
Mode:Managed Frequency:2.412 GHz Access Point: E0:60:66:93:9A:24
Bit Rate=48 Mb/s Tx-Power=4 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=46/70 Signal level=-64 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:3797 Invalid misc:11048 Missed beacon:0
lo no wireless extensions.
eth0 no wireless extensions.

- inxi -Nn RESULTS in
Network: Card-1: Broadcom BCM4306 802.11b/g Wireless LAN Controller driver: b43-pci-bridge
IF: wlan0 state: up mac: 00:90:4b:ad:97:59
Card-2: Broadcom BCM4401-B0 100Base-TX driver: b44
IF: eth0 state: down mac: 00:12:79:c3:1e:3e
Card-3: Atheros AR9271 802.11n
IF: N/A state: N/A mac: N/A

Strangely the 'ping' command always produces error messages, no matter whether a connection is possible or not:
ping 8.8.8.8 -c 4
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
ping: sendmsg: Operation not permitted
OR
ping google.com -c 4
PING google.com (216.58.205.238) 56(84) bytes of data.
ping: sendmsg: Operation not permitted

After reading through some suggestions in various forums I tried the following with not apparent results:

- sudo service network-manager restart
- sudo systemctl restart NetworkManager
- /etc/init.d/network-manager force-reload
- sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
- sudo sysctl -w net.ipv4.ip_forward=1
- sudo iptables -A POSTROUTING --table nat -o %wlan0 -j MASQUERADE

- iwlist scan | egrep -i 'ssid|quality|address' RESULTS IN
lo Interface doesn't support scanning.
eth0 Interface doesn't support scanning.
Cell 01 - Address: C0:25:E9:3E:1E:78
Quality=54/70 Signal level=-56 dBm
ESSID:"casahegel_mobile"

- cat wireless-info.txt | nc termbin.com 9999 RESULTS IN
nc: getaddrinfo: Temporary failure in name resolution

- cat /run/resolvconf/resolv.conf AND cat /etc/resolv.conf RESULT IN
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1

- 802.11 WiFi (wlx74ea3a901293) RESULTS IN
bash: syntax error near unexpected token `('

- ifconfig wlan0 mtu 1400 up RESULTS IN
SIOCSIFMTU: Operation not permitted
SIOCSIFFLAGS: Operation not permitted

- in "NetworkManager.conf" I CHANGED
dns=dnsmasq TO # dns=dnsmasq
AND ADDED
[device]
wifi.scan-rand-mac-address=no

Did I change anything relevant or can I leave everything as is?

I download the Ubuntuforums wireless diagnostic script -as suggested- with this command:
wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireles ... eless-info && chmod +x wireless-info

I ran " ./wireless-info " when the connection was interrupted and will try to attach the file.
When trying to use Pastebin Firefox complained "Secure connection failed". But now it seems to have worked: https://pastebin.com/Vx1JZ5E3

Thank you very much for any assistance.

Kai Kemmann

br1anstorm
Level 4
Level 4
Posts: 200
Joined: Mon Nov 24, 2014 8:53 am

Re: Connectivity issues

Post by br1anstorm » Tue May 01, 2018 5:21 pm

I'm only posting here as a way of bumping this up. I saw this thread when browsing the 'Wireless' forum because I have recently also posted a request for advice.

I'm afraid I don't have any wisdom to offer. I just think it's rather a shame that more than a week has passed since Kai, the OP, posted these extremely detailed queries, as a newly signed-up member in first-ever post on the forum....... and no-one has responded.

Any wireless experts out there who could offer a helping hand????

Post Reply

Return to “Wireless”