Page 1 of 1

the restricted drivers disapeared

Posted: Sun May 20, 2007 8:28 am
by Wh1sper
Hi, I am a German guy who tries his brand new Asus G1 Laptop to Linuxify :)
First let me say a few words about me. I would describe myself as a advanced linuxuser. More than 10 years ;) Most of time I am using Debian unstable.
I am always looking for the ongoing success for ununtu, but did not use it by myself so far. Cassandra is very impressive. Even most of my Fn-Keys are working..! The Live Casandra has worked nearly out of the box. the wireless nonfree driver for the Intel Pro 3945ABG could connect with wpa.
After installation just in between setup the wireless connection there disapeared the non free driver. Now I am using the default normal driver with wep.
thats ok for now, no problem, but there seems something wrong with the switching between different networks, say 2 wireless and the lan. ....But never mind thats not on the top list and I think that is only a question of time :)
Now my question: where is the nonfree driver stuff? in the mintconfig there it is gone also... the notebook has a nvidia 7700 device, I have installed the driver with envy. So there is no really need for this I am just wondering.

Posted: Sun May 20, 2007 3:32 pm
by Husse
Welcome to Mint Wh1sper
I'm not in Cassandra right now so my advice will be a bit vague.
Somewhere in Control Center there is a Restricted drivers section - I think the icon looks a bit like a circuit board.
This is at least for video drivers - if for wifi as well I don't think so. Possibly ndiswrapper can get you wap - look at one of the stickys in this section

Posted: Mon May 21, 2007 3:53 am
by Wh1sper
Thanks for reply
That is the problem, this Icon disapeared also.
Would you please tell what the physical name of it is?
So I would able to search for and start it manually..

Posted: Mon May 21, 2007 5:39 am
by Husse
This command in a terminal
gksu -D /usr/share/applications/restricted-manager.desktop /usr/bin/restricted-manager
starts the restricted manager
It's in the system section of the Control Center if everything is as it should be

Posted: Mon May 21, 2007 12:05 pm
by Wh1sper
Husse wrote:This command in a terminal
gksu -D /usr/share/applications/restricted-manager.desktop /usr/bin/restricted-manager
starts the restricted manager
It's in the system section of the Control Center if everything is as it should be
Worked! And it is in the Menu again... :roll:

Posted: Mon May 21, 2007 2:32 pm
by Wh1sper
..and now to the mainproblem :)
once a time I had the option to connect to my wpa encrypted wlan.
Now, this is not possible, only connect to wep encrypted wlan is possible.
and second there apears no icon with the strength of the connected wlan
with wpa that was in the lower panel. how comes?

Posted: Mon May 21, 2007 8:46 pm
by Boo
are you using the network manager applet? next to the clock.

there is a stick post in wireless about getting it to work.

it may have more encryption selections.

:D

Posted: Tue May 22, 2007 12:23 am
by Wh1sper
Its the symbol with two stacked computers. I can only choose manual network configuration.
I thought, I saw the wireless
i
ii
iii
iiii
Symbol ..
Strange

Posted: Tue May 22, 2007 2:06 am
by Boo
check this post out:
http://www.linuxmint.com/forum/viewtopic.php?t=2577

you have to only have the loopback interfaces listed in /etc/network/interfaces to reset the network manager applet to then use it properly.

:D

Posted: Tue May 22, 2007 4:37 am
by Wh1sper
This did not help. I tried this at first :)

Posted: Wed May 23, 2007 2:05 pm
by Wh1sper
Because I uninstalled the ugly Vista and installed an old XP. I decided to install mint once agfain, now with my experience ;) in handling linuxmint.
I did not configure the wlan in live-mode, but installed at once.
Now there are all icons that dissapered by my former install now there where they should be :)

Posted: Thu May 24, 2007 5:57 am
by Husse
Everything working?
That's a relief :)