Problems connecting linux laptop to mobile phone hotspot

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
stuart57
Level 1
Level 1
Posts: 1
Joined: Tue Jul 16, 2013 10:45 am

Problems connecting linux laptop to mobile phone hotspot

Post by stuart57 » Tue May 01, 2018 10:43 am

Hello,
My son surfs the web on his Mac Air connected to his iphone hotspot; the Mac Air is now kaput and I was going to lend him my Linux Laptop (Lenovo ThinkPad X260) for the same purpose; however the Linux laptop will not connect to his iphone hotspot.
In troubleshooting this, I have experimented at home with my android phone (Samsung Galaxy S7).
I can setup a mobile hotspot on my Samsung, but, although I can see the AndroidAP network on available wireless wifi, I cannot connect; I have used correct password authentication.
I have also tried USB connection with USB tethering - in this case it "connects" but I am unable to view webpages on either Mozilla Firefox or Chromium.
I HAVE been able to connect to the Samsung AndroidAP wifi hotspot with a spare MacBook Pro laptop which connects and opens webpages easily; the only thing I had to do to get that going, after initial problems, was to reset my network settings on my Samsung phone. That now works seamlessly.

But I need my Linux laptop to connect.
On USB tethering, when it does connect, I cannot ping www.google.com, but I can ping 8.8.8.8
I have tried adding in the DNS Server which is listed on my MacBook Pro - namely 192.168.43.1 - on my Linux Laptop, on Network Connections, under IPv4 Settings, but this makes no difference.

On my Linux Laptop, I am using:
Linux Mint 18.3 Cinnamon 64-bit
Cinnamon Version 3.6.7

Here are my inxi -Fxz, and lsusb reports attached.

Thanks for any help.

Stuart

Code: Select all

stuart@stuart-ThinkPad-X260 ~ $ inxi -Fxz
System:    Host: stuart-ThinkPad-X260 Kernel: 4.13.0-39-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: LENOVO (portable) product: 20F6CTO1WW v: ThinkPad X260
           Mobo: LENOVO model: 20F6CTO1WW v: SDK0J40697 WIN Bios: LENOVO v: R02ET48W (1.21 ) date: 06/01/2016
CPU:       Dual core Intel Core i5-6200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9600
           clock speeds: max: 2800 MHz 1: 500 MHz 2: 500 MHz 3: 500 MHz 4: 500 MHz
Graphics:  Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1368x768@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-39-generic
Network:   Card-1: Intel Ethernet Connection I219-V driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: down mac: <filter>
           Card-2: Intel Wireless 8260 driver: iwlwifi bus-ID: 04:00.0
           IF: wlp4s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (41.9% used) ID-1: /dev/sda model: ST500LM000 size: 500.1GB
Partition: ID-1: / size: 451G used: 188G (44%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 472M used: 324M (73%) fs: ext2 dev: /dev/sda1
           ID-3: swap-1 size: 7.99GB used: 0.00GB (0%) fs: swap dev: /dev/dm-3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 38.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 207 Uptime: 1:47 Memory: 1146.3/7411.0MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

stuart@stuart-ThinkPad-X260 ~ $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 138a:0017 Validity Sensors, Inc. Fingerprint Reader
Bus 001 Device 004: ID 04f2:b52c Chicony Electronics Co., Ltd 
Bus 001 Device 013: ID 04e8:6863 Samsung Electronics Co., Ltd GT-I9500 [Galaxy S4] / GT-I9250 [Galaxy Nexus] (network tethering)
Bus 001 Device 002: ID 062a:4102 Creative Labs 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub[code]

Post Reply

Return to “Wireless”