"Wi-Fi Network Authentication" keeps popping up RESOLVED

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
wind_rose_2
Level 1
Level 1
Posts: 45
Joined: Sun Nov 12, 2017 12:32 am

"Wi-Fi Network Authentication" keeps popping up RESOLVED

Post by wind_rose_2 » Fri May 04, 2018 11:38 pm

l am using my Windows laptop to contact you as my Lenovo Linux with Cinnamon Mint 19.3 is having connection issues that l can't seem to resolve.

I had been online all day and had just finished watching an online broadcast that l usually watch daily. When l disconnected from the website and went to try to check my mail l had a message popup "Wi-Fi Network Authentication Required". This is the normal window that would popup when logging into a network but l have the machine set to automatic connect to my home network.

This message is constantly popping up and l can press connect and it will connect me momentarily then l am thrown out and the pop up comes up again.

I have disconnected from the network and reconnected, l have rescanned for networks and reconnected to mine but keep getting the pop up asking for my password, l have shut the wi fi off and restarted it , l have not shut down my router as it is working because l am using it to write to you.

I checked my network settings after shutting it off and it says Wi-Fi Unavailable,as it should, then l turn it back on and it shows my network but every time l clic on my network to access l get the pop up asking for Authentication.

I thought it may have been my server but as l said this laptop is working fine and has been solid. When l check my network it shows my correct Mac address (hardware) and shows signal strength is Excellent, it indicates the IPv4 as being "automatic" as is the IPv6 .
I am new to Linux and other than the steep learning curve have adapted well and not had any issues .

Every time l click to Authenticate (Connect) the pop up closes then reopens again. At my wits end right now..l am just going to do the old windows fix..shut it all off and restart (in the morning) maybe whatever it is will correct itself.

Any help you may offer is gratefully received.
Dave
Last edited by wind_rose_2 on Tue May 08, 2018 7:33 pm, edited 1 time in total.

User avatar
kc1di
Level 13
Level 13
Posts: 4779
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: "Wi-Fi Network Authentication" keeps popping up

Post by kc1di » Sat May 05, 2018 6:26 am

Please generate a profile of your system by going to a terminal and entering this command and posting the results back here:

Code: Select all

inxi -Fxz
Place the result withing the code tags </> found in the tool bar.
Thanks.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

wind_rose_2
Level 1
Level 1
Posts: 45
Joined: Sun Nov 12, 2017 12:32 am

Re: "Wi-Fi Network Authentication" keeps popping up

Post by wind_rose_2 » Sat May 05, 2018 7:48 am

If the computer with the issue is not on line should i save the information requested onto a memory stick to bring it over to this computer so l can post it?

I have just placed my curser over the Software Sources icon (bottom right of screen ) and a message appeared.."Your apt cache is corrupted, do not try to update ,change mirrors" or to that effect as it disappeared.
I have gone to the Software Sources and selected "Restore Defaults" but because of no connection they will not load, they start (having a momentary connection) then stop.

User avatar
kc1di
Level 13
Level 13
Posts: 4779
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: "Wi-Fi Network Authentication" keeps popping up

Post by kc1di » Sat May 05, 2018 8:14 am

Sound like you have more problems than just the wireless but lets start with that first.
yes any way you can post the data will be fine.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

wind_rose_2
Level 1
Level 1
Posts: 45
Joined: Sun Nov 12, 2017 12:32 am

Re: "Wi-Fi Network Authentication" keeps popping up

Post by wind_rose_2 » Sat May 05, 2018 8:55 am

dave@linuxmint18 ~ $ sudo inxi -Fxz
[sudo] password for dave:
System: Host: linuxmint18 Kernel: 4.13.0-39-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: System: LENOVO product: 20266 v: Lenovo Yoga 2 Pro
Mobo: LENOVO model: Yoga2 v: 31900058WIN
Bios: LENOVO v: 76CN43WW date: 03/30/2015
CPU: Dual core Intel Core i5-4210U (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9577
clock speeds: max: 2700 MHz 1: 1080 MHz 2: 1207 MHz 3: 1315 MHz
4: 1287 MHz
Graphics: Card: Intel Haswell-ULT Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: X.org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
tty size: 80x24 Advanced Data: N/A for root
Audio: Card-1 Intel 8 Series HD Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Card-2 Intel Haswell-ULT HD Audio Controller
driver: snd_hda_intel bus-ID: 00:03.0
Sound: Advanced Linux Sound Architecture v: k4.13.0-39-generic
Network: Card: Intel Wireless 7260 driver: iwlwifi bus-ID: 01:00.0
IF: wlp1s0 state: down mac: <filter>
Drives: HDD Total Size: 190.1GB (19.1% used)
ID-1: /dev/sda model: RTMMA128JHV4MWX size: 128.0GB temp: 40C
ID-2: USB /dev/sdb model: Ultra_Fit size: 62.1GB temp: 0C
Partition: ID-1: / size: 110G used: 25G (24%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 8.50GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 48.5C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 207 Uptime: 1:20 Memory: 2077.5/7893.4MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (sudo) inxi: 2.2.35
dave@linuxmint18 ~ $

User avatar
kc1di
Level 13
Level 13
Posts: 4779
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: "Wi-Fi Network Authentication" keeps popping up

Post by kc1di » Sat May 05, 2018 9:53 am

You have an intel card and the correct driver is installed.
First thing I would try is to disable the power management feature.

First try this in a terminal

Code: Select all

sudo iwconfig wlan0 power off 
Note change wlan0 to the actual name of your card, for example mine is wlps0. you can find yours by typing

Code: Select all

iwconfig
this page may be of help in doing that.
https://unix.stackexchange.com/question ... ermanently
after reboot
let me know if it's working?
If not we will do something different.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

wind_rose_2
Level 1
Level 1
Posts: 45
Joined: Sun Nov 12, 2017 12:32 am

Re: "Wi-Fi Network Authentication" keeps popping up

Post by wind_rose_2 » Sat May 05, 2018 10:45 am

In the screenshot l sent that would be the Network card? and the number/letters i am seeing would be wlpls0 correct?

so it would be
sudo iwconfig wlpls0 power off
correct?

User avatar
kc1di
Level 13
Level 13
Posts: 4779
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: "Wi-Fi Network Authentication" keeps popping up

Post by kc1di » Sat May 05, 2018 11:01 am

Yes that's correct if thats the name assigned to your wifi card.

That command will only be temporary until you reboot in order to make it permanent you'll have to follow the instruction on the page I referenced.

but give it a try and see if it stops the disconnects they do the permanent fix.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

wind_rose_2
Level 1
Level 1
Posts: 45
Joined: Sun Nov 12, 2017 12:32 am

Re: "Wi-Fi Network Authentication" keeps popping up

Post by wind_rose_2 » Sat May 05, 2018 11:37 am

Ok So l used that letter numeral sequence shown under Network on the screenshot ( IF: wlpls0 ) without the... IF: And it comes back as
Error for wireless request "Set Power Management" (8B2C) :
SET failed on device wlpsl0 ; No such device

So either l am using the wrong number/letters or l am missing something?
dave@linuxmint18 ~ $ sudo iwconfig wlpls0 power off
[sudo] password for dave:
Error for wireless request "Set Power Management" (8B2C) :
SET failed on device wlpls0 ; No such device.
dave@linuxmint18 ~ $ sudo iwconfig wlpls0 power off
Error for wireless request "Set Power Management" (8B2C) :
SET failed on device wlpls0 ; No such device.
dave@linuxmint18 ~ $ sudo iwconfig
wlp1s0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=22 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off

wind_rose_2
Level 1
Level 1
Posts: 45
Joined: Sun Nov 12, 2017 12:32 am

Re: "Wi-Fi Network Authentication" keeps popping up

Post by wind_rose_2 » Sat May 05, 2018 11:38 am

OH I SEE! It must be wlp1so....l will try that!

User avatar
CaptainKirksChair
Level 4
Level 4
Posts: 315
Joined: Sat Feb 18, 2017 9:29 pm

Re: "Wi-Fi Network Authentication" keeps popping up

Post by CaptainKirksChair » Sat May 05, 2018 11:40 am

Another possibility is disabling IPv6. I had a similar issue with an Atheros wifi card and disabling IPv6 solved my connection issues.

From the menu, open Network. Find your wireless network connection. There should be a tool (configuration) icon. Click it. Choose IPv6 and then move the slider to Off. Click Apply to save the changes. You may have two wireless networks; one for 2.4Ghz and the other for 5Ghz. Try with just one first and if that works, configure the other one similarly. You should probably reboot after that change just to see if everything holds between restarts.

wind_rose_2
Level 1
Level 1
Posts: 45
Joined: Sun Nov 12, 2017 12:32 am

Re: "Wi-Fi Network Authentication" keeps popping up

Post by wind_rose_2 » Sat May 05, 2018 11:48 am

I have managed to "Power Off" in the terminal, rebooted and no change.

wind_rose_2
Level 1
Level 1
Posts: 45
Joined: Sun Nov 12, 2017 12:32 am

Re: "Wi-Fi Network Authentication" keeps popping up

Post by wind_rose_2 » Sat May 05, 2018 11:56 am

I have disabled th IPv6 and no immediate change l will now reboot and try it again

wind_rose_2
Level 1
Level 1
Posts: 45
Joined: Sun Nov 12, 2017 12:32 am

Re: "Wi-Fi Network Authentication" keeps popping up

Post by wind_rose_2 » Sat May 05, 2018 12:06 pm

It is like a switch, l turn in on and it shuts itself off

User avatar
kc1di
Level 13
Level 13
Posts: 4779
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: "Wi-Fi Network Authentication" keeps popping up

Post by kc1di » Sat May 05, 2018 1:42 pm

if you type the command

Code: Select all

iwconfig
what does it say?
post the results here.
should look something like this:

Code: Select all

 wlp3s0  IEEE 802.11  ESSID:
          Mode:Managed  Frequency:2.462 GHz  Access Point: C0:3F:0E:C7:95:E4   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
On mine you'll notice Power Management: is ON
now after the command

Code: Select all

sudo iwconfig wlp3s0 power off 
it should look like this

Code: Select all

wlp3s0    IEEE 802.11  ESSID:
          Mode:Managed  Frequency:2.462 GHz  Access Point: C0:3F:0E:C7:95:E4   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
that's temporary though if you reboot it will revert to on. You need to make the change in the file I posted before and save it. to make it permanently remain off.
By the way the designation of you wireless card will look similar to this

Code: Select all

wlp3s0 
.
IPV6 may cause problems also and should be set to ignore.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

wind_rose_2
Level 1
Level 1
Posts: 45
Joined: Sun Nov 12, 2017 12:32 am

Re: "Wi-Fi Network Authentication" keeps popping up

Post by wind_rose_2 » Sat May 05, 2018 2:28 pm

you will see the results at the bottom of the terminal print out that l had previously sent (right at the bottom)

User avatar
kc1di
Level 13
Level 13
Posts: 4779
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: "Wi-Fi Network Authentication" keeps popping up

Post by kc1di » Sat May 05, 2018 3:17 pm

ok lets try it this way see if it will work for you. In a terminal copy or type the following command and hit enter.

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
The reboot.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

wind_rose_2
Level 1
Level 1
Posts: 45
Joined: Sun Nov 12, 2017 12:32 am

Re: "Wi-Fi Network Authentication" keeps popping up

Post by wind_rose_2 » Sat May 05, 2018 3:26 pm

That does nothing.

wind_rose_2
Level 1
Level 1
Posts: 45
Joined: Sun Nov 12, 2017 12:32 am

Re: "Wi-Fi Network Authentication" keeps popping up

Post by wind_rose_2 » Sat May 05, 2018 3:37 pm

I have noticed that when l check the available networks in Network Settings my server is check marked (sometimes) as being on and then to the right there is the settings (gear wheel) a padlock and a signal image. I have noticed that 3 other (unknown to me) routers are also indicating the Gear Wheel image..what might that indicate..that they are set to automaticly connect? How could l remove the gear symbols?

User avatar
kc1di
Level 13
Level 13
Posts: 4779
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: "Wi-Fi Network Authentication" keeps popping up

Post by kc1di » Sun May 06, 2018 7:58 am

I would suggest you change the channel of your system so that it does not get interference from the other routers. You may also want to change the password if your able to do that. The problem may be that all those routers NM is trying to connect to are all on the same channel and thus NM will try to connect to the strongest one.
this page may help. If yours router's signal drop off for even a second NM will try to reconnect to a different router thus dropping your connection.
https://www.howtogeek.com/197268/how-to ... ng-system/

I know in my situation channel 11 turned out to be the best compromise between interference and good connection speed. Yours may differ.

good luck.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

Post Reply

Return to “Wireless”