rtl8723be wifi performance is very poor [SOLVED]

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
wosser
Level 1
Level 1
Posts: 5
Joined: Sat May 05, 2018 9:35 am

rtl8723be wifi performance is very poor [SOLVED]

Post by wosser » Sat May 05, 2018 10:07 am

I'm attempting to configure a 2 year old HP laptop (model: 15-ay023na) to run a fresh install of Linux Mint 18.3 Sylvia (Kernel 4.13.0-39-generic).

However it seems that the wifi connection reliability has diminished considerably. This machine used to run Windows 10 with no wifi problems anywhere in the house. Under linux mint the wifi only works if I'm within about 10 feet of the router box. So I'm thinking it's a config option that needs setting somewhere in Mint on the laptop.

Note that ALL other WIFI enabled devices are still working absolutely fine, so I'm happy that the problem is not with the WIFI router.

The laptop's WIFI chipset is (according to dmesg) "rtl8723be".

What I've tried so far (to no avail...)
  • Setting the "Regulatory" locale to be "GB" (the default was DE for some reason).
  • apt-get update and apt-get upgrade, the system seems to be very up to date.
  • Driver Manager did install some "ubuntu firmware" but showed no details.
  • Turned off Bluetooth (handled by the same chipset apparently).
  • Numerous reboots throughout all these attemps.
iwconfig reports the following while the WIFI is working (some bits redacted)...

Code: Select all

wlp2s0    IEEE 802.11  ESSID:"XXXXXXXX"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 7C:__:__:__:__:__   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=34/70  Signal level=-76 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:243   Missed beacon:0
The wifi link feels very fragile and tenuous, although I know that this hardware is capable of excellent wifi performance when running Win10.

How can I verify that I have the right drivers for this chipset?

I don't know how to diagnose this issue any further, I'd be very grateful for any guidance.
Last edited by wosser on Mon May 07, 2018 6:55 am, edited 1 time in total.

User avatar
kc1di
Level 13
Level 13
Posts: 4569
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: rtl8723be wifi performance is very poor

Post by kc1di » Sun May 06, 2018 9:06 am

Hello wosser and welcome to Linux Mint Forums,

I would try this command from a terminal and then reboot, see if it help the situation.

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
Just copy and past into the terminal and hit enter.
It will turn off the NM's power saving feature which causes problems with many cards.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

JeremyB
Level 18
Level 18
Posts: 8827
Joined: Fri Feb 21, 2014 8:17 am

Re: rtl8723be wifi performance is very poor

Post by JeremyB » Mon May 07, 2018 5:41 am

It likely only has one antenna on a card designed for 2, in terminal

Code: Select all

sudo modprobe -r rtl8723be && sleep 15 && sudo modprobe rtl8723be ant_sel=2
If that fixes the issue do

Code: Select all

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be-ant.conf

wosser
Level 1
Level 1
Posts: 5
Joined: Sat May 05, 2018 9:35 am

Re: rtl8723be wifi performance is very poor

Post by wosser » Mon May 07, 2018 6:30 am

JeremyB wrote:
Mon May 07, 2018 5:41 am
It likely only has one antenna on a card designed for 2, in terminal

Code: Select all

sudo modprobe -r rtl8723be && sleep 15 && sudo modprobe rtl8723be ant_sel=2
If that fixes the issue do

Code: Select all

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be-ant.conf
A huge, immediate improvement! Thank you, JeremyB. Yes you're right about the manufacturer (HP) only fitting one antenna. I never realised that when I had the machine opened up last week, but I took pictures. One of them clearly shows the absent antenna cable...
IMG_20180506_103819.jpg
Strangely though, ant-sel=2 does work MUCH better than whatever the default was. Perhaps the sticker has the "1" and "2"" the wrong way around.

Do you think it's worth me buying a second antenna cable and installing it somehow? I guess I'd have to find a location inside the case that hasn't got any of the gold RF shielding paint covering it.

If it has 2 antennas is there a way to select both?

Anyway, thank you very much for your suggestion, it seems to be working a lot better for now.

wosser
Level 1
Level 1
Posts: 5
Joined: Sat May 05, 2018 9:35 am

Re: rtl8723be wifi performance is very poor

Post by wosser » Tue May 08, 2018 4:13 pm

kc1di wrote:
Sun May 06, 2018 9:06 am
Hello wosser and welcome to Linux Mint Forums,

I would try this command from a terminal and then reboot, see if it help the situation.

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
Just copy and past into the terminal and hit enter.
It will turn off the NM's power saving feature which causes problems with many cards.
Thanks for the tip, oddly enough I had already added this line manually to that file a day or two before. If your command is run verbatim on a default linux mint system such as mine, it will have no effect because the regex will not find a matching line to replace. Better to suggest that the user add the line manually using a text editor perhaps.

Post Reply

Return to “Wireless”