/etc/resolve.conf: no such file or directory

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 8
Joined: Wed Nov 11, 2015 12:45 pm

/etc/resolve.conf: no such file or directory

Post by klawncare1239 » Tue May 08, 2018 12:01 am


So, I've got a relatively new install of Mint 18.3 Cinnamon on a Dell XPS 15. Love it. Had it working perfectly, basically EVERYTHING working, even managed to get fan under control so that she's quiet as a kitten.

However, today, I closed the lid to suspend and thought it HAD suspended, since it was so quiet. Threw it in my laptop only to find an hour later that it had NOT suspended and was piping hot with the fan blowing for all it was worth. Pulled it out, opened the lid and tried to see if I could just let her cool off. Tried to see the login prompt would come up, so I could login and then shut down properly to allow quick cool down (although maybe leaving it on with the fans running would have been better, I don't know.

At any rate, since I couldn't get in, I went ahead and did a hard shut down. However, now, trying to login I am stuck at a black screen following the LM logo.

If I go to the recovery menu and then simply resume, I can get in, although my resolution is all messed up. Also, if I load using kernel 4.10 vs 4.13, I can get in. In this case my resolution is fine. In either case, though, I cannot get connected to any wireless internet (haven't tried ethernet). I can "see" my connection options, but, upon boot-up, the system will say "connecting". Then a dialogue will pop up saying I'm connected, but, I've got not internet. Trying to choose any other wifi connection results in the menu dropping away, but no change in internet connection.

So, I shut down and went to the recovery area to see if I could rebuild any damaged packages, but I need internet for that. So, I tried to enable networking, but receive the error in the subject about the non-existent resolve.conf file/directory. Not sure what to do at this point to repair my system so that wifi works.

BTW - the wifi WAS working and does still work from the live USB I used for the install.

Suggestions? I did try researching this for quite a long time this evening, trying to find a solution myself. I am sorry if I have not found the proper thread which might address my issue. if there is one, feel free to simply link me to it.

Thanks so much for any assistance. GOT to get to bed. Exhausted. I'll check in the morning to see if anyone was up later than me and possibly has any suggestions for me.

Post Reply

Return to “Wireless”