Wi-Fi Not Appearing - Linux Mint 18.3- Atheros [Solved]

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
tosh32
Level 1
Level 1
Posts: 5
Joined: Sat May 12, 2018 2:27 am

Wi-Fi Not Appearing - Linux Mint 18.3- Atheros [Solved]

Post by tosh32 » Sat May 12, 2018 2:56 am

Hi, I have the same problem as MaxSolar0713. My computer is an Acer Aspire 1 model A114-31 on which I've just installed Mint 18.3.
I read asinoro reply and append the text of the result below. Two lines bother me:

1. IF: wlp3s0 state: down mac: <filter> (Looks as though I have to change wlp3s switch to 1 ?)

2. 03:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:0042] (rev 31) (The number 0280 is displayed in red. Problem ?)

Although I have used Linux before I am a newbie at meddling with it and using the forums so apologies if I have broken into this thread.

Code: Select all

System:     Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3) info: mate-panel dm: lightdm
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Acer product: Aspire A114-31 v: V1.09 Chassis: type: 10
           Mobo: APL model: Bulbasaur_AP v: V1.09
           Bios: Insyde v: V1.09 date: 10/17/2017
CPU:       Dual core Intel Celeron N3350 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 4377
           clock speeds: min/max: 800/2400 MHz 1: 804 MHz 2: 900 MHz
           3: 799 MHz
Graphics:  Card: Intel Device 5a85 bus-ID: 00:02.0 chip-ID: 8086:5a85
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Device 5a98
           driver: snd_hda_intel bus-ID: 00:0e.0 chip-ID: 8086:5a98
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 1000
           bus-ID: 02:00.1 chip-ID: 10ec:8168
           IF: enp2s0f1 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Qualcomm Atheros Device 0042
           driver: ath10k_pci bus-ID: 03:00.0 chip-ID: 168c:0042
           IF: wlp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 31.0GB (52.2% used)
           ID-1: /dev/mmcblk0 model: N/A size: 31.3GB serial: 0xf85f9d70
           ID-2: USB /dev/sda model: TransMemory size: 31.0GB serial: C89CDCBF6D9AC1A1A002C6B3-0:0
Partition: ID-1: / size: 24G used: 6.0G (27%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 473M used: 69M (16%) fs: ext2 dev: /dev/mmcblk0p2
           ID-3: swap-1 size: 4.12GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID:      System: supported: N/A
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   System Temperatures: cpu: 25.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 197 Uptime: 2 min Memory: 759.5/3789.9MB
           Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481 running in mate-terminal) inxi: 2.2.35 
03:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:0042] (rev 31)
	Subsystem: Lite-On Communications Inc Device [11ad:08a6]
	Kernel driver in use: ath10k_pci
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: acer-wireless: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: acer-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
3: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
Last edited by tosh32 on Sun May 13, 2018 6:23 am, edited 2 times in total.

tosh32
Level 1
Level 1
Posts: 5
Joined: Sat May 12, 2018 2:27 am

Re: Wi-Fi Not Appearing - Linux Mint 18.3

Post by tosh32 » Sat May 12, 2018 11:00 am

Well I solved my problem by using the script in this post viewtopic.php?f=53&t=269043 Big thank you to Jeremy B :)

Code: Select all

sudo apt-get install linux-modules-extra-4.15.0-20-generic
That will teach me read a bit further next time, colour me embarrassed :oops:

JeremyB
Level 18
Level 18
Posts: 8869
Joined: Fri Feb 21, 2014 8:17 am

Re: Wi-Fi Not Appearing - Linux Mint 18.3- Atheros

Post by JeremyB » Sat May 12, 2018 11:14 am

I am not sure how that command would do anything as your results show a different kernel involved- Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)

tosh32
Level 1
Level 1
Posts: 5
Joined: Sat May 12, 2018 2:27 am

Re: Wi-Fi Not Appearing - Linux Mint 18.3- Atheros

Post by tosh32 » Sat May 12, 2018 12:52 pm

I wish I knew enough to be able to tell you why it worked Jeremy :roll: but there is no doubt that it has, again, thank you very much.

asinoro
Level 4
Level 4
Posts: 246
Joined: Mon Feb 12, 2018 11:43 am

Re: Wi-Fi Not Appearing - Linux Mint 18.3- Atheros

Post by asinoro » Sun May 13, 2018 1:21 am

Interesting it appears that the extra modules of another kernel helped to load correct the current module of your kernel.
What it shows now the command?

Code: Select all

lspci -nnk | grep -A2 0280
If you marked as solved your topic you will help also other users.

tosh32
Level 1
Level 1
Posts: 5
Joined: Sat May 12, 2018 2:27 am

Re: Wi-Fi Not Appearing - Linux Mint 18.3- Atheros

Post by tosh32 » Sun May 13, 2018 2:43 am

The command now shows this:

3:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:0042] (rev 31)
Subsystem: Lite-On Communications Inc Device [11ad:08a6]
Kernel driver in use: ath10k_pci

How do I mark as solved?

asinoro
Level 4
Level 4
Posts: 246
Joined: Mon Feb 12, 2018 11:43 am

Re: Wi-Fi Not Appearing - Linux Mint 18.3- Atheros

Post by asinoro » Sun May 13, 2018 2:54 am

You mark the topic [SOLVED], by adding it to your first post title.

Post Reply

Return to “Wireless”