Acer Aspire 5310 wifi not working(solved)

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
rawill
Level 1
Level 1
Posts: 23
Joined: Thu May 31, 2018 9:13 pm

Acer Aspire 5310 wifi not working(solved)

Post by rawill » Thu May 31, 2018 9:23 pm

Newbie here. Just installed Mint 17.2 on this computer. However I can only get onto the web via the hardwire cable.

I have searched everywhere for solutions and tried lots of them, including solutions found on here.
But no wifi connections show up, and the wifi symbol top left icon above the keyboard does not light up.

I am sure the answer will be on this board and someone can point me to it.
many thanks, in advance.

By the way, Mint transformed the computer in terms of startup speed and speed of usage compared with the Vista that was on it.
Initially I put Ubuntu 16.04 on, it messed up the dual boot and Vista does not work anymore.
Then I tried Mint, by accident as I already had in on a memory stick and put it in to copy another file and rebooted with it still in.

Glad I did, even though Mint is built on an older version of Ubuntu.

Robin
Last edited by rawill on Fri Jun 15, 2018 6:16 pm, edited 1 time in total.

User avatar
jimallyn
Level 18
Level 18
Posts: 8136
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Acer Aspire 5310 wifi not working

Post by jimallyn » Thu May 31, 2018 10:01 pm

Hi, Robin, and welcome to the Linux Mint forums. At least in the past, people have been able to get wifi going on that model in Linux, but most of what I found was from 2008 or 2009, so may not still be valid. We have a member here, JeremyB, who is quite good on wifi stuff, so if there is a way to get wifi going on that, he will likely know what it is. He checks in regularly, so you will probably hear from him (or somebody else) within a day or so. But, you might want to consider installing a newer version of Mint on that computer. Mint 17.x is only supported until about this time next year, while Mint 18.3 is supported until 2021. And Mint 19 will be out soon (probably sometime in June, the last I heard).

I looked up that computer on the web, and it sounds like it's pretty weak in terms of CPU and RAM, so you're probably best off using the XFCE version of Mint. XFCE uses the least resources of the three desktop environments currently available.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

rawill
Level 1
Level 1
Posts: 23
Joined: Thu May 31, 2018 9:13 pm

Re: Acer Aspire 5310 wifi not working

Post by rawill » Thu May 31, 2018 10:27 pm

Many thanks.
What a super fast reply!

Yes, it is very low on resources. I bought in new, then gave it to my mother, finally lots of things would not work so we got her a new computer a few years ago.

I decided this would be good to ressurect and put in our holiday house.

So the platform you mention, is that the one I have in 17.2. or is a later version still on that platform.

User avatar
AZgl1500
Level 7
Level 7
Posts: 1662
Joined: Thu Dec 31, 2015 3:20 am
Location: /Home/Desktop
Contact:

Re: Acer Aspire 5310 wifi not working

Post by AZgl1500 » Thu May 31, 2018 11:57 pm

get the 18.3 XCFE and it will probably have the WiFi drivers for you.

rawill
Level 1
Level 1
Posts: 23
Joined: Thu May 31, 2018 9:13 pm

Re: Acer Aspire 5310 wifi not working

Post by rawill » Fri Jun 01, 2018 1:17 am

Interesting, and thank you.
I tried 18.? XCFE, I thought all was going well but when it asked my for my password after it had installed it told me my password was invalid.

So I thought I had missed something and so I tried again, same issue.
So here I am back on 17.2 talking to you.

I downloaded an image, burnt it a disc, and loaded from there, then clicked on the install icon.Tell me what I did wrong.
Can't figure it out.


I have installed ubuntu and mint on other computers before.
Including a dual boot on a one computer that eventually died, mainboard I was told!

Update: Well after another attempt install, my 4th! I took out the CD, as i had previously, rebooted it, left it and went to bed.
This morning it was working!
So I rebooted, put in the password, it accepted it, so all is well with the world.
I now have the distro you guys have recommended.

But still no wifi connection showing in the connection box.
I will persevere, this system looks a lot like Windows, more than Ubuntu, so it suits me, even though it is built on Ubuntu.

I have another Win 10 Computer that win has messed up on.
It is a 64 bit, so the latest Mint may go on to that one in dual boot mode.
Which version would you guys suggest, it has 2 gig ram, and 500 gig hd.
Again it is a low spec Acer, forget the model for now, and I am not where it is!

rawill
Level 1
Level 1
Posts: 23
Joined: Thu May 31, 2018 9:13 pm

Re: Acer Aspire 5310 wifi not working

Post by rawill » Thu Jun 14, 2018 1:38 am

I wonder if the below will help anyone solve my no wifi issue/

robin@robin-Aspire-5310 ~ $ inxi -Fzx
System: Host: robin-Aspire-5310 Kernel: 4.13.0-43-generic i686 (32 bit gcc: 5.4.0)
Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.3 Sylvia
Machine: System: Acer product: Aspire 5310 v: V1.40
Mobo: Acer model: Acadia Bios: Acer v: V1.40 date: 06/29/2007
CPU: Single core Intel Celeron M 520 (-UP-) cache: 1024 KB
flags: (lm nx pae sse sse2 sse3 ssse3) bmips: 3191 speed: 1595 MHz (max)
Graphics: Card: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1280x800@60.00hz
GLX Renderer: Mesa DRI Intel 945GM x86/MMX/SSE2
GLX Version: 1.4 Mesa 17.2.8 Direct Rendering: Yes
Audio: Card Intel NM10/ICH7 Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.13.0-43-generic
Network: Card-1: Broadcom NetLink BCM5787M Gigabit Ethernet PCI Express
driver: tg3 v: 3.137 bus-ID: 04:00.0
IF: enp4s0 state: down mac: <filter>
Card-2: Broadcom BCM4311 802.11b/g WLAN bus-ID: 05:00.0
IF: N/A state: N/A mac: N/A
Drives: HDD Total Size: 80.0GB (12.8% used)
ID-1: /dev/sda model: TOSHIBA_MK8037GS size: 80.0GB
Partition: ID-1: / size: 73G used: 8.7G (13%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 1.06GB used: 0.10GB (9%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 52.0C mobo: 52.0C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 149 Uptime: 4 days Memory: 163.8/989.2MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35
robin@robin-Aspire-5310 ~ $

timlinux2468
Level 1
Level 1
Posts: 7
Joined: Mon Jun 20, 2016 10:26 am

Re: Acer Aspire 5310 wifi not working

Post by timlinux2468 » Fri Jun 15, 2018 10:54 am

Hi, I have Acer Aspire 3690 with same (I think) wifi card - Broadcom 4311. I recently installed Mint 18.3 (Mate edition), and having done that, launched Driver Manager. I chose "firmware-b43-installer", applied changes and wifi worked. (I may have done a restart, can't remember!).
With Mint 17.3 where no drivers seemed to be available by default, I found the following worked:


How to Fix Broadcom BCM4311 Wireless Driver on Ubuntu and Linux Mint
Posted on February 13, 2013 by Geekster

In this article I will show you how to make your wireless connection work on Broadcam BCM4311 network interface card, on Ubuntu, Debian and Linux Mint Systems.

To fix your wireless problem, this is what you have to do:


Launch Terminal

Remove the default driver [if nec]:

sudo apt-get remove --purge bcmwl-kernel-source





Install the Linux Firmware nonfree drivers:

sudo apt-get install firmware-b43-installer





Load the b43 module:

sudo modprobe b43






To make it work automatically, do:

sudo su

[ enter password - nothing will show on screen, but prompt will turn red and blue with # instead of $ ]

echo "b43" >> /etc/modules



exit
[takes you out of super-user mode]



exit
[closes Terminal]

Restart

rawill
Level 1
Level 1
Posts: 23
Joined: Thu May 31, 2018 9:13 pm

Re: Acer Aspire 5310 wifi not working

Post by rawill » Fri Jun 15, 2018 6:10 pm

Many thanks, that is really, really weird.
I tried your first suggestion.

It worked! So again many thanks. :x

I had tried that before under a 17.2 version and it did not work.
However I did not do the purge command in the terminal, so maybe that was why some conflict with the earlier install.

Now all I have to do is sort the screensaver so it only uses my photos as the screensaver, Not the installed images.

Now I just found the solution to my screensaver issue. It is GL Slideshow in the first screen.
Probably did not describe it correctly, but there is solution on here somewhere, and I found it.
Great info on here if you look hard enough.
Last edited by rawill on Sat Jun 16, 2018 2:10 am, edited 1 time in total.

rawill
Level 1
Level 1
Posts: 23
Joined: Thu May 31, 2018 9:13 pm

Re: Acer Aspire 5310 wifi not working(solved)

Post by rawill » Sat Jun 16, 2018 2:07 am

https://ubuntuforums.org/showthread.php?t=2042920

This was the answer, in the ubuntuforums.
Answer is partway down.

sudo apt-get install xscreensaver xscreensaver-data-extra xscreensaver-gl-extra

Post Reply

Return to “Wireless”