Wifi Issues on Dual Boot Dell E6420

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
CGE925
Level 1
Level 1
Posts: 2
Joined: Fri Jun 01, 2018 5:04 pm

Wifi Issues on Dual Boot Dell E6420

Post by CGE925 » Fri Jun 01, 2018 6:14 pm

New Linux user here, running Mint 18.3 alongside Win10 Pro on a Dell Latitude E6420 equipped with the Broadcom BC43228. Everything has been updated via the update manager, including a recent Level 4 update of the kernel, etc. so I believe all drivers should be up to date. BIOS is not the latest but is a few years old.

The issue is that after a re-boot into Linux, I have no WiFi. Hard wired via Ethernet works perfectly. I have tried many of the usual suggestions on these forums, but the only one that works reliably (100% of the time), is to "...pull the power cord, pull the battery, hold the power button for 30+ seconds then re-connect and restart" When I do this, WiFi starts up instantly every time. I usually leave the machine suspended, and WiFi reconnects fine after waking from Suspend. Only after a re-boot is there a problem

rfkill shows NO hard or soft blocks, power management is OFF. If you need any other listings, please let me know

Suggestions as to a fix for this would be appreciated. Other than this one issue, I LOVE Linux and am looking forward to firing Win10 off all my computers, as soon as I can fix Mint.

Thanks in advance.


Code: Select all

System:    Host: jeff-Latitude-E6420 Kernel: 4.13.0-43-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9) Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell (portable) product: Latitude E6420 v: 01
           Mobo: Dell model: 032T9K v: A02 Bios: Dell v: A21 date: 11/14/2013
CPU:       Quad core Intel Core i7-2720QM (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 17561
           clock speeds: max: 2200 MHz 1: 1177 MHz 2: 915 MHz 3: 853 MHz
           4: 903 MHz 5: 978 MHz 6: 867 MHz 7: 853 MHz 8: 910 MHz
Graphics:  Card: NVIDIA GF119M [NVS 4200M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1600x900@60.04hz
           GLX Renderer: NVS 4200M/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.130 Direct Rendering: Yes
Audio:     Card-1 NVIDIA GF119 HDMI Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-43-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: 5040 bus-ID: 00:19.0
           IF: eno1 state: down mac: <filter>
           Card-2: Broadcom BCM43228 802.11a/b/g/n driver: wl bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 750.2GB (6.9% used)
           ID-1: /dev/mmcblk0 model: N/A size: 31.9GB
           ID-2: /dev/sda model: ST9250414ASG size: 250.1GB
           ID-3: /dev/sdb model: ST500LM000 size: 500.1GB
Partition: ID-1: / size: 19G used: 12G (69%) fs: ext4 dev: /dev/sdb1
           ID-2: /home size: 431G used: 5.8G (2%) fs: ext4 dev: /dev/sdb6
           ID-3: swap-1 size: 10.00GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 57.0C mobo: N/A gpu: 0.0:53C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 241 Uptime: 3 min Memory: 1387.8/7932.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35


: dell-wifi: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: brcmwl-0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
Last edited by JeremyB on Fri Jun 01, 2018 6:21 pm, edited 1 time in total.
Reason: added code tags

rawill
Level 1
Level 1
Posts: 23
Joined: Thu May 31, 2018 9:13 pm

Re: Wifi Issues on Dual Boot Dell E6420

Post by rawill » Fri Jun 01, 2018 9:12 pm

I look forward to your answer. See my query re a similar issue on an Acer Aspire 5310.

In my case i suspect it is something to do with the way the Acer is made. I have no issue on the little Acer One Aspire ZG model.

I have got no wifi icon symbol in the connect box.
I also want to get rid of Win 10 in a later computer it is fraught with difficulties.
Slow beyond belief, but worse than that, it tries to upgrade, fails and then uninstalls the files, total time taken, about 4 hours.
Tech guys tell me the only way to fix it is to reinstall a proffessional version of windows 10.

I had upgraded from Win 7, big mistake, and now M/S do not support the upgrade version.
Planned obsolescence.

CGE925
Level 1
Level 1
Posts: 2
Joined: Fri Jun 01, 2018 5:04 pm

SOLVED Wifi Issues on Dual Boot Dell E6420

Post by CGE925 » Sun Jun 03, 2018 4:43 pm

It looks like I've managed to fix my problem. I decided to try changing the Broadcom driver from the "recommended" "bcmwl-kernel-source" to the alternative "b43-firmware-installer". Lo and behold, after four full system restarts, my wifi reconnects perfectly each time, no need to pull the plug and battery and hold the power switch.

I'm loving Linux more and more.

:D

Post Reply

Return to “Wireless”