no wifi/ wireless unavailabe on LM 18.3

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Thu Jun 07, 2018 10:15 am

no wifi/ wireless unavailabe on LM 18.3

Post by lester87 » Thu Jun 07, 2018 10:33 am

Hiya, :D

I've just installed linuxmint on a brand new HP 15 - bw068sa machine and I'm having problems with wifi.

I'm dual booting with windows 10, and I already tried installing ubuntu and met with the same problem so tried LM instead.

LM cinnamon 18.3 works fine with ethernet cable. Initially no wifi was showing at all, just wired connections. I followed some advice on this forum and now it shows wireless but its unavailable and rescanning doesn't respond.

I'd appreciate some help as I'd love to make linux work!

many thanks,


when I inxi -Fxz I get the follwing...

Code: Select all

System:    Host: jo87-HP-Laptop-15-bw0xx Kernel: 4.13.0-43-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: HP product: HP Laptop 15-bw0xx v: Type1ProductConfigId
           Mobo: HP model: 8330 v: 27.32 Bios: Insyde v: F.21 date: 11/17/2017
CPU:       Dual core AMD A6-9220 RADEON R4 5 COMPUTE CORES 2C+3G (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 9981
           clock speeds: max: 2500 MHz 1: 1882 MHz 2: 1479 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Device 98e4 bus-ID: 00:01.0
           Display Server: X.Org 1.18.4 drivers: ati,amdgpu (unloaded: fbdev,vesa,radeon)
           Resolution: 1920x1080@60.10hz
           GLX Renderer: AMD STONEY (DRM 3.18.0 / 4.13.0-43-generic, LLVM 5.0.0)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] Device 157a
           driver: snd_hda_intel bus-ID: 00:09.2
           Card-2 Advanced Micro Devices [AMD/ATI] Device 15b3
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.13.0-43-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Realtek Device d723
           driver: rtl8723de port: 2000 bus-ID: 03:00.0
           IF: wlo1 state: down mac: <filter>
           WAN IP: <filter> IF: enp2s0 ip-v4: <filter> ip-v6: <filter>
           IF: wlo1 ip-v4: N/A ip-v6: N/A
Drives:    HDD Total Size: 1000.2GB (6.5% used)
           ID-1: /dev/sda model: WDC_WD10JPVX size: 1000.2GB temp: 36C
Partition: ID-1: / size: 9.1G used: 6.6G (77%) fs: ext4 dev: /dev/sda6
           ID-2: /home size: 705G used: 310M (1%) fs: ext4 dev: /dev/sda8
           ID-3: swap-1 size: 60.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 43.0C mobo: 20.0C gpu: 0.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 179 Uptime: 8 min Memory: 999.5/3895.7MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

Level 19
Level 19
Posts: 9033
Joined: Fri Feb 21, 2014 8:17 am

Re: no wifi/ wireless unavailabe on LM 18.3

Post by JeremyB » Thu Jun 07, 2018 10:45 am

What happens when you

Code: Select all

sudo ifconfig wlo1 up

Level 1
Level 1
Posts: 30
Joined: Thu May 31, 2018 9:13 pm

Re: no wifi/ wireless unavailabe on LM 18.3

Post by rawill » Sun Jun 17, 2018 4:04 am

Not sure if it is relevant, but check out my thread on no wifi on my Acer Aspire 5310.

I had to change the driver.
Took me about 2 weeks to figure it out, but not without lots of help from the members or this forum.


Post Reply

Return to “Wireless”