No Wifi Applet on Tara --how to get it back?

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
KrisHolt
Level 1
Level 1
Posts: 16
Joined: Mon Jan 22, 2018 10:23 pm

No Wifi Applet on Tara --how to get it back?

Post by KrisHolt » Thu Jul 05, 2018 3:02 am

Code: Select all

kris@kris-HP-Laptop-15-bs0xx:~$ uname -a
Linux kris-HP-Laptop-15-bs0xx 4.15.0-24-generic #26-Ubuntu SMP Wed Jun 13 08:44:47 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
kris@kris-HP-Laptop-15-bs0xx:~$ clear

Code: Select all

kris@kris-HP-Laptop-15-bs0xx:~$ inxi -Fxz
System:    Host: kris-HP-Laptop-15-bs0xx Kernel: 4.15.0-24-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.6 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: HP product: HP Laptop 15-bs0xx v: Type1ProductConfigId serial: N/A
           Mobo: HP model: 832A v: 23.50 serial: N/A
           UEFI: Insyde v: F.35 date: 03/08/2018
Battery    BAT1: charge: 30.8 Wh 100.0% condition: 30.8/31.1 Wh (99%)
           model: Hewlett-Packard PABAS0241231 status: Full
CPU:       Dual core Intel Core i5-7200U (-MT-MCP-) 
           arch: Kaby Lake rev.9 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10848
           clock speeds: max: 3100 MHz 1: 871 MHz 2: 618 MHz 3: 784 MHz
           4: 640 MHz
Graphics:  Card: Intel HD Graphics 620 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.09hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)
           version: 4.5 Mesa 18.0.0-rc5 Direct Render: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.15.0-24-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 01:00.0
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Realtek Device d723 port: 3000 bus-ID: 02:00.0
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1000.2GB (1.0% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB
Partition: ID-1: / size: 237G used: 9.3G (5%) fs: ext4 dev: /dev/sda9
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 40.0C mobo: 29.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 201 Uptime: 29 min Memory: 1930.3/7894.3MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 

Code: Select all

kris@kris-HP-Laptop-15-bs0xx:~$ rfkill list all
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

Code: Select all

kris@kris-HP-Laptop-15-bs0xx:~$ iwconfig
lo        no wireless extensions.

eno1      no wireless extensions.

Code: Select all

kris@kris-HP-Laptop-15-bs0xx:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 04f3:250e Elan Microelectronics Corp. 
Bus 001 Device 003: ID 04f2:b5db Chicony Electronics Co., Ltd 
Bus 001 Device 002: ID 0bda:b009 Realtek Semiconductor Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
kris@kris-HP-Laptop-15-bs0xx:~$ lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 02)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 02)
00:08.0 System peripheral: Intel Corporation Skylake Gaussian Mixture Model
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d4e (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device d723
kris@kris-HP-Laptop-15-bs0xx:~$
Last edited by JeremyB on Thu Jul 05, 2018 4:57 am, edited 1 time in total.
Reason: added code tags

skomo
Level 1
Level 1
Posts: 7
Joined: Mon Dec 18, 2017 2:59 am

Re: No Wifi Applet on Tara --how to get it back?

Post by skomo » Thu Jul 05, 2018 3:30 am

Hi, i don't know if it can solve your problem, but i noticed after installed kernel 4.15 my wifi broadcom stopped working. The solution is to rollback to a previous kernel. 4.15 is bugged at the moment. In Arch forum i saw a post where they say to compile a pathed 4.15kernel to solve this issue. But i think i'll wait for an official fix.

JeremyB
Level 18
Level 18
Posts: 8861
Joined: Fri Feb 21, 2014 8:17 am

Re: No Wifi Applet on Tara --how to get it back?

Post by JeremyB » Thu Jul 05, 2018 4:55 am

Krisholt

Code: Select all

sudo apt-get install dkms git build-essential
git clone -b extended https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add ./rtlwifi_new
sudo dkms install rtlwifi-new/0.6
Reboot

skomo, see viewtopic.php?f=53&t=272328#p1489284

skomo
Level 1
Level 1
Posts: 7
Joined: Mon Dec 18, 2017 2:59 am

Re: No Wifi Applet on Tara --how to get it back?

Post by skomo » Thu Jul 05, 2018 1:14 pm

Thank you!!

KrisHolt
Level 1
Level 1
Posts: 16
Joined: Mon Jan 22, 2018 10:23 pm

Re: No Wifi Applet on Tara --how to get it back?

Post by KrisHolt » Thu Jul 05, 2018 4:43 pm

Thank you for the help on installing rtlwifi_new on Tara 19! :D
This worked like a charm!

I can see that if I want to use Sylvia 18.3, I have to fallback to select on advanced boot options kernel 4.13.0-45 where the rtl8723de WiFi works, unlike the new kernel 4.15.0-24-generic.

Post Reply

Return to “Wireless”