Wireless USB Adapter Connection issue

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 22
Joined: Wed Sep 13, 2017 8:26 pm

Wireless USB Adapter Connection issue

Post by stridder » Fri Jul 06, 2018 11:19 pm

I use Ultra wireless-N USB adapter 300Mbps 2.4Ghs, model: U12-43870 rev.B (info from adapter box) with Mint 18.2 cinnamon with old Gateway desktop.
From CD it seems that it has realtek chip.
When I plug it in, my wireless hotspot is shown, but when I click connect - it tries to connect and then message appears: you are disconnected/offline.
After trying to connect, my hotspot disappears from wireless connections until restart.
I provided hotspot pswd in connection settings. I actually tried 2 hotspots, cannot connect to any from Mint. Both of them work well and stable with Win7.
There are following files under linux folder on CD:

Don't know which chip is in this adapter (and thus which file to use), is there a way to determine it say with inxi?

There's this link in "Last Drivers Download.url" file on CD under linux folder:
http://www.realtek.com.tw/downloads/dow ... l=4&Conn=3

RTL8192EU_linux_v4.3.1.1_11320.20140505.zip contains install.sh, which I ran (after unpacking all content of course), but compilation fails.
One time (right after running this install.sh - script failed so I don't know if it has anything to do with this script), it connected to my hotspot and I could use internet from browser, but it was the 1st and last time it connected.

From similar thread it seems people often request for the following info:

Code: Select all

inxi -Fxz
System:    Host: DX4200-09 Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.3 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.2 Sonya
Machine:   System: Gateway product: DX4200-09 v: 7B3P091G
           Mobo: Gateway model: RS780 v: Rev 1.0 Bios: American Megatrends v: 7B3P091G date: 08/06/2008
CPU:       Quad core AMD model unknown (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 24001
           clock speeds: max: 3000 MHz 1: 800 MHz 2: 800 MHz 3: 1800 MHz 4: 2300 MHz
Graphics:  Card: NVIDIA GT218 [GeForce 210] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce 210/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 340.104 Direct Rendering: Yes
Audio:     Card-1 NVIDIA High Definition Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network:   Card: Marvell 88E8071 PCI-E Gigabit Ethernet Controller
           driver: sky2 v: 1.30 port: e800 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 768.2GB (21.8% used) ID-1: /dev/sda model: M4 size: 128.0GB temp: 0C
           ID-2: /dev/sdb model: WDC_WD6400AAKS size: 640.1GB temp: 41C
Partition: ID-1: / size: 39G used: 13G (34%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 18G used: 9.8G (60%) fs: ext4 dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 46.0C mobo: 36.0C gpu: 0.0:61C
           Fan Speeds (in rpm): cpu: 1081 fan-1: 1674 fan-3: 0
Info:      Processes: 220 Uptime: 14 min Memory: 1131.0/4203.1MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

Code: Select all

inxi -Nn:

Network:   Card: Marvell 88E8071 PCI-E Gigabit Ethernet Controller driver: sky2
           IF: enp2s0 state: down mac: 00:22:68:64:95:0a 

Code: Select all

iwconfig output:

wlx803f5d9eaa23  IEEE 802.11  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off

enp2s0    no wireless extensions.
lo        no wireless extensions. 

Code: Select all

rfkill list all
0: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
No wired network used when running these commands.
Thank you!

Level 1
Level 1
Posts: 4
Joined: Tue Jul 03, 2018 12:02 am

Re: Wireless USB Adapter Connection issue

Post by redbeardzombie » Thu Jul 19, 2018 1:00 am

For what it's worth, I had a helluva' time getting my Marvell to work. I finally ended up cannibalizing one of my other old laptops and it worked just fine. I think it's a driver problem with the marvell units which cause a soft blocked state. I wish I had more to offer and I hope someone can help you get it working. Best of luck. :D

Post Reply

Return to “Wireless”