Slow internet via wifi

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
shom_ronnie
Level 2
Level 2
Posts: 68
Joined: Tue Jun 12, 2018 1:33 pm
Location: Kolkata, India

Slow internet via wifi

Post by shom_ronnie » Sun Jul 08, 2018 11:40 am

I have had problems connecting with wifi previously, but since i have moved to linux mint tara its working fine, but the one thing i have noticed is the internet speed on the wifi is horrible. I have a pack of about 60mbps, i get around 50 or so on other wifi devices. Only on this laptop i get say a 10mbps. Any ideas what could possibly be the problem. Turned off firewall as well.
System: Host: Shom-HP-Notebook Kernel: 4.15.0-24-generic x86_64
bits: 64 gcc: 7.3.0
Desktop: Cinnamon 3.8.7 (Gtk 3.22.30-1ubuntu1)
Distro: Linux Mint 19 Tara
Machine: Device: laptop System: HP product: HP Notebook v: Type1ProductConfigId serial: N/A
Mobo: HP model: 81EF v: 63.40 serial: N/A
UEFI: Insyde v: F.41 date: 03/02/2018
Battery BAT1: charge: 34.2 Wh 100.0% condition: 34.2/41.4 Wh (83%)
model: COMPAL PABAS0241231 status: Full
CPU: Dual core Intel Core i3-5005U (-MT-MCP-)
arch: Broadwell rev.4 cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7981
clock speeds: max: 1900 MHz 1: 1040 MHz 2: 1093 MHz 3: 1080 MHz
4: 1108 MHz
Graphics: Card: Intel HD Graphics 5500 bus-ID: 00:02.0
Display Server: x11 (X.Org 1.19.6 )
drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1366x768@60.02hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
version: 4.5 Mesa 18.0.0-rc5 Direct Render: Yes
Audio: Card-1 Intel Broadwell-U Audio Controller
driver: snd_hda_intel bus-ID: 00:03.0
Card-2 Intel Wildcat Point-LP High Def. Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-24-generic
Network: Card-1: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller
driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 07:00.0
IF: enp7s0 state: down mac: <filter>
Card-2: Broadcom Limited BCM43142 802.11b/g/n
driver: wl bus-ID: 0d:00.0
IF: wlp13s0 state: up mac: <filter>
Drives: HDD Total Size: 1000.2GB (30.1% used)
ID-1: /dev/sda model: HGST_HTS541010A9 size: 1000.2GB temp: 0C
Partition: ID-1: / size: 50G used: 18G (37%) fs: ext4 dev: /dev/sda2
ID-2: swap-1 size: 5.00GB used: 0.00GB (0%)
fs: swap dev: /dev/sda3
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 47.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 225 Uptime: 11 min Memory: 1142.0/3857.5MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56

User avatar
Sir Charles
Level 7
Level 7
Posts: 1832
Joined: Thu Jan 04, 2018 1:00 pm

Re: Slow internet via wifi

Post by Sir Charles » Sun Jul 08, 2018 12:02 pm

It could be that you are on a "congested" wifi-chanel. I uselinssidto monitor my wifi connection. It is in the repositories.
You could also run

Code: Select all

nmcli dev wifi
in a terminal to have a overview of wifi-connections around you.
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

shom_ronnie
Level 2
Level 2
Posts: 68
Joined: Tue Jun 12, 2018 1:33 pm
Location: Kolkata, India

Re: Slow internet via wifi

Post by shom_ronnie » Sun Jul 08, 2018 12:07 pm

I am certain that is not the problem, because i have other devices on the same wifi, giving me round about 50mbps. I also have wavemon installed, it says -26dBm. So its certainly not the channel, if it had been so, it would have been on my mobile phone as well which is in wifi

User avatar
Sir Charles
Level 7
Level 7
Posts: 1832
Joined: Thu Jan 04, 2018 1:00 pm

Re: Slow internet via wifi

Post by Sir Charles » Sun Jul 08, 2018 12:09 pm

Yes, right! I overlooked this fact:
Only on this laptop i get say a 10mbps
Sorry about that!
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

shom_ronnie
Level 2
Level 2
Posts: 68
Joined: Tue Jun 12, 2018 1:33 pm
Location: Kolkata, India

Re: Slow internet via wifi

Post by shom_ronnie » Wed Jul 11, 2018 11:43 am

Any ideas anyone, Its so annoying to use the wifi internet. Would really appreciate anybody helping me out here

User avatar
JoeFootball
Level 6
Level 6
Posts: 1392
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: Slow internet via wifi

Post by JoeFootball » Wed Jul 11, 2018 6:38 pm

shom_ronnie wrote:Any ideas anyone, Its so annoying to use the wifi internet. Would really appreciate anybody helping me out here
You can try some of the ideas in this article from the Easy Linux Tips Project. Section 2 may interest you.

Joe

JeremyB
Level 18
Level 18
Posts: 8861
Joined: Fri Feb 21, 2014 8:17 am

Re: Slow internet via wifi

Post by JeremyB » Wed Jul 11, 2018 6:48 pm


tuxutku
Level 1
Level 1
Posts: 2
Joined: Wed Jul 18, 2018 1:05 pm

Re: Slow internet via wifi

Post by tuxutku » Wed Jul 18, 2018 1:08 pm

i have the same problem with the same specific kernel version, issue started after updated to this kernel version
EDIT: LAN connections are fine with both ethernet and wifi as i just checked, Live cd has the same issue, internet download speed is only 20~ 40~ Kb/s

sorry for my mistake :(
Last edited by tuxutku on Wed Jul 18, 2018 1:40 pm, edited 2 times in total.

User avatar
Moem
Level 16
Level 16
Posts: 6233
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Slow internet via wifi

Post by Moem » Wed Jul 18, 2018 1:25 pm

tuxutku wrote:
Wed Jul 18, 2018 1:08 pm
i have the same problem with the same specific kernel version, issue started after updated to this kernel version
So you're on 4.15.0-24? Try going back to one kernel earlier, and see what you get. Kernel 4.15.0-24 is buggy for many people.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

tuxutku
Level 1
Level 1
Posts: 2
Joined: Wed Jul 18, 2018 1:05 pm

Re: Slow internet via wifi

Post by tuxutku » Wed Jul 18, 2018 2:49 pm

I am so sorry again, its just my provider having problems and there is no problem with my computer :oops:
it just happened to be when i am tested android, it just get a little bit of a juice (i mean all devices suffering :wink: )

shom_ronnie
Level 2
Level 2
Posts: 68
Joined: Tue Jun 12, 2018 1:33 pm
Location: Kolkata, India

[SOLVED] Slow internet via wifi

Post by shom_ronnie » Tue Jul 24, 2018 12:08 pm

Changing the BSSID to that of my router actually solved the problem. Thnx again forum. That link was really helpful. Thank you

Post Reply

Return to “Wireless”