linux mint 19 and killer 1550 wireless not working

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Mr Fiddes
Level 1
Level 1
Posts: 1
Joined: Mon Jul 09, 2018 9:57 pm

linux mint 19 and killer 1550 wireless not working

Post by Mr Fiddes » Mon Jul 09, 2018 10:55 pm

Hi all,
Firstly - i am very new to Linux (3 days) and have very low to no experience with code admin.
4 days ago i received my custom laptop and decided to install Linux mint 19 as OS.
I am able to connect the laptop to the internet via wired connection however it doesn't seem to be picking up my wireless Killer 1550 PCIe network adapter.

Code: Select all

fiddsy@FIDDSY-laptop:~$ inxi -Fz
System:    Host: FIDDSY-laptop Kernel: 4.15.0-24-generic x86_64 bits: 64
           Desktop: Cinnamon 3.8.7  Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: IT Channel Pty product: N8xxEP6 serial: N/A
           Mobo: IT Channel Pty model: N8xxEP6 serial: N/A
           UEFI: American Megatrends v: 5.13 date: 04/13/2018
Battery    BAT0: charge: 19.3 Wh 33.7% condition: 57.4/59.9 Wh (96%)
CPU:       6 core Intel Core i7-8750H (-MT-MCP-) cache: 9216 KB
           clock speeds: max: 4100 MHz 1: 3175 MHz 2: 2674 MHz 3: 2608 MHz
           4: 2699 MHz 5: 2796 MHz 6: 2952 MHz 7: 2835 MHz 8: 2832 MHz
           9: 2823 MHz 10: 2827 MHz 11: 2703 MHz 12: 2714 MHz
Graphics:  Card-1: Intel Device 3e9b
           Card-2: NVIDIA GP106M [GeForce GTX 1060 Mobile]
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.01hz
           OpenGL: renderer: GeForce GTX 1060/PCIe/SSE2
           version: 4.6.0 NVIDIA 390.48
Audio:     Card Intel Device a348 driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-24-generic
Network:   Card-1: Intel Device 2526
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169
           IF: enp4s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 250.1GB (7.5% used)
           ID-1: /dev/nvme0n1 model: Samsung_SSD_970_EVO_250GB size: 250.1GB
Partition: ID-1: / size: 228G used: 18G (9%) fs: ext4 dev: /dev/nvme0n1p2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 56.0C mobo: N/A gpu: 48C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 273 Uptime: 1:02 Memory: 1137.8/15893.6MB
           Client: Shell (bash) inxi: 2.3.56 
Can anyone offer a solution or a step by step guide because in absolutely lost here...
thanks in advance.

Skunkfoot
Level 1
Level 1
Posts: 3
Joined: Mon Aug 27, 2018 3:46 pm

Re: linux mint 19 and killer 1550 wireless not working

Post by Skunkfoot » Mon Aug 27, 2018 4:02 pm

I'm having the same issue as Mr Fiddes apparently. Finally managed to dual boot Mint with Windows on this one and now I'm finding out that, apparently, my wireless card isn't supported yet. Hopefully someone who's more familiar with Linux can develop a solution for me, Mr Fiddes, and the people over at Killer Networking.

Code: Select all

skunkfoot@skunkfoot:~$ inxi -Fz
System:    Host: skunkfoot Kernel: 4.15.0-33-generic x86_64 bits: 64 Desktop: Cinnamon 3.8.8
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Micro-Star product: GL63 8RC v: REV:1.0 serial: N/A
           Mobo: Micro-Star model: MS-16P6 v: REV:1.0 serial: N/A
           UEFI: American Megatrends v: E16P6IMS.104 date: 04/08/2018
Battery    BAT1: charge: 42.6 Wh 100.0% condition: 42.6/42.4 Wh (101%)
           hidpp__0: charge: N/A condition: NA/NA Wh
CPU:       6 core Intel Core i7-8750H (-MT-MCP-) cache: 9216 KB
           clock speeds: max: 4100 MHz 1: 900 MHz 2: 899 MHz 3: 900 MHz 4: 900 MHz 5: 900 MHz 6: 900 MHz
           7: 900 MHz 8: 900 MHz 9: 900 MHz 10: 900 MHz 11: 900 MHz 12: 899 MHz
Graphics:  Card-1: Intel Device 3e9b
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile]
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.02hz
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 version: 4.6.0 NVIDIA 390.48
Audio:     Card Intel Device a348 driver: snd_hda_intel Sound: ALSA v: k4.15.0-33-generic
Network:   Card-1: Intel Device 2526
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
           Card-2: Qualcomm Atheros QCA8171 Gigabit Ethernet driver: alx
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 2512.5GB (1.8% used)
           ID-1: /dev/nvme0n1 model: Samsung_SSD_970_PRO_512GB size: 512.1GB
           ID-2: /dev/sda model: ST2000LM015 size: 2000.4GB
Partition: ID-1: / size: 24G used: 9.7G (43%) fs: ext4 dev: /dev/sda2
           ID-2: /home size: 815G used: 351M (1%) fs: ext4 dev: /dev/sda4
           ID-3: swap-1 size: 36.70GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 49.0C mobo: N/A gpu: 47C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 277 Uptime: 15 min Memory: 988.9/15882.2MB Client: Shell (bash) inxi: 2.3.56 
I tried following the steps that Killer Networking offers for the rest of their wireless cards, found here: https://www.killernetworking.com/driver ... nux#faq_80. Unfortunately, that didn't seem to work.

From Killer Networking:
With the exception Killer Wireless-AC 1550 series, the drivers for all of our devices are community developed and supported. We neither develop nor support the Linux drivers for our devices, and this is common, as free and open source is the Linux way.
Can anyone here offer some guidance for us? Thanks!

--Skunkfoot

JeremyB
Level 19
Level 19
Posts: 9452
Joined: Fri Feb 21, 2014 8:17 am

Re: linux mint 19 and killer 1550 wireless not working

Post by JeremyB » Mon Aug 27, 2018 4:43 pm

You can try this

Code: Select all

sudo apt-get install git build-essential
git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git/
cd backport-iwlwifi
make defconfig-iwlwifi-public
sed -i 's/CPTCFG_IWLMVM_VENDOR_CMDS=y/# CPTCFG_IWLMVM_VENDOR_CMDS is not set/' .config
make -j4
sudo make install
Reboot, after a kernel update you will need to

Code: Select all

cd backport-iwlwifi
make clean
make defconfig-iwlwifi-public
make -j4
sudo make install
Make sure Secure Boot is disabled in BIOS/UEFI
If it doesn't work after the reboot post results from terminal for

Code: Select all

dmesg | grep iwl

Skunkfoot
Level 1
Level 1
Posts: 3
Joined: Mon Aug 27, 2018 3:46 pm

Re: linux mint 19 and killer 1550 wireless not working

Post by Skunkfoot » Mon Aug 27, 2018 5:15 pm

Worked flawlessly. I'm surprised I couldn't find much else about this issue on the web, glad you managed to figure out an easy solution. Thanks a lot! I'm going to email Killer Networking support and link them to this thread as well in case they get calls about this issue from other users. Thanks again.

--Skunkfoot

Skunkfoot
Level 1
Level 1
Posts: 3
Joined: Mon Aug 27, 2018 3:46 pm

Re: linux mint 19 and killer 1550 wireless not working

Post by Skunkfoot » Mon Aug 27, 2018 7:24 pm

UPDATE:

So I emailed Killer Networking about this issue and here is their response, in case it helps future related issues at all:
Thank you for the information!

We have had quite a few other users ask about this, but if the iwlwifi driver wasn't already updated in whatever kernel they were using, the solution was so convoluted that it wasn't something we were able to offer up. This looks much simpler. For now, I have added a section of user-contributed links. I will likely get my test machine with the 1550 out tomorrow so that I can confirm this myself in Mint, and see if I can use the same solution (or something similar) in Ubuntu.

The issue has been that, while the iwlwifi driver is present in most Linux kernels, it does not contain our hardware ID, so a user would have to patch the driver, then recompile the kernel. I'm guessing this line:


sed -i 's/CPTCFG_IWLMVM_VENDOR_CMDS=y/# CPTCFG_IWLMVM_VENDOR_CMDS is not set/' .config

does something to get around that, but I'm not experienced enough in Linux to know exactly what is happening there, so I'll have to do some research.

In the meantime, I have credited JeremyB.

Anthony Davis,
Killer and SmartByte Service Technician
I'm impressed with their candid, thorough response and their customer service in general. Hopefully this info helps clear up any potential confusion in the future!

--Skunkfoot

JeremyB
Level 19
Level 19
Posts: 9452
Joined: Fri Feb 21, 2014 8:17 am

Re: linux mint 19 and killer 1550 wireless not working

Post by JeremyB » Mon Aug 27, 2018 7:37 pm

I would say the customer support has very little knowledge of linux, recompile an entire kernel for a wifi module? That is just barbaric

User avatar
catweazel
Level 17
Level 17
Posts: 7770
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: linux mint 19 and killer 1550 wireless not working

Post by catweazel » Mon Aug 27, 2018 7:59 pm

JeremyB wrote:
Mon Aug 27, 2018 7:37 pm
That is just barbaric
Not anywhere near as barbaric as the old Windwoes fall back... format and reinstall.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

Post Reply

Return to “Wireless”