Can't make USB wifi adaptor work in Linux Mint 19

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
anbarto
Level 1
Level 1
Posts: 2
Joined: Tue Jul 10, 2018 5:46 am

Can't make USB wifi adaptor work in Linux Mint 19

Post by anbarto » Tue Jul 10, 2018 6:06 am

Hi all, I'm trying to use an iAmotus USB WiFi Adaptor AC600, which is a Realtek RTL8811AU wifi card, in Linux Mint 19, since my built-in wifi card has stopped working a while ago. Please bear in mind that I'm very green and doing my best... I've tried the instructions for installation and a number of posts on this and Ubuntu forums, to no avail... I'm really running out of possible methods! (But I must be missing something.) My computer is a Compaq 15 notebook pc s015nf. Here is the info that I know how to get, please be patient if I've omitted something obvious... Thanks in advance for any help!

Code: Select all

twan@twan-Compaq-15-Notebook-PC:~$ uname -a
Linux twan-Compaq-15-Notebook-PC 4.15.0-24-generic #26-Ubuntu SMP Wed Jun 13 08:44:47 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Code: Select all

twan@twan-Compaq-15-Notebook-PC:~$ cat /etc/issue
Linux Mint 19 Tara \n \l

Code: Select all

twan@twan-Compaq-15-Notebook-PC:~$ inxi -Fxz
System:    Host: twan-Compaq-15-Notebook-PC Kernel: 4.15.0-24-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: MATE 1.20.1 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Hewlett-Packard product: Compaq 15 Notebook PC v: 096D100000405F00050660180 serial: N/A
           Mobo: Hewlett-Packard model: 2213 v: 57.26 serial: N/A
           UEFI: Insyde v: F.18 date: 05/21/2014
Battery    BAT1: charge: 33.4 Wh 91.7% condition: 36.5/41.4 Wh (88%)
           model: COMPAL PABAS0241231 status: Discharging
CPU:       Dual core Intel Celeron N2830 (-MCP-) 
           arch: Silvermont rev.8 cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8663
           clock speeds: max: 2415 MHz 1: 1636 MHz 2: 1514 MHz
Graphics:  Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.99hz
           OpenGL: renderer: Mesa DRI Intel Bay Trail
           version: 4.2 Mesa 18.0.0-rc5 Direct Render: Yes
Audio:     Card Intel Atom Processor Z36xxx/Z37xxx Series High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-24-generic
Network:   Card-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe
           driver: rt2800pci v: 2.3.0 bus-ID: 02:00.0
           IF: wlp2s0f0 state: down mac: <filter>
           Card-2: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 1000 bus-ID: 04:00.0
           IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 500.1GB (3.7% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABF0 size: 500.1GB
Partition: ID-1: / size: 457G used: 18G (4%) fs: ext4 dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.0C mobo: 41.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 165 Uptime: 3 days Memory: 1595.0/3833.7MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56

User avatar
catweazel
Level 17
Level 17
Posts: 7756
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Can't make USB wifi adaptor work in Linux Mint 19

Post by catweazel » Tue Jul 10, 2018 6:48 am

anbarto wrote:
Tue Jul 10, 2018 6:06 am
Realtek RTL8811AU
sudo apt install rtl8812au-dkms in a terminal then reboot.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

anbarto
Level 1
Level 1
Posts: 2
Joined: Tue Jul 10, 2018 5:46 am

Re: Can't make USB wifi adaptor work in Linux Mint 19

Post by anbarto » Tue Jul 10, 2018 11:52 am

Thanks!! Didn't do the trick, though. Below is the output I got. There is an error message toward the end that I'm not sure what to do with. Any ideas?

twan@twan-Compaq-15-Notebook-PC:~$ sudo apt install rtl8812au-dkms
[sudo] password for twan:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
rtl8812au-dkms
0 upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
Need to get 1 116 kB of archives.
After this operation, 8 906 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu bionic/universe amd64 rtl8812au-dkms all 4.3.8.12175.20140902+dfsg-0ubuntu8 [1 116 kB]
Fetched 1 116 kB in 0s (4 381 kB/s)
Selecting previously unselected package rtl8812au-dkms.
(Reading database ... 335029 files and directories currently installed.)
Preparing to unpack .../rtl8812au-dkms_4.3.8.12175.20140902+dfsg-0ubuntu8_all.deb ...
Unpacking rtl8812au-dkms (4.3.8.12175.20140902+dfsg-0ubuntu8) ...
Setting up rtl8812au-dkms (4.3.8.12175.20140902+dfsg-0ubuntu8) ...
Loading new rtl8812au-4.3.8.12175.20140902+dfsg DKMS files...
Building for 4.15.0-24-generic
Building initial module for 4.15.0-24-generic
Secure Boot not enabled on this system.
Done.

8812au:
Running module version sanity check.
Error! Module version v4.3.8_12175.20140902 for 8812au.ko
is not newer than what is already found in kernel 4.15.0-24-generic (v4.3.20_16317.20160108).
You may override by specifying --force.

depmod...........

DKMS: install completed.

Post Reply

Return to “Wireless”