[Solved] No WiFi: Inspiron 6000, Dell 1370 miniPCI / BCM4318

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 3
Joined: Sat Jul 14, 2018 8:50 pm

[Solved] No WiFi: Inspiron 6000, Dell 1370 miniPCI / BCM4318

Post by LMSimon » Sat Jul 14, 2018 10:06 pm

I'm unable to find wlan0 or anything resembling it on this laptop - see details from inxi -Fxz below.

Problem doesn't manifest itself in Windows XP so I know the card functions fine, and the same issue occurs with the one or two other Distro's I've played with. When loading Win XP the machine's Fn+F2 means of switching the card on / off works fine but not so booting with Linux.

This is my first time posting after installing Mint on other machines without any issues whatsoever; I did more than a couple of hours searching and attempting fixes, clearly to no avail. All I've found out is that Broadcom chipsets seem to be problematic and that my Terminal command line expertise took a real dive since Windows replaced Unix at work. I'm re-learning long forgotten skills..........

Please let me know what further data's needed.


System: Host: dell-Inspiron-6000 Kernel: 4.15.0-24-generic i686 bits: 32 gcc: 7.3.0
Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Linux Mint 19 Tara
Machine: Device: portable System: Dell product: Inspiron 6000 serial: N/A
Mobo: Dell model: 0W9260 serial: N/A BIOS: Dell v: A09 date: 09/28/2005
Battery BAT0: charge: 73.3 Wh 112.5% condition: 65.1/73.3 Wh (89%) model: Sanyo DELL 00 status: Full
CPU: Single core Intel Celeron M (-UP-) arch: Dothan rev.8 cache: 1024 KB
flags: (nx pae sse sse2) bmips: 2793 speed: 1396 MHz (max)
Graphics: Card: Intel Mobile 915GM/GMS/910GML Express Graphics Controller bus-ID: 00:02.0
Display Server: x11 (X.Org 1.19.6 ) drivers: intel (unloaded: modesetting,fbdev,vesa)
Resolution: 1280x800@60.00hz
OpenGL: renderer: Mesa DRI Intel 915GM x86/MMX/SSE2 version: 1.4 Mesa 18.0.5 Direct Render: Yes
Audio: Card Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller
driver: snd_intel8x0 ports: ed00 ec40 bus-ID: 00:1e.2
Sound: Advanced Linux Sound Architecture v: k4.15.0-24-generic
Network: Card-1: Broadcom Limited BCM4401-B0 100Base-TX driver: b44 v: 2.0 bus-ID: 03:00.0
IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Card-2: Broadcom Limited BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
driver: b43-pci-bridge bus-ID: 03:03.0
IF: N/A state: N/A mac: N/A
Drives: HDD Total Size: 160.0GB (9.2% used)
ID-1: /dev/sda model: WDC_WD1600BEVE size: 160.0GB
Partition: ID-1: / size: 146G used: 14G (10%) fs: ext4 dev: /dev/sda1
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 43.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 142 Uptime: 10 min Memory: 555.2/2004.2MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56
Last edited by LMSimon on Tue Jul 17, 2018 2:27 am, edited 1 time in total.

Level 1
Level 1
Posts: 3
Joined: Sat Jul 14, 2018 8:50 pm

Re: No WiFi: Inspiron 6000, Dell 1370 miniPCI / BCM4318

Post by LMSimon » Mon Jul 16, 2018 2:14 am

No idea for why - I claim Newbie Status in my defence - but after (re-?) installing firmware-b43-installer:

sudo apt install firmware-b43-installer,

removing the module:
sudo modprobe -r b43,

then enabling:
sudo modprobe b43,

it works; even the Fn+F2 keyboard switch works. I have to remove / re-enable after every re-boot though.

If anyone else is reading this perhaps they can explain the ins and outs of this um, quirky behaviour? Also how one might automate this work-around fix?

Post Reply

Return to “Wireless”