Page 1 of 1

Poor wifi speed

Posted: Wed Aug 01, 2018 3:24 pm
by SJM
I have a 200 mbps connection to my house, verified with on other devices. For some reason, I'm getting 0.5 mbps via wifi on my linux box.

iwconfig output:

Code: Select all

lo        no wireless extensions.

wlp33s0b1  IEEE 802.11  ESSID:"VM9750668"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: C0:05:C2:CE:45:41   
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=55/70  Signal level=-55 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:324  Invalid misc:29   Missed beacon:0

enp35s0   no wireless extensions.
inxi -Fxz output:

Code: Select all

System:    Host: stuart-LinuxMint Kernel: 4.15.0-29-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: ASUSTeK model: PRIME A320M-K v: Rev X.0x
           Bios: American Megatrends v: 0902 date: 09/08/2017
CPU:       Quad core AMD Ryzen 3 1200 (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 24751
           clock speeds: max: 3100 MHz 1: 1545 MHz 2: 1399 MHz 3: 1373 MHz
           4: 1374 MHz
Graphics:  Card: NVIDIA Device 128b bus-ID: 25:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: GeForce GT 710/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.130 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] Device 1457
           driver: snd_hda_intel bus-ID: 27:00.3
           Card-2 NVIDIA GK208 HDMI/DP Audio Controller
           driver: snd_hda_intel bus-ID: 25:00.1
           Card-3 JMTek LLC. driver: USB Audio usb-ID: 001-005
           Sound: Advanced Linux Sound Architecture v: k4.15.0-29-generic
Network:   Card-1: Broadcom BCM43217 802.11b/g/n
           driver: bcma-pci-bridge bus-ID: 21:00.0
           IF: wlp33s0b1 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: f000 bus-ID: 23:00.0
           IF: enp35s0 state: down mac: <filter>
Drives:    HDD Total Size: NA (-) ID-1: /dev/nvme0n1 model: N/A size: 256.1GB
Partition: ID-1: / size: 227G used: 54G (25%) fs: ext4 dev: /dev/nvme0n1p1
           ID-2: swap-1 size: 8.52GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 30.0C mobo: N/A gpu: 0.0:55C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 196 Uptime: 8 min Memory: 1179.0/7976.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

Re: Poor wifi speed

Posted: Wed Aug 01, 2018 6:31 pm
by kyphi
A Wi-Fi connection is generally much slower than a wired or fibre connection since it is subject to interference and shares the available spectrum with other devices. You might have to contact your service provider to clarify your problem.

The dial on shows a speed range from 0 - 100, perhaps you meant a speed of 20 Mbps for your other devices.

Re: Poor wifi speed

Posted: Thu Aug 02, 2018 11:05 am
by SJM
Well, was showing 102mbps -- while my wife was using another device -- so I think the 200mbps connection to my house is functioning as intended.

I ran the test over wireless, on a tablet which was physically next to my computer. My desktop is consistently showing 0.5 mbps.

However, it shows 40-50 mbps if I use it tethered to my android phone.

Re: Poor wifi speed

Posted: Thu Aug 02, 2018 12:09 pm
by phd21

I just read your post and the good replies to it. Here are my thoughts on this as well.

Is this something new or has this always been this way with your wireless connections? If it is something new, it may be the newer Linux Kernel, try restarting into a slightly older kernel.

What are the wireless devices that you have used to test this with, a computer with a broadcom wireless adapter and a tablet? Your results show the computer's wireless is only running at 54mbps ( wireless "g" mode).

There are a few reasons this could be happening, some of which are easy to fix:
- Is the hardware router a wireless g/n/ac or the older and slower b/g? If all your wireless devices are wireless n/ac capable make sure the router is set to wireless n or n/ac not just "mixed".
- Make sure the hardware router is not close to sources of Interference like fluorescent lighting, power supplies, etc...
- Try changing the hardware router's wireless channel(s) because certain channels might be congested, used by many other nearby wireless routers and adapters. You will have to restart all computers and or devices or at least logout and back in.
- Distance from the hardware router can also affect the performance
- If you use a VPN provider's servers in either the hardware router or from desktop and other devices, try testing without using the VPN connection(s).

Another option could be the computer's wireless adapter driver is not the best one. FYI: "JeremyB" is one of the best with networking adapters and networking hardware diagnostics people in this forum. You can always get and try another USB WiFi adapter, they are not expensive.

Linux Mint Forums - Viewing profile - JeremyB

FYI-2: for comparison: The Internet connection plan that I am currently connected to is rated about 30mbps. My WiFi adapter (Ralink RT2870) is a 300mps USB WiFi adapter (wireless g/n) and the Network Manager is showing 162mbps and 91% signal strength. BTW: WiFi testing results tend to change, so run them and check the results like 3 times and use an average of those results.

There is no reason to pay extra for 200mbps Internet service if none of your Internet devices can use that much bandwidth; wired (Ethernet) connections using gigabytes adapters (10/100/1000) can use the extra bandwidth for media servers, etc...

Retrieving configuration...
Retrieving server list...
Selecting best server based on latency...
Testing download speed........................................
Download: 29.33 Mbit/s
Testing upload speed..................................................
Upload: 25.70 Mbit/s


wlx IEEE 802.11 ESSID:""
Mode:Managed Frequency:2.462 GHz Access Point: xx:xx:xx:xx:xx:xx
Bit Rate=216 Mb/s Tx-Power=20 dBm
Retry short long limit:2 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=70/70 Signal level=-29 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:167 Invalid misc:143862 Missed beacon:0

Hope this helps ...

Re: Poor wifi speed

Posted: Thu Aug 02, 2018 1:26 pm
by SJM
Hi Phd21, and thanks for that thoughtful reply.

It's a relatively recent thing. I'm not sure how to restart with an older kernel?

I have a 200mbps connection because there are several heavy internet users in my household. I'm realistically hoping to get 20-30 mbps per device.

I have tested it with an android tablet. I placed the android tablet physically right next to the computer and ran the app -- result, 40-50 mbps. Desktop was giving me 0.5 mbps.

I then tethered desktop to my android phone and got 20-30 mbps. I'm currently using it in this mode.

I think this proves that what's wrong is either a hardware or software issue with my linux desktop... doesn't it?

Re: Poor wifi speed

Posted: Thu Aug 02, 2018 1:51 pm
by phd21

You are welcome...

First, a Linux Kernel issue on a computer with Linux Mint would not affect the Android Tablet's performance, and from what you just said, it appears to not affect that. It appears to be a problem with the Linux computer's software (drivers) and or its hardware, but hardware router settings may still improve that.

Anyone using Linux Mint can boot into the advanced settings and choose another previous Linux Kernel to see if that is a problem. If you do not see a boot menu during bootup, try holding down the left or right shift keys, the Esc key, or the spacebar, then select advanced options and pick a previous Linux Kernel. When your system comes up, try testing the Internet connection again.

FYI: I installed a "speedtest" app that I run from the console terminal using the command "speedtest" instead of using a browser, but the browser works too.

speedtest-cli - Internet Speed Test In Linux Terminal ... x-terminal

Code: Select all

sudo apt-get install speedtest-cli
or using python

Code: Select all

pip install speedtest-cli
sivel/speedtest-cli: Command line interface for testing internet bandwidth using

Hope this helps ...

Re: Poor wifi speed

Posted: Thu Aug 02, 2018 1:58 pm
by rui no onna
kyphi wrote:
Wed Aug 01, 2018 6:31 pm
The dial on shows a speed range from 0 - 100, perhaps you meant a speed of 20 Mbps for your other devices.
Note, I think that might change based on your internet connection speed. Iirc, mine showed 0-150.

Re: Poor wifi speed

Posted: Sat Aug 04, 2018 2:35 am
by kyphi
rui no onna wrote:
Thu Aug 02, 2018 1:58 pm
Note, I think that might change based on your internet connection speed. Iirc, mine showed 0-150.
That is possible, however, below is a June summary of speeds attained in various centres throughout the world as measured by

You can get more detailed figures when you click on one of the locations. Is your location listed?

For me, shows my connection speed to be the same as speedtest-cli.

Re: Poor wifi speed

Posted: Sat Aug 04, 2018 3:06 am
by AZgl1500
do you have a 2nd WiFi router?

if so, hook it up to one of the LAN ports on the 1st one.

then put it on a channel far away from the 1st one.

you have a smartphone, download this app ... i.analyzer

and look to see what other WiFi signals are in your neighborhood.

I am betting you find some that are on the same channel you are using.

Move the router to a different channel, and if you can, log into the 5g band instead of the 2.4g band.

here are some pix of what it can show you. Note that I have 2 signals on the same channel.
The 2nd one is my Samsung SmartTV which is logged into the internet via the WiFi....
I need to get it off of WiFi and connect it to the LAN... it is causing Bit Error rates for me.



note that it also shows the 5gHz band, the one on the bottom. Wish my laptop supported 5g :cry:

Re: Poor wifi speed

Posted: Sun Aug 05, 2018 4:08 pm
by SJM
I don't have a second router. How do I move my router onto a different channel, please?

Re: Poor wifi speed

Posted: Sun Aug 05, 2018 7:48 pm
by AZgl1500
SJM wrote:
Sun Aug 05, 2018 4:08 pm
I don't have a second router. How do I move my router onto a different channel, please?
My router is provided by AT&T, but I have also noticed that my Buffalo router was pretty close to this info:

For modem Configuration:
try this on your router, it just might be the same. the last 3 digits are the only difference on any of them.

search Google for the router's model info.
it should give you the username: admin on some of mine, and the password is usually the same on all of them from the factory. that is the prime reason that when you get a new router, you should go into Admin functions and change the password immediately.

I just tried mine and it comes right back to me, but that is because I had my browser remember the ACCESS code.


After I got into the Admin function, you will be able to see:


info like that, and you can change the channel it is on.
Mine used to be on Channel 11, and I moved it to 1