[SOLVED] Lost WiFi after Kernel update.

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
ViliusNedz
Level 1
Level 1
Posts: 2
Joined: Wed Aug 08, 2018 10:26 am

[SOLVED] Lost WiFi after Kernel update.

Post by ViliusNedz » Wed Aug 08, 2018 10:35 am

Hello,
I am new with Linux.

After kernel update I have lost my WiFi. I have tried some stuff from forum. Some of these I think is:
viewtopic.php?f=150&t=227392
viewtopic.php?t=263651
viewtopic.php?t=256408
viewtopic.php?f=47&t=272192&p=1501822&h ... i#p1501822

Nothing helped. Then I have tried to wait till newest kernels be released. It also did not helped.

I cannot see WiFi icon in my panel bar.
Here is some information:
inxi -Fxz
Gives me this:

Code: Select all

System:    Host: vilius-Vostro-3560 Kernel: 4.15.0-29-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell product: Vostro 3560 v: A17
           Mobo: Dell model: 05GV6H v: A00 Bios: Dell v: A17 date: 04/14/2014
CPU:       Dual core Intel Core i5-3230M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10376
           clock speeds: max: 3200 MHz 1: 3181 MHz 2: 3042 MHz 3: 3071 MHz 4: 3122 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.01hz, 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 18.0.5 Direct Rendering: Yes
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-29-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 01:00.0
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Broadcom BCM43142 802.11b/g/n driver: bcma-pci-bridge bus-ID: 02:00.0
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 128.0GB (55.0% used) ID-1: /dev/sda model: Crucial_CT128MX1 size: 128.0GB
Partition: ID-1: / size: 110G used: 59G (56%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 8.46GB used: 0.22GB (3%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 55.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 3400
Info:      Processes: 221 Uptime: 18:41 Memory: 2618.8/7852.1MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
rfkill list all
gives me:

Code: Select all

1: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no
iwconfig
gives me:

Code: Select all

enp1s0    no wireless extensions.

lo        no wireless extensions.

docker0   no wireless extensions.
Can someone help me with WiFi?
Last edited by Moem on Thu Aug 09, 2018 5:40 pm, edited 1 time in total.
Reason: Marked this as [SOLVED] for you; please note that you can and should do this for your own topics. Thanks!

JeremyB
Level 19
Level 19
Posts: 9058
Joined: Fri Feb 21, 2014 8:17 am

Re: Lost WiFi after Kernerl update.

Post by JeremyB » Wed Aug 08, 2018 10:44 am


ViliusNedz
Level 1
Level 1
Posts: 2
Joined: Wed Aug 08, 2018 10:26 am

Re: Lost WiFi after Kernerl update.

Post by ViliusNedz » Wed Aug 08, 2018 11:28 am

Thanks. Worked. :)))

Jake_UK
Level 1
Level 1
Posts: 18
Joined: Sun Jan 09, 2011 3:09 pm
Location: UK

Re: Lost WiFi after Kernerl update.

Post by Jake_UK » Thu Aug 09, 2018 10:30 am

Thanks JeremyB - It also worked for me on an HP laptop I 'upgraded' by replacing Win10 with Mint XFCE! :lol:

Do you know if this issue is already logged with the kernel team and therefore hopefully will be work natively in the next (?) kernel update?

JeremyB
Level 19
Level 19
Posts: 9058
Joined: Fri Feb 21, 2014 8:17 am

Re: Lost WiFi after Kernel update.

Post by JeremyB » Thu Aug 09, 2018 4:37 pm

There are at least a dozen bug reports filed with Ubuntu now about this issue. The last I heard their fix was in the testing repositories

Jake_UK
Level 1
Level 1
Posts: 18
Joined: Sun Jan 09, 2011 3:09 pm
Location: UK

Re: [SOLVED] Lost WiFi after Kernel update.

Post by Jake_UK » Fri Aug 10, 2018 6:26 am

Great news, thanks again for the interim solution!

Post Reply

Return to “Wireless”