USB Wi-Fi Device Realtek RTL8811AU

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
After8Minty
Level 2
Level 2
Posts: 51
Joined: Wed Mar 07, 2018 7:08 am
Location: England

Re: USB Wi-Fi Device Realtek RTL8811AU

Post by After8Minty »

I am now trying a more recent adapter. It's a Wavlink AC1300 USB 3.0, backward compatible with USB 2.0 - still no joy though. :x

Bus 001 Device 008: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac WLAN Adapter
Bus 001 Device 003: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera
Bus 001 Device 009: ID 1d57:0008 Xenta
Bus 001 Device 006: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 007: ID 05e3:0718 Genesys Logic, Inc. IDE/SATA Adapter
Bus 001 Device 004: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 03f0:171d Hewlett-Packard Bluetooth 2.0 Interface [Broadcom BCM2045]
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

JeremyB
Level 20
Level 20
Posts: 11325
Joined: Fri Feb 21, 2014 8:17 am

Re: USB Wi-Fi Device Realtek RTL8811AU

Post by JeremyB »

Post results for

Code: Select all

iwconfig; ifconfig; dmesg | grep wlx

After8Minty
Level 2
Level 2
Posts: 51
Joined: Wed Mar 07, 2018 7:08 am
Location: England

Re: USB Wi-Fi Device Realtek RTL8811AU

Post by After8Minty »

iwconfig; ifconfig; dmesg | grep wlx
ens4 no wireless extensions.

wls2 IEEE 802.11 ESSID:"TALKTALK0DAC0E"
Mode:Managed Frequency:2.462 GHz Access Point: 70:0B:01:0D:AC:0B
Bit Rate=54 Mb/s Tx-Power=15 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=59/70 Signal level=-51 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:80 Missed beacon:0

lo no wireless extensions.

wlx803f5d11f069 unassociated Nickname:"<WIFI@REALTEK>"
Mode:Managed Frequency=5.18 GHz Access Point: Not-Associated
Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

ens4: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 00:1b:24:1e:f6:90 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 18 memory 0xda000000-da020000

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 1692 bytes 164491 (164.4 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1692 bytes 164491 (164.4 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wls2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.1.93 netmask 255.255.255.0 broadcast 192.168.1.255
inet6 fdaa:bbcc:ddee:0:dc0e:c9f1:5bbc:1884 prefixlen 64 scopeid 0x0<global>
inet6 fdaa:bbcc:ddee:0:219:d2ff:fe99:c6aa prefixlen 64 scopeid 0x0<global>
inet6 fe80::219:d2ff:fe99:c6aa prefixlen 64 scopeid 0x20<link>
ether 00:19:d2:99:c6:aa txqueuelen 1000 (Ethernet)
RX packets 7633 bytes 3098865 (3.0 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 5801 bytes 965220 (965.2 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlx803f5d11f069: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 80:3f:5d:11:f0:69 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 907 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

[ 38.439507] rtl8812au 1-7:1.0 wlx803f5d11f069: renamed from wlan0
[ 45.256581] IPv6: ADDRCONF(NETDEV_UP): wlx803f5d11f069: link is not ready
[ 45.804205] IPv6: ADDRCONF(NETDEV_UP): wlx803f5d11f069: link is not ready
[ 46.072513] IPv6: ADDRCONF(NETDEV_UP): wlx803f5d11f069: link is not ready
[ 50.092199] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 52.675399] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 58.661479] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 62.174955] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 68.356194] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 80.732852] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 93.706898] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 115.660694] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 128.844420] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 139.081061] IPv6: ADDRCONF(NETDEV_UP): wlx803f5d11f069: link is not ready
[ 727.991362] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 741.092269] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 803.236161] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 816.348246] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 831.700785] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 844.728108] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 856.105382] IPv6: ADDRCONF(NETDEV_UP): wlx803f5d11f069: link is not ready
[ 1150.789971] IPv6: ADDRCONF(NETDEV_UP): wlx803f5d11f069: link is not ready
[ 1150.844153] IPv6: ADDRCONF(NETDEV_UP): wlx803f5d11f069: link is not ready
[ 1239.098243] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 1241.723371] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 1247.372739] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 1250.927769] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 1257.168599] RTL871X: rtw_set_802_11_connect(wlx803f5d11f069) fw_state=0x00000008
[ 1264.962275] IPv6: ADDRCONF(NETDEV_UP): wlx803f5d11f069: link is not ready
[ 1283.144576] IPv6: ADDRCONF(NETDEV_UP): wlx803f5d11f069: link is not ready
[ 1283.202611] IPv6: ADDRCONF(NETDEV_UP): wlx803f5d11f069: link is not ready
[ 1288.014813] IPv6: ADDRCONF(NETDEV_UP): wlx803f5d11f069: link is not ready
[ 1288.061404] IPv6: ADDRCONF(NETDEV_UP): wlx803f5d11f069: link is not ready

JeremyB
Level 20
Level 20
Posts: 11325
Joined: Fri Feb 21, 2014 8:17 am

Re: USB Wi-Fi Device Realtek RTL8811AU

Post by JeremyB »

Lets try another way to disable IPv6.

Code: Select all

xed admin:///etc/default/grub
Go to the line that has "quiet splash", normally it is

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Change it to

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash ipv6. disable=1"
Save and exit then

Code: Select all

sudo update-grub
Reboot

After8Minty
Level 2
Level 2
Posts: 51
Joined: Wed Mar 07, 2018 7:08 am
Location: England

Re: USB Wi-Fi Device Realtek RTL8811AU

Post by After8Minty »

JeremyB Two screenshots that I took from Network Manager may help with this issue. The first represents the Realtek USB Adapter, the second is the onboard PCI Wi-Fi
Screenshot from 2019-12-08 19-29-04.jpg
Screenshot from 2019-12-08 19-29-04.jpg (8.31 KiB) Viewed 1143 times
Attachments
Screenshot from 2019-12-08 19-28-26.jpg
Screenshot from 2019-12-08 19-28-26.jpg (15.89 KiB) Viewed 1143 times

After8Minty
Level 2
Level 2
Posts: 51
Joined: Wed Mar 07, 2018 7:08 am
Location: England

Re: USB Wi-Fi Device Realtek RTL8811AU

Post by After8Minty »

In response to your last suggestion something weird happened. First an alert

xed admin:///etc/default/grub

** (xed:5231): WARNING **: 19:47:02.355: The specified location is not mounted

Then a prompt for my password, followed by the following text:-

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

JeremyB
Level 20
Level 20
Posts: 11325
Joined: Fri Feb 21, 2014 8:17 am

Re: USB Wi-Fi Device Realtek RTL8811AU

Post by JeremyB »

try

Code: Select all

sudo ifconfig wls2 down
See if the USB will connect, possibly unplug and plug back in.

Seeing that error in terminal is normal for xed admin:///etc/default/grub

After8Minty
Level 2
Level 2
Posts: 51
Joined: Wed Mar 07, 2018 7:08 am
Location: England

Re: USB Wi-Fi Device Realtek RTL8811AU

Post by After8Minty »

Alas JeremyB still no joy. In fact, I tried to come back on your last message but I lost the connection totally and had to reboot. I think I'll have to leave it for now, I am sorry that your efforts have not yielded the results we both hoped for and thank you for all the support your have been offering. I'll be back tomorrow and maybe it will work out. One thing I have noticed and that is the USB adapter does keep trying to connect ... signified by the intermittent flashing LED. Who knows, maybe better luck tomorrow. Thanks so much for giving me your time, I'm sure you won't let it beat you. :D

JeremyB
Level 20
Level 20
Posts: 11325
Joined: Fri Feb 21, 2014 8:17 am

Re: USB Wi-Fi Device Realtek RTL8811AU

Post by JeremyB »

Lets ditch this driver and try another

Code: Select all

sudo dkms remove rtl8812au/4.3.14 --all

Code: Select all

git clone https://github.com/aircrack-ng/rtl8812au.git
cd rtl8812au
sudo ./dkms-install.sh
Reboot

After8Minty
Level 2
Level 2
Posts: 51
Joined: Wed Mar 07, 2018 7:08 am
Location: England

Re: USB Wi-Fi Device Realtek RTL8811AU

Post by After8Minty »

You're a genius - it finally connects. There is another issue though, I can't manually switch off the PCI device without it cutting off the USB adapter, and the PCI device takes priority over the USB adapter. Is there a way round this? I have tried switching off the onboard device and re-booting but that doesn't solve it. The only way I can temporarily do this is to enter the code you previously suggested (sudo modprobe -r iwl3945) but when I reboot I think this will automatically restore the status quo.

JeremyB
Level 20
Level 20
Posts: 11325
Joined: Fri Feb 21, 2014 8:17 am

Re: USB Wi-Fi Device Realtek RTL8811AU

Post by JeremyB »

Blacklist the driver for the internal

Code: Select all

echo "blacklist iwl3945" | sudo tee /etc/modprobe.d/iwl3945.conf

After8Minty
Level 2
Level 2
Posts: 51
Joined: Wed Mar 07, 2018 7:08 am
Location: England

Re: USB Wi-Fi Device Realtek RTL8811AU

Post by After8Minty »

Brilliant! I have now rebooted and only the USB adapter shows in Network Manager but the onboard Wi-Fi LED is still displayed and if I manually switch it off I lose the network connection. However, I can live with that, I am so grateful to you for the time you have spent helping to get this sorted out ... many thanks! ISSUE SOLVED :D

Post Reply

Return to “Wireless”