Wifi adapter hard blocked <SOLVED>

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
rmeese5
Level 1
Level 1
Posts: 3
Joined: Sun Sep 09, 2018 1:22 pm

Wifi adapter hard blocked <SOLVED>

Post by rmeese5 » Sun Sep 09, 2018 4:22 pm

Hi all,

I am brand new to Linux. I had an old laptop that i wanted to give a different OS a shot. I installed LM19 and everything seems to work well except for my Realtek RTL8191SEvB. When I do rfkill it shows that it is hard blocked. I can toggle the soft block on with the keyboard but I cannot get the hard block to go away.

Code: Select all

rmeese5@rmeese5-Satellite-L655D:~$ inxi -Fxz
System:    Host: rmeese5-Satellite-L655D Kernel: 4.15.0-33-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: TOSHIBA product: Satellite L655D v: PSK2LU-001003 serial: N/A
           Mobo: AMD model: Guam serial: N/A
           BIOS: Insyde v: 2.00 date: 03/24/2011
Battery    BAT1: charge: 16.7 Wh 100.0% condition: 16.7/53.7 Wh (31%)
           model: Panasonic PA3817U-1BRS status: Full
CPU:       Dual core AMD Athlon II P320 (-MCP-) 
           arch: K10 rev.3 cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 8378
           clock speeds: max: 2100 MHz 1: 800 MHz 2: 1500 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250]
           bus-ID: 01:05.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1366x768@59.97hz
           OpenGL: renderer: AMD RS880 (DRM 2.50.0 / 4.15.0-33-generic, LLVM 6.0.0)
           version: 3.3 Mesa 18.0.5 Direct Render: Yes
Audio:     Card Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.15.0-33-generic
Network:   Card-1: Realtek RTL8191SEvB Wireless LAN Controller
           driver: rtl8192se port: 7000 bus-ID: 02:00.0
           IF: wlp2s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros AR8152 v1.1 Fast Ethernet
           driver: atl1c v: 1.0.1.1-NAPI port: 6000 bus-ID: 08:00.0
           IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 320.1GB (4.6% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABD0 size: 320.1GB
Partition: ID-1: / size: 289G used: 10G (4%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 704M used: 151M (24%) fs: ext4 dev: /dev/sda1
           ID-3: swap-1 size: 4.02GB used: 0.00GB (0%)
           fs: swap dev: /dev/dm-2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 65.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 183 Uptime: 6 min Memory: 1137.5/3684.7MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
Also this is what I get with iwconfig:
lo no wireless extensions.

enp8s0 no wireless extensions.

wlp2s0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry short limit:7 RTS thr=2347 B Fragment thr:off
Power Management:off

Any help to ween off of windows OS would be much appreciated. Also I am extreme noob to linux and these forums.
Last edited by rmeese5 on Sun Sep 09, 2018 10:18 pm, edited 2 times in total.

User avatar
Moem
Level 17
Level 17
Posts: 7010
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Wifi adapter hard blocked

Post by Moem » Sun Sep 09, 2018 4:26 pm

Most laptops have a toggle switch for wifi in a location that can be reached when the lid is closed. Could that be the case with yours too? You wouldn't be the first...
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

rmeese5
Level 1
Level 1
Posts: 3
Joined: Sun Sep 09, 2018 1:22 pm

Re: Wifi adapter hard blocked

Post by rmeese5 » Sun Sep 09, 2018 9:51 pm

Negative. The only wifi on off toggle is the fn f8 and that toggles the soft block. I installed from a flash drive and the computer downloaded language packs with the wifi during install... I did try to reset the bios as well with no luck. Also, there doesn't seem to be a way to enable/disable the wifi adapter from the bios..

rmeese5
Level 1
Level 1
Posts: 3
Joined: Sun Sep 09, 2018 1:22 pm

Re: Wifi adapter hard blocked <SOLVED>

Post by rmeese5 » Sun Sep 09, 2018 10:19 pm

I was able to solve this finally. I unplugged the laptop, took out the battery, and held the power button for 30 seconds. Upon reboot the wireless adapter worked. :P :oops: 8) Now it's time to explore this new OS.

User avatar
catweazel
Level 17
Level 17
Posts: 7741
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Wifi adapter hard blocked <SOLVED>

Post by catweazel » Sun Sep 09, 2018 10:30 pm

rmeese5 wrote:
Sun Sep 09, 2018 10:19 pm
I was able to solve this finally. I unplugged the laptop, took out the battery, and held the power button for 30 seconds. Upon reboot the wireless adapter worked. Now it's time to explore this new OS.
Have fun!
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

Post Reply

Return to “Wireless”