Linux Mint 18.3 wifi issue

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Kev1105
Level 1
Level 1
Posts: 49
Joined: Tue Mar 03, 2015 3:31 pm

Linux Mint 18.3 wifi issue

Post by Kev1105 » Tue Sep 18, 2018 6:50 pm

Lads

Hope your all good.

I am having and issue connecting to secured WiFi networks in Mint 18.3 XFCE .
I was running the latest kernel 4.15.0-34 I downgraded to 4.15.0-20 no change.
I can connect to open networks no issue.
Any Ideas?
Screenshot_2018-09-18_23-49-00.png

Kev1105
Level 1
Level 1
Posts: 49
Joined: Tue Mar 03, 2015 3:31 pm

Re: Linux Mint 18.3 wifi issue

Post by Kev1105 » Wed Sep 26, 2018 5:38 am

Well lads
This post has been sitting here a while. Any Ideas?

JeremyB
Level 19
Level 19
Posts: 9305
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint 18.3 wifi issue

Post by JeremyB » Wed Sep 26, 2018 6:03 am

See https://ubuntuforums.org/showthread.php ... st13614520 and make changes. I know Atheros wifi devices do not like WEP/TKIP encryption

Kev1105
Level 1
Level 1
Posts: 49
Joined: Tue Mar 03, 2015 3:31 pm

Re: Linux Mint 18.3 wifi issue

Post by Kev1105 » Wed Sep 26, 2018 6:18 am

Thanks for the reply.

I don't think that's the issue with that the 2 networks I tried were WP2/WPA and it seems to time out rather then connect.
I disabled the security and it connected no issue.
Could it be a user group I need to be added to, if so which?

JeremyB
Level 19
Level 19
Posts: 9305
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint 18.3 wifi issue

Post by JeremyB » Wed Sep 26, 2018 6:23 am

It could be the wifi power management, the first command in the link will stop that after rebooting

Kev1105
Level 1
Level 1
Posts: 49
Joined: Tue Mar 03, 2015 3:31 pm

Re: Linux Mint 18.3 wifi issue

Post by Kev1105 » Wed Sep 26, 2018 6:35 am

I've tried that editing that file but all that's in it are the lines

/etc/NetworkManager.conf

'[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false'

the WiFi power save settings are in another file
and that's just set to

'[connection]
wifi.powersave = 3'


I tried changing that value to 2/1 but no change

JeremyB
Level 19
Level 19
Posts: 9305
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint 18.3 wifi issue

Post by JeremyB » Wed Sep 26, 2018 4:53 pm

While connected to the wifi internet, encryption off do

Code: Select all

wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info && chmod +x wireless-info
Then turn encryption on, try to connect, then do

Code: Select all

./wireless-info
Disable encryption, connect and do

Code: Select all

cat wireless-info.txt | nc termbin.com 9999
Post URL from terminal

Kev1105
Level 1
Level 1
Posts: 49
Joined: Tue Mar 03, 2015 3:31 pm

Re: Linux Mint 18.3 wifi issue

Post by Kev1105 » Wed Sep 26, 2018 7:39 pm

Thanks Jeremy

The URL
http://termbin.com/pjfg

JeremyB
Level 19
Level 19
Posts: 9305
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint 18.3 wifi issue

Post by JeremyB » Thu Sep 27, 2018 10:31 am

See if you can connect to encrypted network after disabling UFW

Kev1105
Level 1
Level 1
Posts: 49
Joined: Tue Mar 03, 2015 3:31 pm

Re: Linux Mint 18.3 wifi issue

Post by Kev1105 » Thu Sep 27, 2018 7:32 pm

I tried that no good still behaves the same

JeremyB
Level 19
Level 19
Posts: 9305
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint 18.3 wifi issue

Post by JeremyB » Fri Sep 28, 2018 7:39 am

Go into Network Manager settings for the connection and set IPv6 to ignore/off

Kev1105
Level 1
Level 1
Posts: 49
Joined: Tue Mar 03, 2015 3:31 pm

Re: Linux Mint 18.3 wifi issue

Post by Kev1105 » Sat Sep 29, 2018 7:02 am

That worked,

But I can only do this for networks I previously connected to that were open
I can disable IpV6 ON WIFI connections totally?

JeremyB
Level 19
Level 19
Posts: 9305
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint 18.3 wifi issue

Post by JeremyB » Sat Sep 29, 2018 7:11 am

You could do

Code: Select all

gksu xed /etc/default/grub
Scroll down to the line that starts with GRUB_CMDLINE_LINUX_DEFAULT= and add ipv6.disable=1 inside the quotes

Most users would likely have GRUB_CMDLINE_LINUX_DEFAULT="quiet splash ipv6.disable=1"
Save, exit the editor and do

Code: Select all

sudo update-grub

Kev1105
Level 1
Level 1
Posts: 49
Joined: Tue Mar 03, 2015 3:31 pm

Re: Linux Mint 18.3 wifi issue

Post by Kev1105 » Wed Oct 03, 2018 3:31 pm

I did what you advised but there is still some networks it won't connect to
one is a Cisco modem transmitting 2.4GHZ and 5GHZ on the same SSID.

Any other suggestions?

Kev1105
Level 1
Level 1
Posts: 49
Joined: Tue Mar 03, 2015 3:31 pm

Re: Linux Mint 18.3 wifi issue

Post by Kev1105 » Sun Oct 21, 2018 5:19 pm

Any ideas?

JeremyB
Level 19
Level 19
Posts: 9305
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint 18.3 wifi issue

Post by JeremyB » Mon Oct 22, 2018 5:01 pm

If the Cisco transmitting on 2.4 and 5 GHz is on AC mode, the wireless card you have may not be able to connect as it isn't capable

Kev1105
Level 1
Level 1
Posts: 49
Joined: Tue Mar 03, 2015 3:31 pm

Re: Linux Mint 18.3 wifi issue

Post by Kev1105 » Thu Oct 25, 2018 2:54 pm

The thing is it connected to it before and now the Ethernet has stopped working
Eth0 is missing

JeremyB
Level 19
Level 19
Posts: 9305
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint 18.3 wifi issue

Post by JeremyB » Thu Oct 25, 2018 4:45 pm

You didn't have eth0, you had enp1s0 for ethernet interface. Did you happen to do a kernel update?

Kev1105
Level 1
Level 1
Posts: 49
Joined: Tue Mar 03, 2015 3:31 pm

Re: Linux Mint 18.3 wifi issue

Post by Kev1105 » Fri Oct 26, 2018 2:39 pm

I did through the update manager the latest 4.15.0-38
Is there a known bug?

JeremyB
Level 19
Level 19
Posts: 9305
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint 18.3 wifi issue

Post by JeremyB » Fri Oct 26, 2018 4:42 pm

Post results for

Code: Select all

dpkg -l | egrep 'linux-image|linux-modules'

Post Reply

Return to “Wireless”