<Solved> Linux Mint 19 can't find WI-Fi

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Fri Sep 28, 2018 8:39 pm

<Solved> Linux Mint 19 can't find WI-Fi

Post by TunePunch » Fri Sep 28, 2018 8:55 pm

i just recently installed linux mint 19 and of all the problems alongside the installation i think the wifi is the only one left.
i have seen a lot of posts in this forum about the same situation but i cant fix it by those methods.
So.... any ideas?

A big thank you in advance

Code: Select all

System:    Host: daniel-Lenovo-Legion-Y530-15ICH Kernel: 4.15.0-20-generic x86_64 bits: 64
           Desktop: Cinnamon 3.8.8  Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: LENOVO product: 81FV v: Lenovo Legion Y530-15ICH serial: N/A
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: N/A
           UEFI: LENOVO v: 8JCN44WW date: 08/13/2018
Battery    BAT0: charge: 26.2 Wh 49.0% condition: 53.4/52.5 Wh (102%)
CPU:       Quad core Intel Core i5-8300H (-MT-MCP-) cache: 8192 KB
           clock speeds: max: 4000 MHz 1: 1530 MHz 2: 2880 MHz 3: 3287 MHz 4: 3359 MHz 5: 3321 MHz 6: 3357 MHz
           7: 3398 MHz 8: 3367 MHz
Graphics:  Card-1: Intel Device 3e9b
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile]
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.16hz
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 version: 4.6.0 NVIDIA 396.54
Audio:     Card Intel Device a348 driver: snd_hda_intel Sound: ALSA v: k4.15.0-20-generic
Network:   Card-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter driver: ath10k_pci
           IF: wlp7s0 state: down mac: 50:5b:c2:dd:13:07
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: 8c:16:45:97:0d:85
Drives:    HDD Total Size: 1128.2GB (1.1% used)
           ID-1: /dev/nvme0n1 model: KBG30ZMT128G_TOSHIBA size: 128.0GB
           ID-2: /dev/sda model: ST1000LM049 size: 1000.2GB
Partition: ID-1: / size: 115G used: 6.4G (6%) fs: ext4 dev: /dev/sda3
           ID-2: swap-1 size: 6.07GB used: 0.00GB (0%) fs: swap dev: /dev/sda4
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 60.0C mobo: N/A gpu: 45C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 233 Uptime: 11 min Memory: 1187.7/7850.8MB Client: Shell (bash) inxi: 2.3.56 
if you need me to post anything else just say it.
Last edited by TunePunch on Sat Sep 29, 2018 6:46 am, edited 1 time in total.

Level 20
Level 20
Posts: 10134
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint 19 can't find WI-Fi

Post by JeremyB » Sat Sep 29, 2018 6:19 am

Do in terminal

Code: Select all

echo "blacklist ideapad-laptop" | sudo tee /etc/modprobe.d/ideapad-laptop.conf

Level 1
Level 1
Posts: 2
Joined: Fri Sep 28, 2018 8:39 pm

Re: Linux Mint 19 can't find WI-Fi

Post by TunePunch » Sat Sep 29, 2018 6:44 am

it worked. thank you so much. i might have saved my college years.

Post Reply

Return to “Wireless”