Wifi no longer working, ethernet does work

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
kingflash
Level 1
Level 1
Posts: 1
Joined: Sun Sep 30, 2018 12:35 am

Wifi no longer working, ethernet does work

Post by kingflash » Sun Sep 30, 2018 12:43 am

hello im a fairly new user of mint, i installed it on a old laptop from 2011 a dell latitude e6420 and it was working fine for about 5 days until I was trying to install a new browser using the terminal. I have no idea what happened but as soon as i tried booting up the new browser (brave) it would glitch and then my internet went away on mozilla. i tried rebooting, no internet. so i tried to reinstall the drivers and still no internet. i decided to just wipe and reinstall mint again. internet came back but i still had to reboot the laptop for the changes made after installation. as i rebooted it back up, internet is no longer working. same issue as before. i ran this in the terminal before i closed my laptop after 2 hours of searching for answers. thank you in advance. im still fairly new and im just wary of trying to install stuff on the terminal now.


System: Host: kingflash-Latitude-E6420 Kernel: 4.15.0-20-generic x86_64
bits: 64 gcc: 7.3.0
Desktop: MATE 1.20.1 (Gtk 3.22.30-1ubuntu1)
Distro: Linux Mint 19 Tara
Machine: Device: laptop System: Dell product: Latitude E6420 v: 01 serial: N/A
Mobo: Dell model: 0K0DNP v: A02 serial: N/A
BIOS: Dell v: A14 date: 07/11/2012
Battery BAT0: charge: 44.2 Wh 85.6% condition: 51.6/62.2 Wh (83%)
model: Samsung SDI DELL 5CGM428 status: Discharging
CPU: Dual core Intel Core i5-2540M (-MT-MCP-)
arch: Sandy Bridge rev.7 cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10376
clock speeds: max: 3300 MHz 1: 823 MHz 2: 1071 MHz 3: 888 MHz
4: 880 MHz
Graphics: Card: Intel 2nd Generation Core Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: x11 (X.Org 1.19.6 )
drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1600x900@60.00hz
OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile
version: 3.3 Mesa 18.0.0-rc5 Direct Render: Yes
Audio: Card Intel 6 Series/C200 Series Family High Def. Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network: Card-1: Intel 82579LM Gigabit Network Connection
driver: e1000e v: 3.2.6-k port: 4080 bus-ID: 00:19.0
IF: eno1 state: down mac: <filter>
Card-2: Broadcom Limited BCM43228 802.11a/b/g/n
driver: wl bus-ID: 02:00.0
IF: wlp2s0 state: dormant mac: <filter>
Drives: HDD Total Size: 282.0GB (5.5% used)
ID-1: /dev/sda model: TOSHIBA_MK2561GS size: 250.1GB
ID-2: USB /dev/sdb model: STORAGE_DEVICE size: 31.9GB
Partition: ID-1: / size: 229G used: 13G (6%) fs: ext4 dev: /dev/sda1
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 54.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 177 Uptime: 6 min Memory: 533.2/5839.8MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56

0: dell-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
1: dell-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
3: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
4: brcmwl-0: Wireless LAN
Soft blocked: no
Hard blocked: no

Post Reply

Return to “Wireless”