Google Wifi Router

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
jaydee920
Level 1
Level 1
Posts: 2
Joined: Mon Oct 01, 2018 6:21 pm

Google Wifi Router

Post by jaydee920 » Mon Oct 01, 2018 6:30 pm

Hey all. I have Mint installed onto a USB drive. I was using a TPLINK AC1200 router and all was fine. (Computer was a Older Dell with a Centrino WIFI card). After getting a new Google router it refuses to connect. After entering the password it tries to connect but then prompts for the password again. I took the usb out to a different computer with Mint installed on the HDD (working just fine) and booted off the USB. Same problem. It will not connect. I then updated to Mint 19 and still having the same issue. I have tried entering the bssid mac with no luck either. If I plug my old router back in it connects right away. I've tried searching around and found nothing related to Google wifi / Mint issues.

Thanks!

JeremyB
Level 19
Level 19
Posts: 9336
Joined: Fri Feb 21, 2014 8:17 am

Re: Google Wifi Router

Post by JeremyB » Mon Oct 01, 2018 6:51 pm

Check the new routers encryption settings, use WPA2-PSK with AES/CCMP without WEP/WPA/TKIP

jaydee920
Level 1
Level 1
Posts: 2
Joined: Mon Oct 01, 2018 6:21 pm

Re: Google Wifi Router

Post by jaydee920 » Mon Oct 01, 2018 7:16 pm

Sadly there are no options for this. The router is setup only through a phone app. No advanced settings at all. I was able to make it work with Mint 18.3 but any update passed this does not seem to work.

montg0w3n
Level 1
Level 1
Posts: 1
Joined: Mon Nov 19, 2018 12:33 pm

Re: Google Wifi Router

Post by montg0w3n » Mon Nov 19, 2018 10:20 pm

OP, did you ever find a solution to this problem? I also am having the same problem with Mint 19.

For a little more information, I connected earlier today at work with no problems (not a Google WiFi router). I came home and was unable to connect to my Google WiFi router through Mint 19. What I mean by not connect is that I am able to see the connection, enter the authentication information, but after 30 seconds or so, Network Manager prompts me for the authentication information again. I was able to turn my phone into a hotspot and connect to it (the phone is connected to the Google WiFi router, BTW). I tried manually editing the wireless network file under /etc/NetworkManager/system-connections as described here: https://productforums.google.com/forum/ ... ZGmcGT-ljk but I had no luck with this being an actual resolution.

JeremyB, the OP was unfortunately right, with this router we're unable to do any advanced customization to the security settings, but there must be a work around for it.

Post Reply

Return to “Wireless”