Cannot pair my headset via bluetooth [SOLVED]

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
wurstebruut
Level 1
Level 1
Posts: 2
Joined: Thu Oct 04, 2018 2:53 pm

Cannot pair my headset via bluetooth [SOLVED]

Post by wurstebruut » Thu Oct 04, 2018 3:07 pm

I am running mint 19 cinnamon on my desktop and I have usb bluetooth dongle. I can pair just fine out of the box with an audio device I have, and with my android phone.

However, I cannot pair up my Bowers & Wilkins PX headset for some reason. It just doesn't pair up. I tried both the default Bluetooth app, and blueman. When I trie to pair up via blueman I see it sends and recieves data like 3 times and then it just quits. I tried to remove the headset and scan again, but that didn't change anything.

I had the same problem with my laptop (also mint 19) and this headset and there this guide worked. But for my desktop this unfortunately doesn't do anything.

lsusb says this about the dongle:

Code: Select all

Bus 001 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Any ideas?
Last edited by wurstebruut on Thu Oct 04, 2018 4:19 pm, edited 1 time in total.

deepakdeshp
Level 11
Level 11
Posts: 3856
Joined: Sun Aug 09, 2015 10:00 am

Re: Cannot pair my headset via bluetooth

Post by deepakdeshp » Thu Oct 04, 2018 3:33 pm

  • uname -r
gives the kernel version you are running. Please make same kernel version in your desktop as per your laptop. After installing new kernel you have to reboot
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

wurstebruut
Level 1
Level 1
Posts: 2
Joined: Thu Oct 04, 2018 2:53 pm

Re: Cannot pair my headset via bluetooth

Post by wurstebruut » Thu Oct 04, 2018 4:19 pm

The kernel version is 4.15.0-36-generic on my desktop and 4.15.0-34-generic on my laptop.

However, somehow I already fixed it in the meantime. Based on some google searches I did the following commands:

Code: Select all

sudo hciconfig hci0 voice 0x0060

Code: Select all

pulseaudio -k
and

Code: Select all

pusleaudio
This made available the options 'headset', 'audiosink' and 'handsfree' in blueman-manager. At first that didn't work, but when I deleted the headset and then searched again, and then chose 'headset' instead of pairing suddenly everything works.

It is voodoo to me, I have no idea why or how that worked, but it did somehow.

Post Reply

Return to “Wireless”